AUR web interface

**This is the bug tracker for the AUR web interface.**

Use this tracker to report bugs or make feature requests regarding the behaviour or implementation of the AUR software.
Please read the Reporting Bug Guidelines before filing a new task.
https://wiki.archlinux.org/title/Bug_reporting_guidelines

- Please report bugs related to Arch Linux official packages here: http://bugs.archlinux.org/index.php?project=1
- Please report bugs for [community] packages here: http://bugs.archlinux.org/index.php?project=5
- For any packages in the AUR contact the maintainer or leave a comment on the package's detail page.

Source Code:
https://gitlab.archlinux.org/archlinux/aurweb/
Tasklist

FS#16887 - header.php not included when uploading a package fails (pkgsubmit.php)

Attached to Project: AUR web interface
Opened by mickael9 (mickael9) - Wednesday, 28 October 2009, 18:04 GMT
Last edited by Loui Chang (louipc) - Monday, 20 September 2010, 01:27 GMT
Task Type Bug Report
Category Backend
Status Closed
Assigned To Loui Chang (louipc)
Architecture All
Severity Very Low
Priority Normal
Reported Version 1.6.0
Due in Version 1.7.0
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

The title says it all, the header.php is not included, and you end up with a page without style.
I looked at the code, and I think the problem is related to the chdir($_SERVER['DOCUMENT_ROOT']) call that makes the header.php inclusion fail (wrong directory?)

easy fix : store the previous path with getcwd() instead of using $_SERVER['DOCUMENT_ROOT']
This task depends upon

Closed by  Loui Chang (louipc)
Monday, 20 September 2010, 01:27 GMT
Reason for closing:  Fixed
Additional comments about closing:  1.7.0
Comment by xyx (imagelife) - Friday, 30 October 2009, 11:28 GMT
yeah,these days I can't upload PKGBUILD with pkgsubmit.php,
please fix it :)
Comment by mickael9 (mickael9) - Friday, 30 October 2009, 18:11 GMT Comment by xyx (imagelife) - Saturday, 31 October 2009, 00:00 GMT
thx, I got it :)
Comment by mickael9 (mickael9) - Monday, 02 November 2009, 17:08 GMT
I don't get it, why you closed it ?
Comment by Roman Kyrylych (Romashka) - Monday, 02 November 2009, 17:09 GMT
ignore me, I got confused
Comment by Loui Chang (louipc) - Monday, 23 November 2009, 23:15 GMT
Fixed in git.
Comment by mickael9 (mickael9) - Saturday, 28 November 2009, 20:17 GMT
I can't see a commit that fixes this issue, are you sure it's commited?
Can you give me a link to the commit?
Comment by Loui Chang (louipc) - Saturday, 28 November 2009, 21:48 GMT
I guess I was a bit hasty in that assumption. It seems it's a web server configuration issue.
My local installation works fine, but aur.archlinux.org is configured differently.
It may be possible to fix this in code. I'll have to investigate.

The problem has to do with document-root changing:
http://redmine.lighttpd.net/wiki/1/Docs:ModSimpleVhost#Conditionals-vs-simple-vhost

Because of that header.php and footer.php aren't found.
Comment by mickael9 (mickael9) - Saturday, 28 November 2009, 22:48 GMT
What about the fix I mentioned ? Saving the current directory with getcwd() before calling chdir() then restoring it with chdir($saved_path);
I don't think relying on DOCUMENT_ROOT is a good idea, for example, one could install the AUR in a subdirectory.
Is it even necessary to chdir at all ?
Comment by mickael9 (mickael9) - Sunday, 07 March 2010, 19:42 GMT
No news on this ?
The bug is triggered by going to pkgsubmit.php and pressing Upload without filling any field.
I'm attaching a patch.
Comment by Loui Chang (louipc) - Saturday, 05 June 2010, 04:57 GMT

Loading...