Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#16881 - [policykit-gnome] manager registration failed (patch from fedora)

Attached to Project: Arch Linux
Opened by tuxce (tuxce) - Wednesday, 28 October 2009, 14:18 GMT
Last edited by Jan de Groot (JGC) - Wednesday, 28 October 2009, 14:25 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

When using polkit-gnome-authorization, window asking for password does not appear.

Additional info:
* package version(s)
policykit-gnome 0.9.2-4

Steps to reproduce:
Run polkit-gnome-authorization and try to edit an action:

** (polkit-gnome-authorization:15311): WARNING **: Caught error: Method "ObtainAuthorization" with signature "suu" on interface "org.freedesktop.PolicyKit.AuthenticationAgent" doesn't exist

And if you try to start agent:
$ LC_ALL=C /usr/lib/PolicyKit/polkit-gnome-manager
(polkit-gnome-manager:15328): PolicyKitGnome-DEBUG: Starting PolicyKit GNOME session daemon version 0.9.2

** (polkit-gnome-manager:15328): WARNING **: Object already registered at /org/gnome/PolicyKit/Manager, can't re-register at /
(polkit-gnome-manager:15328): PolicyKitGnome-DEBUG: Setting kill timer to 30 seconds.


bugs in Fedora bugtracker: https://bugzilla.redhat.com/show_bug.cgi?id=517257
patch: https://bugzilla.redhat.com/attachment.cgi?id=357302

After applying the patch, it works for me.

This task depends upon

Closed by  Jan de Groot (JGC)
Wednesday, 28 October 2009, 14:25 GMT
Reason for closing:  Duplicate
Additional comments about closing:  See  bug 16841 . I'd like to fix the regression instead of this bug.

Loading...