Arch Linux

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#16865 - [thinkfinger] issue with linux kernel > 2.6.28

Attached to Project: Arch Linux
Opened by Romain Boissat (rboissat) - Tuesday, 27 October 2009, 13:55 GMT
Last edited by Allan McRae (Allan) - Saturday, 16 June 2012, 07:53 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Francois Charette (Firmicus)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 3
Private No



When using thinkfinger and linux kernel > 2.6.28, the password prompt takes at least 5 seconds to appear.

The issue and patch are discussed there:

So far, applying this patch solved the problem in my case.

Additional info:
* package version(s): 0.3-2

Steps to reproduce:
- install the current thinkfinger package.
- run tf-tool --add-user <your_login> to generate bir file.
- follow to add sudo support.
- run: sudo -k && sudo -s.
This task depends upon

Closed by  Allan McRae (Allan)
Saturday, 16 June 2012, 07:53 GMT
Reason for closing:  No response
Comment by Romain Boissat (rboissat) - Monday, 02 November 2009, 12:16 GMT

Concerning this issue, I have been testing several values for USB_TIMEOUT inlibthinkfinger/libthinkfinger.c .
5 is quite too low, 50 seems perfect here.
Comment by Francois Charette (Firmicus) - Monday, 02 November 2009, 13:17 GMT
I have not noticed this issue on my T61, but I will happily test the patch (and the USB_TIMEOUT parameter) when I get a chance.
Comment by Romain Boissat (rboissat) - Monday, 02 November 2009, 14:52 GMT
Ok. For the record, I have a Lenovo X300.

It may be then hardware relative, here is some info about the fingerprint reader:

USB 00.0: 11600 Fingerprint Reader
[Created at usb.122]
UDI: /org/freedesktop/Hal/devices/usb_device_483_2016_noserial_if0
Unique ID: mZxt.2ZOIHS5Eja7
Parent ID: uIhY.MxUuepIFPaE
SysFS ID: /devices/pci0000:00/0000:00:1a.0/usb3/3-2/3-2:1.0
SysFS BusID: 3-2:1.0
Model: "SGS Thomson Microelectronics Fingerprint Reader"
Hotplug: USB
Vendor: usb 0x0483 "SGS Thomson Microelectronics"
Device: usb 0x2016 "Fingerprint Reader"
Revision: "0.01"
Speed: 12 Mbps
Module Alias: "usb:v0483p2016d0001dc00dsc00dp00icFFisc00ip00"
Config Status: cfg=new, avail=yes, need=no, active=unknown
Attached to: #4 (Hub)
Comment by Thomas Dziedzic (tomd123) - Thursday, 27 May 2010, 04:14 GMT
Comment by Francois Charette (Firmicus) - Thursday, 27 May 2010, 13:32 GMT
Well, I have tested this USB_TIMEOUT parameter long ago and did not notice any improvement, so as nobody complained since then, I did not touch the package, and then forgot to close this. If you can confirm that this would indeed be an improvement, I'll be glad to make the change.
Comment by archnewbie (archnewbie) - Thursday, 02 September 2010, 14:01 GMT
It takes realy horrible long.
Even if i do not want to use the fingerprint reader i have to wait.
Please also watch my reported bug about to fast password entering.
Comment by Greg (dolby) - Friday, 04 March 2011, 05:38 GMT
Has this been reported upstream? Although i dont think its so active..
Comment by Jan de Groot (JGC) - Monday, 17 October 2011, 14:47 GMT
Upstream is dead. We should consider removing this software in favour of something more developed like fprint. AFAIK we had this in our repositories, but I can't find it anymore.
Comment by Jelle van der Waa (jelly) - Tuesday, 13 March 2012, 11:33 GMT
any update?