Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#16818 - [gnome] 10-15 sec delay when starting a gnome-session for the first time

Attached to Project: Arch Linux
Opened by John (graysky) - Saturday, 24 October 2009, 11:14 GMT
Last edited by Jan de Groot (JGC) - Tuesday, 27 April 2010, 10:41 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 27
Private No

Details

Description: There is a 10-15 sec pause from the time I call xinit to when Gnome loads up. This is true whether I login via gdm or when I log in on tty1 and type xinit. This pause/lag/delay is only present the first time I log in. If I exit Gnome, then type xinit again, the Gnome desktop comes up in 2 sec flat. To reproduce the delayed startup, I have to reboot and login fresh.

I made a new user with no configs, extraneous programs in startup such as compiz, etc. to test this and found that the delay is not caused by some old dot file in my real user's home directory.

Additional info:
* package version(s)
System is up-to-date running Xorg packages, gnome, and gnome-extras. Sorry I can't pinpoint a particular package, but I dunno if this is a Gnome problem, or an Xorg problem, or neither!

* config and/or log files etc.

The ~/.xinit for the new user contains only one line
<code>
exec ck-launch-session gnome-session
</code>

Here is the output of the xinit
<code>
$ xinit

This is a pre-release version of the X server from The X.Org Foundation.
It is not supported in any way.
Bugs may be filed in the bugzilla at http://bugs.freedesktop.org/.
Select the "xorg" product for bugs you find in this release.
Before reporting bugs in pre-release versions please check the
latest version in the X.Org Foundation git repository.
See http://wiki.x.org/wiki/GitPage for git access instructions.

X.Org X Server 1.6.3.901 (1.6.4 RC 1)
Release Date: 2009-8-25
X Protocol Version 11, Revision 0
Build Operating System: Linux 2.6.30-ARCH x86_64
Current Operating System: Linux novelty 2.6.31-ARCH #1 SMP PREEMPT Tue Oct 13 11:33:39 CEST 2009 x86_64
Build Date: 04 September 2009 05:45:43PM

Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Sat Oct 24 06:47:02 2009
(==) Using config file: "/etc/X11/xorg.conf"
(EE) Microsoft NaturalR Ergonomic Keyboard 4000: failed to initialize for relative axes.

(gnome-settings-daemon:3367): GLib-GObject-CRITICAL **: g_param_spec_flags: assertion `G_TYPE_IS_FLAGS (flags_type)' failed

(gnome-settings-daemon:3367): GLib-GObject-CRITICAL **: g_object_class_install_property: assertion `G_IS_PARAM_SPEC (pspec)' failed
Window manager warning: Failed to read saved session file /home/archie/.config/metacity/sessions/10da13a8cbe06a5696125638122713119700000032940021.ms: Failed to open file '/home/archie/.config/metacity/sessions/10da13a8cbe06a5696125638122713119700000032940021.ms': No such file or directory
Unable to open desktop file evolution.desktop for panel launcher
** Message: Initializing gksu extension...
Initializing nautilus-image-converter extension

** (nautilus:3397): WARNING **: libeel-2.so.2: cannot open shared object file: No such file or directory
</code>


Steps to reproduce:

1) Start a gnome session and time how long the desktop takes to display
2) Log out and repeat step 1, you'll find that the first time took MUCH longer than the subsequent time
This task depends upon

Closed by  Jan de Groot (JGC)
Tuesday, 27 April 2010, 10:41 GMT
Reason for closing:  Not a bug
Additional comments about closing:  This is a configuration issue on the user system. Nonexistent floppydrives configured in BIOS cause timeouts on udisk startup because of floppydrive probing.
Comment by John (graysky) - Saturday, 24 October 2009, 11:18 GMT Comment by John (graysky) - Sunday, 25 October 2009, 19:00 GMT
Here is ~/.xsession-errors after I installed kdebase-workspace and started a kdesession. You'll notice that there are no GLib-GObject-CRITICAL entries which might be pointing the problem at Gnome, not xorg.

<code>
startkde: Starting up...
kdeinit4: preparing to launch /usr/lib/libkdeinit4_klauncher.so
kdeinit4: preparing to launch /usr/lib/libkdeinit4_kded4.so
kdeinit4: preparing to launch /usr/lib/libkdeinit4_kbuildsycoca4.so
kbuildsycoca4 running...
kdeinit4: preparing to launch /usr/lib/libkdeinit4_kbuildsycoca4.so
kbuildsycoca4 running...
kdeinit4: preparing to launch /usr/lib/libkdeinit4_kconf_update.so
Invalid D-BUS member name 'idle-hint' found in interface 'org.freedesktop.ConsoleKit.Session' while parsing introspection
Invalid D-BUS member name 'is-local' found in interface 'org.freedesktop.ConsoleKit.Session' while parsing introspection
Invalid D-BUS member name 'x11-display-device' found in interface 'org.freedesktop.ConsoleKit.Session' while parsing introspection
Invalid D-BUS member name 'x11-display' found in interface 'org.freedesktop.ConsoleKit.Session' while parsing introspection
Invalid D-BUS member name 'display-device' found in interface 'org.freedesktop.ConsoleKit.Session' while parsing introspection
Invalid D-BUS member name 'remote-host-name' found in interface 'org.freedesktop.ConsoleKit.Session' while parsing introspection
Invalid D-BUS member name 'session-type' found in interface 'org.freedesktop.ConsoleKit.Session' while parsing introspection
Invalid D-BUS member name 'unix-user' found in interface 'org.freedesktop.ConsoleKit.Session' while parsing introspection
X Error: XSyncBadAlarm 164
Extension: 146 (Uknown extension)
Minor opcode: 11 (Unknown request)
Resource id: 0x0
X Error: XSyncBadAlarm 164
Extension: 146 (Uknown extension)
Minor opcode: 11 (Unknown request)
Resource id: 0x0
kdeinit4: preparing to launch /usr/lib/libkdeinit4_kcminit_startup.so
kdeinit4: preparing to launch /usr/lib/libkdeinit4_ksmserver.so
<unknown program name>(3450)/ KStartupInfo::createNewStartupId: creating: "audacity;1256488862;168790;3450_TIME0" : "unnamed app"
kephald starting up
XRANDR error base: 174
RRInput mask is set!!
RandRScreen::loadSettings - adding mode: 325 1680 x 1050
RandRScreen::loadSettings - adding mode: 326 1400 x 1050
RandRScreen::loadSettings - adding mode: 327 1280 x 1024
RandRScreen::loadSettings - adding mode: 328 1280 x 1024
RandRScreen::loadSettings - adding mode: 329 1280 x 960
RandRScreen::loadSettings - adding mode: 330 1152 x 864
RandRScreen::loadSettings - adding mode: 331 1024 x 768
RandRScreen::loadSettings - adding mode: 332 1024 x 768
RandRScreen::loadSettings - adding mode: 333 1024 x 768
RandRScreen::loadSettings - adding mode: 334 832 x 624
RandRScreen::loadSettings - adding mode: 335 800 x 600
RandRScreen::loadSettings - adding mode: 336 800 x 600
RandRScreen::loadSettings - adding mode: 337 800 x 600
RandRScreen::loadSettings - adding mode: 338 800 x 600
RandRScreen::loadSettings - adding mode: 339 800 x 600
RandRScreen::loadSettings - adding mode: 340 800 x 600
RandRScreen::loadSettings - adding mode: 341 700 x 525
RandRScreen::loadSettings - adding mode: 342 700 x 525
RandRScreen::loadSettings - adding mode: 343 640 x 512
RandRScreen::loadSettings - adding mode: 344 640 x 512
RandRScreen::loadSettings - adding mode: 345 640 x 480
RandRScreen::loadSettings - adding mode: 346 640 x 480
RandRScreen::loadSettings - adding mode: 347 640 x 480
RandRScreen::loadSettings - adding mode: 348 640 x 480
RandRScreen::loadSettings - adding mode: 349 640 x 480
RandRScreen::loadSettings - adding mode: 350 640 x 480
RandRScreen::loadSettings - adding mode: 351 576 x 432
RandRScreen::loadSettings - adding mode: 352 512 x 384
RandRScreen::loadSettings - adding mode: 353 512 x 384
RandRScreen::loadSettings - adding mode: 354 512 x 384
RandRScreen::loadSettings - adding mode: 355 416 x 312
RandRScreen::loadSettings - adding mode: 356 400 x 300
RandRScreen::loadSettings - adding mode: 357 400 x 300
RandRScreen::loadSettings - adding mode: 358 400 x 300
RandRScreen::loadSettings - adding mode: 359 400 x 300
RandRScreen::loadSettings - adding mode: 360 320 x 240
RandRScreen::loadSettings - adding mode: 361 320 x 240
RandRScreen::loadSettings - adding mode: 362 320 x 240
RandRScreen::loadSettings - adding crtc: 323
RandRScreen::loadSettings - adding output: 324
Setting CRTC 323 on output "default" (previous 0 )
CRTC outputs: (324)
Output name: "default"
Output refresh rate: 50
Output rect: QRect(0,0 1680x1050)
Output rotation: 1
XRandROutputs::init
added output 324
adding an output 0 with geom: QRect(0,0 1680x1050)
output: "SCREEN-0" QRect(0,0 1680x1050) 1952543855 true true
load xml
connected: 1
looking for current "SCREEN-0"
known "*" has score: 0.125
screen: 0 QRect(0,0 1680x1050)
looking for a matching configuration...
connected: 1
looking for current "SCREEN-0"
known "*" has score: 0.125
found outputs, known: false
activate external configuration!!
registered the service: true
screens registered on the bus: true
outputs registered on the bus: true
configurations registered on the bus: true
kdeinit4: preparing to launch /usr/lib/libkdeinit4_kglobalaccel.so
kdeinit4: preparing to launch /usr/lib/libkdeinit4_plasma-desktop.so
kdeinit4: preparing to launch /usr/bin/knotify4
QDBusObjectPath: invalid path ""
QLayout: Attempting to add QLayout "" to QWidget "", which already has a layout
Object::connect: No such signal SystemTray::Manager::jobStateChanged(SystemTray::Job*)
Invalid D-BUS interface name 'org.kde.plasma-desktop.PlasmaApp' found while parsing introspection
kdeinit4: preparing to launch /usr/bin/kwrited
kdeinit4: preparing to launch /usr/lib/kde4/kio_trash.so
kdeinit4: preparing to launch /usr/lib/libkdeinit4_kaccess.so
<unknown program name>(3506)/ kdemain: Xlib XKB extension major= 1 minor= 0
kdeinit4: preparing to launch /usr/lib/libkdeinit4_krunner.so
kdeinit4: preparing to launch /usr/lib/libkdeinit4_nepomukserver.so
kdeinit4: preparing to launch /usr/lib/libkdeinit4_nepomukserver.so
Nepomuk server already running.
[/usr/bin/nepomukservicestub] (Soprano::PluginManager) found no soprano plugin at "/usr/lib/soprano/libsoprano_sesame2backend.so"
[/usr/bin/nepomukservicestub] (Soprano::PluginManager) found no soprano plugin at "/usr/lib/soprano/libsoprano_sesame2backend.so"
[/usr/bin/nepomukservicestub] (Soprano::Redland::BackendPlugin) creating model of type "hashes" with options "hash-type='bdb',contexts='yes',dir='/home/user/.kde4/share/apps/nepomuk/repository/main/data/redland'"
[/usr/bin/nepomukservicestub] (ServerCore) new socket connection.
[/usr/bin/nepomukservicestub] (ServerCore) new socket connection.
[/usr/bin/nepomukservicestub] (ServerCore) new socket connection.
[/usr/bin/nepomukservicestub] (ServerCore) new socket connection.
kdeinit4: preparing to launch /usr/lib/kde4/kio_trash.so
kdeinit4: preparing to launch /usr/bin/nepomukservicestub
kdeinit4: preparing to launch /usr/bin/nepomukservicestub
Unknown service name: 10dae3ef65000125648872200000031460006_1256488823_243624
kdeinit4: preparing to launch /usr/bin/nepomukservicestub
Unknown service name: 10dae3ef65000125648872200000031460007_1256488823_217426
kdeinit4: preparing to launch /usr/bin/nepomukservicestub
Unknown service name: 10dae3ef65000125648872200000031460008_1256488823_217245
kdeinit4: preparing to launch /usr/lib/libkdeinit4_klipper.so
QDBusObjectPath: invalid path ""
Unknown service name: 10dae3ef65000125648872200000031460009_1256488829_295359
"Warning: You do not seem to have the package gstreamer0.10-plugins-good installed.
Some video features have been disabled."
kdeinit4: preparing to launch /usr/bin/systemsettings
kdeinit4: preparing to launch /usr/bin/systemsettings
"Warning: You do not seem to have the package gstreamer0.10-plugins-good installed.
Some video features have been disabled."
QProcess: Destroyed while process is still running.
kdeinit4: Fatal IO error: client killed
kdeinit4: sending SIGHUP to children.
klauncher: Exiting on signal 1
kdeinit4: sending SIGTERM to children.
kdeinit4: Exit.
kglobalaccel: Fatal IO error: client killed
kdeinit4: Fatal IO error: client killed
kdeinit4: sending SIGHUP to children.
nepomukserver: Fatal IO error: client killed
kded4: Fatal IO error: client killed
kdeinit4: sending SIGTERM to children.
kdeinit4: Exit
</code>
Comment by Jan de Groot (JGC) - Tuesday, 22 December 2009, 10:12 GMT
Looking at the description, this looks normal to me. The first time you start GNOME, it does a lot of harddisk I/O. The 2nd time it loads all things from cache. If you see massive hdd activity during initial startup, this isn't a bug, but normal behaviour.
Comment by John (graysky) - Tuesday, 22 December 2009, 10:25 GMT
@JGC - There is minimal HDD activity during this pause. It just seems to hang for this time period.
Comment by Francisco Pina (Stunts) - Tuesday, 22 December 2009, 14:02 GMT
@JGC - I suffer from the very same bug, but I am using Readahead. I confirm that the HDD activity is minimal during this period.
Comment by Gert (naguz) - Friday, 08 January 2010, 23:12 GMT
I also have this problem. There is noe heavy hd activity here either. The bug started to bug me after upgrading to gnome 2.28, and it just seems like it takes a little nap before continuing.
Comment by John (graysky) - Saturday, 09 January 2010, 13:48 GMT
If you look at /home/user/.config/metacity/sessions/ it's empty. The permissions look fine for it, but whatever is trying to write that blah.ms file seems to be having problems. I'll bet this is the cause of the delay.
Comment by Jan de Groot (JGC) - Sunday, 21 February 2010, 13:06 GMT
Must be some autostartup thing on your system. I can't reproduce this, and now I switched my harddisk for an SSD, startup is instant here.
Comment by John (graysky) - Sunday, 21 February 2010, 14:38 GMT
@Jan - Can you post a screenshot or a list of your user's startup applications Preferences>Startup Applications.
Comment by Jan de Groot (JGC) - Sunday, 21 February 2010, 15:05 GMT
I'm running gnome 2.29.90 at this moment, so this list isn't representative for the stable release.

One thing makes me think though: do you have the hostname of your system listed in /etc/hosts? I remember GNOME doing lookups on your hostname at startup, not having your hostname in /etc/hosts could cause a huge slowdown.
Comment by John (graysky) - Sunday, 21 February 2010, 15:21 GMT
Yeah hostname is in there.... I'm running only the default startup stuff + gnomescreensaver + compiz (I have removed both of them and retested, the delay is STILL there). It's also there on a virgin user (one I freshly created).
Comment by Francisco Pina (Stunts) - Monday, 22 February 2010, 15:15 GMT
I can confirm that my /etc/hosts is correctly configured.
I have also been checking my "Startup Applications", and everything seems ok. I've also got Alunn on autostart tough.
Check your ~/.config/autostart . I had a lot of stuff there that I removed. I thought it could be the culprit, but I guess it's not.
Comment by John (graysky) - Monday, 22 February 2010, 20:27 GMT
@Francisco - I removed everything from my ~/.config/autostart and rebooted. Upon logging after the reboot, the lag is still present :(
Comment by Francisco Pina (Stunts) - Tuesday, 23 February 2010, 09:35 GMT
Here is my list of "Startup applications":
Alunn; /usr/lib/at-spi/at-spi-registryd; fusion-icon; /usr/lib/gnome-disk-utility/gdu-notification-daemon; gnome-keyring-daemon --start; /usr/bin/gnome-settings-daemon; /usr/lib/gnome-session/helpers/gnome-settings-daemon-helper; nm-applet --sm-disable; /usr/lib/polkit-gnome/polkit-gnome-authentication-agent-1; gnome-power-manager; system-config-printer-applet; gnome-screensaver; seahorse-daemon.
I experience the lag. Let's see what we've got in common, that JGC doesn't.
Comment by John (graysky) - Tuesday, 23 February 2010, 19:51 GMT
@Francisco - make a totally new user, reboot and log in as that user. With the default programs installed, do you experience the lag? I do.

# useradd -m -G users,audio,lp,optical,storage,video,wheel,power -s /bin/bash archie
# passwd archie
# reboot

login as archie through gdm

to remove archie just:

# userdel -r archie
Comment by Francisco Pina (Stunts) - Wednesday, 24 February 2010, 10:11 GMT
OK, here's what I've got:
A new user "archie" will log to desktop in about 4 secs.
Loging him out and back will decrease to about 3 secs. It's hardly noticable (and readahead is not caching any of archie's files, so the difference is perfectly justified).
Loging out archie and loging in as my main user, still causes the delay just as if I had just rebooted the computer.
Adding all the startup programs to "archie" as I have on my main user does not cause any additional delay (alunn, compiz, and a heavier GTK theme).
I hope these results help shed some light on the subject.
Comment by John (graysky) - Sunday, 28 February 2010, 10:42 GMT
OK! I installed x86_64 to a new partition and installed gnome. I started gdm and when I logged in **for the first time** I hit the desktop in 4 seconds flat. Subsequent logins took 1-2 sec. When I rebooted into my existing (older) install of Arch, the first time I log in takes 11 sec. Subsequent logins take 1-2 sec. Something is to blame here but I don't know what.

I get the same errors on the fresh install as I do on the older install. Here are gdm errors from the new install:

<code>
GNOME_KEYRING_SOCKET=/tmp/keyring-bs3WTc/socket
SSH_AUTH_SOCK=/tmp/keyring-bs3WTc/socket.ssh
GNOME_KEYRING_PID=3969

(gnome-settings-daemon:3965): GLib-GObject-CRITICAL **: g_param_spec_flags: assertion `G_TYPE_IS_FLAGS (flags_type)' failed

(gnome-settings-daemon:3965): GLib-GObject-CRITICAL **: g_object_class_install_property: assertion `G_IS_PARAM_SPEC
(pspec)' failed
Window manager warning: Failed to read saved session file
/home/user/.config/metacity/sessions/10c2f26a39e2abda77126726968583486300000039360018.ms: Failed to open file
'/home/user/.config/metacity/sessions/10c2f26a39e2abda77126726968583486300000039360018.ms': No such file or directory

(polkit-gnome-authentication-agent-1:4012): GLib-GObject-WARNING **: cannot register existing type `_PolkitError'

(polkit-gnome-authentication-agent-1:4012): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0'
failed
* Detected Session: gnome
* Searching for installed applications...
* NVIDIA on Xorg detected, exporting: __GL_YIELD=NOTHING
* Using the GTK Interface
* Starting Compiz
... executing: compiz --replace --sm-disable --ignore-desktop-hints ccp

(gnome-power-manager:4010): GLib-GObject-CRITICAL **: g_object_unref: assertion `G_IS_OBJECT (object)' failed

waiting for X server to shut down gnome-settings-daemon: Fatal IO error 11 (Resource temporarily unavailable) on X
server :0.0.
emerald: Fatal IO error 11 (Resource temporarily unavailable) on X server :0.0.
gnome-screensaver: Fatal IO error 11 (Resource temporarily unavailable) on X server :0.0.
XIO: fatal IO error 4 (Interrupted system call) on X server ":0.0"
after 4244 requests (4015 known processed) with 0 events remaining.
</code>
Comment by John (graysky) - Sunday, 04 April 2010, 12:55 GMT
Problem is worse now that I've upgraded to 2.30 :(
Comment by Alf (sege) - Sunday, 04 April 2010, 13:49 GMT
I'm having the same problem. It takes up to 15-20 sec before I can do anything.

This is my .xsession-errors:

/etc/gdm/Xsession: Beginning session setup...
/etc/gdm/Xsession: ssh-agent not found!
/etc/gdm/Xsession: Setup done, will execute: gnome-session
GNOME_KEYRING_CONTROL=/tmp/keyring-eJxfYF
GNOME_KEYRING_CONTROL=/tmp/keyring-eJxfYF
GNOME_KEYRING_CONTROL=/tmp/keyring-eJxfYF
SSH_AUTH_SOCK=/tmp/keyring-eJxfYF/ssh

(polkit-gnome-authentication-agent-1:3651): GLib-GObject-WARNING **: cannot register existing type `_PolkitError'

(polkit-gnome-authentication-agent-1:3651): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed

--------------

Before I upgraded to 2.30 there was just 2 "GNOME_KEYRING_CONTROL" lines. Now there is three.

I also got some new stuff in startup applications.

Before I had:
AT SPI Registry
Certificate and Key Storage
Disk Notifications
GNOME Settings Daemon
GNOME Settings Daemon Helper
PolicyKit Authentication Agent
Screenserver

Now I have:
AT SPI Registry
Certificate and Key Storage
Disk Notifications
GNOME Settings Daemon
GNOME Settings Daemon Helper
PolicyKit Authentication Agent
Screenserver
Secret Storage Service
SSH Key Agent

But it makes no difference if I turn them off.
Comment by Michael Kogan (Photon) - Sunday, 04 April 2010, 13:51 GMT
Try to remove (backup) ~/.gconf/desktop/gnome/session, it solved the problem to me though I don't know why.
Comment by Alf (sege) - Sunday, 04 April 2010, 14:01 GMT
I don't have any folder named session in ~/.gconf/desktop/gnome/
So there is nothing to remove. :(

Comment by Michael Kogan (Photon) - Sunday, 04 April 2010, 14:25 GMT
Looks like in my case it's another issue with the same symptoms. I had ca. 5s idle time on Gnome start, also there was an issue with Compiz start. In my case it helped to set ~/.gconf/desktop/gnome/session/required_components/windowmanager to "metacity" instead of "compiz" and the issue is gone (though not solved: now I have to start compiz via fusion-icon). See also here: http://bbs.archlinux.org/viewtopic.php?id=94304
Comment by Francisco Pina (Stunts) - Sunday, 04 April 2010, 14:38 GMT
The problem got worse for me with with the upgrade to gnome 2.30.
I have managed to turn it back to the way it was by setting ~/.gconf/desktop/gnome/session/required_components/windowmanager to "fusion-icon" instead of "compiz".
It's not solved tough. It just reduced the login time from 20 secs to 10.
Comment by Jonathan De Nil (ulukai) - Sunday, 04 April 2010, 14:41 GMT
I'm experiencing the same problem. Running Arch64 on a completely new PC. Did a fresh install of Arch + Gnome, only stable repos and fully updated. Everything worked fine untill I updated to gnome 2.30. With 2.28 I didn't have this issue. I just tried reinstalling, and have the same problem immediately. Also virgin users (newly created users, no modifications to profile) have it! Disabling all the startup programs - including Gnome's - don't help. I'm not using Compiz either, not even compositing at all.

On my work I have a laptop with an almost identical set of software: Arch + Gnome and quite a lot of the same apps and configurations, but there I don't have the problem. Only difference: it's 32 bit.

Can I provide some logs or test something? Please let me know! I would really like to help solving this bug.
Comment by John (graysky) - Sunday, 04 April 2010, 15:46 GMT
I have a full 30 second delay now under 2.30 when logging in for the first time (on a reboot). Subsequent logins are under 2 seconds. I am starting gdm by the inittab method if that matters....
Here is my ~/.xsession-errors

/etc/gdm/Xsession: Beginning session setup...
/etc/gdm/Xsession: Setup done, will execute: /usr/bin/ssh-agent -- gnome-session
GNOME_KEYRING_CONTROL=/tmp/keyring-yTOYIt
GNOME_KEYRING_CONTROL=/tmp/keyring-yTOYIt
SSH_AUTH_SOCK=/tmp/keyring-yTOYIt/ssh
GNOME_KEYRING_CONTROL=/tmp/keyring-yTOYIt
Window manager warning: Failed to read saved session file /home/user/.config/metacity/sessions/10e7ea58c72edf0cc5127039584473336800000041300020.ms: Failed to open file '/home/user/.config/metacity/sessions/10e7ea58c72edf0cc5127039584473336800000041300020.ms': No such file or directory

(polkit-gnome-authentication-agent-1:4192): GLib-GObject-WARNING **: cannot register existing type `_PolkitError'

(polkit-gnome-authentication-agent-1:4192): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed

(gnome-power-manager:4193): GLib-GObject-WARNING **: gsignal.c:2273: signal `proxy-status' is invalid for instance `0x23c9720'
Initializing nautilus-image-converter extension
** Message: Initializing gksu extension...
Comment by Francisco Pina (Stunts) - Sunday, 04 April 2010, 16:17 GMT
@John:
What happens if you start a different WM within your gnome session, such as openbox?
In your case it seems like metacity is looking for a file in a wrong place (unless your login name is "user").
Comment by John (graysky) - Sunday, 04 April 2010, 18:33 GMT
@stunts - I have (in the past) found this to be a gnome-only problem. Check this out: I rebooted and did a ctrl+alt+F1, then logged in as root and did a telinit 3, logged out then logged back in as my normal user, and did a startx, here is the output.

GNOME_KEYRING_CONTROL=/tmp/keyring-ufreq9
GNOME_KEYRING_PID=4151
GNOME_KEYRING_CONTROL=/tmp/keyring-ufreq9
GNOME_KEYRING_CONTROL=/tmp/keyring-ufreq9
SSH_AUTH_SOCK=/tmp/keyring-ufreq9/ssh
Window manager warning: Failed to read saved session file /home/user/.config/metacity/sessions/108e8c5390b72cd083127040563076447300000041360020.ms: Failed to open file '/home/user/.config/metacity/sessions/108e8c5390b72cd083127040563076447300000041360020.ms': No such file or directory

(polkit-gnome-authentication-agent-1:4190): GLib-GObject-WARNING **: cannot register existing type `_PolkitError'

(polkit-gnome-authentication-agent-1:4190): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed
* Detected Session: gnome

(gnome-power-manager:4191): GLib-GObject-WARNING **: gsignal.c:2273: signal `proxy-status' is invalid for instance `0x1537f20'
* Searching for installed applications...
Initializing nautilus-image-converter extension
** Message: Initializing gksu extension...
* NVIDIA on Xorg detected, exporting: __GL_YIELD=NOTHING
* Using the GTK Interface
* Starting Compiz
... executing: compiz --replace --sm-disable --ignore-desktop-hints ccp --indirect-rendering

(gnome-settings-daemon:4150): GVFS-RemoteVolumeMonitor-WARNING **: invoking IsSupported() failed for remote volume monitor with
dbus name org.gtk.Private.GduVolumeMonitor: org.freedesktop.DBus.Error.NoReply: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or
the network connection was broken.

Note that there is a LONG pause between the "executing: compiz..." line and the gnome-settings-daemon/GVFS-RemoteVolumeMonitor-WARNING. Could this be the source of the problem?

Please comment here or in this discussion thread: http://bbs.archlinux.org/viewtopic.php?pid=737295
Comment by Jonathan De Nil (ulukai) - Sunday, 04 April 2010, 19:15 GMT
It certainly isn't related to GDM, because I use Slim and have the problem too. Never even have installed Compiz, so no relation to that either.
What is really weird, is that it also affects new users. It must be a default value or bug in a certain package.

Is it only on Arch64 machines or also with 32 bit installs?
Are other distro's also affected?

Here is my slim.log:

slim: waiting for X server to begin accepting connections
This is a pre-release version of the X server from The X.Org Foundation.
It is not supported in any way.
Bugs may be filed in the bugzilla at http://bugs.freedesktop.org/.
Select the "xorg" product for bugs you find in this release.
Before reporting bugs in pre-release versions please check the
latest version in the X.Org Foundation git repository.
See http://wiki.x.org/wiki/GitPage for git access instructions.

X.Org X Server 1.7.5.902 (1.7.6 RC 2)
Release Date: 2010-03-12
X Protocol Version 11, Revision 0
Build Operating System: Linux 2.6.33-ARCH x86_64
Current Operating System: Linux arch64jon 2.6.32-ARCH #1 SMP PREEMPT Mon Mar 15 20:44:03 CET 2010 x86_64
Kernel command line: root=/dev/disk/by-uuid/40809f52-1830-4fec-8f71-9ac95d87731c ro
Build Date: 13 March 2010 07:35:38PM

Current version of pixman: 0.18.0
Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Sun Apr 4 20:06:19 2010
(==) Using config file: "/etc/X11/xorg.conf"
.
The XKEYBOARD keymap compiler (xkbcomp) reports:
> Warning: Type "ONE_LEVEL" has 1 levels, but <RALT> has 2 symbols
> Ignoring extra symbols
Errors from xkbcomp are not fatal to the X server
The XKEYBOARD keymap compiler (xkbcomp) reports:
> Warning: Duplicate shape name ""
> Using last definition
> Warning: Duplicate shape name ""
> Using last definition
> Warning: Duplicate shape name ""
> Using last definition
> Warning: Duplicate shape name ""
> Using last definition
> Warning: Duplicate shape name ""
> Using last definition
> Warning: Duplicate shape name ""
> Using last definition
> Warning: Duplicate shape name ""
> Using last definition
> Warning: Duplicate shape name ""
> Using last definition
> Warning: Duplicate shape name ""
> Using last definition
> Warning: Duplicate shape name ""
> Using last definition
> Warning: Duplicate shape name ""
> Using last definition
> Warning: Duplicate shape name ""
> Using last definition
> Warning: Duplicate shape name ""
> Using last definition
> Warning: Duplicate shape name ""
> Using last definition
> Warning: Multiple doodads named ""
> Using first definition
> Warning: Multiple doodads named ""
> Using first definition
> Warning: Multiple doodads named ""
> Using first definition
> Warning: Multiple doodads named ""
> Using first definition
> Warning: Multiple doodads named ""
> Using first definition
> Warning: Multiple doodads named ""
> Using first definition
Errors from xkbcomp are not fatal to the X server
/usr/bin/xauth: creating new authority file /home/jonathan/.Xauthority
GNOME_KEYRING_CONTROL=/tmp/keyring-mMTxue
GNOME_KEYRING_PID=1809
GNOME_KEYRING_CONTROL=/tmp/keyring-mMTxue
SSH_AUTH_SOCK=/tmp/keyring-mMTxue/ssh
GNOME_KEYRING_CONTROL=/tmp/keyring-mMTxue
SSH_AUTH_SOCK=/tmp/keyring-mMTxue/ssh
Window manager warning: Failed to read saved session file /home/jonathan/.config/metacity/sessions/10db1e87113842396127040440068895100000017760019.ms: Failed to open file '/home/jonathan/.config/metacity/sessions/10db1e87113842396127040440068895100000017760019.ms': No such file or directory

(polkit-gnome-authentication-agent-1:1843): GLib-GObject-WARNING **: cannot register existing type `_PolkitError'

(polkit-gnome-authentication-agent-1:1843): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed

(gnome-power-manager:1841): GLib-GObject-WARNING **: gsignal.c:2273: signal `proxy-status' is invalid for instance `0x1545710'
Comment by 甘露(Lu Gan) (ganlu) - Sunday, 04 April 2010, 23:43 GMT
I have the same problem, Wallpaper show almost immediately, then nothing, I just have to wait 10-15 seconds then panel and desktop icon appear, I have a working desktop at that time. is this related to nautilus?
Comment by Börje Holmberg (linfan) - Monday, 05 April 2010, 11:15 GMT
I do not use gdm or any other graphical login manager and I have not this lag, but on my friend's puter with gdm this lag is present - with the symptoms described above. I have run gconf-cleaner on my friend's computer, but it did not help. With that silly gdm you don't get them error msg when logging out. Maybe I should try running gnome from startx just to check.
I also noticed that once started gnome loads normally when logging in and out and also when changing users and logging in from gdm.
Comment by Jonathan De Nil (ulukai) - Monday, 05 April 2010, 13:23 GMT
I booted into runlevel 3 (no X) and did a startx from the shell. Still had the same problem without graphical login manager.
As proposed in this thread http://bbs.archlinux.org/viewtopic.php?pid=737295 I tried with this command too in .xinitrc: "exec ck-launch-session dbus-launch --auto-syntax --exit-with-session gnome-session" but it doesn't work either.
Comment by João Vieira (Vieira) - Monday, 05 April 2010, 15:52 GMT
Same problem. Compiz not installed, 32bits.
Comment by Jonathan De Nil (ulukai) - Tuesday, 06 April 2010, 07:35 GMT
Like I mentioned before, I didn't have this issue on my laptop, until today. I installed gnome-shell-git from AUR and when starting the shell via "gnome-shell --replace" I see the same phenomenom: only the desktop shows, it seems like my laptop is loading a bunch of stuff (hdd led lights up), then there is a pause of like 10 seconds (hdd led off) and then it lights up again and loads the remaining bits.

Would it have something to do with the packages gnome-shell depends on (especially clutter and the new gobject-stuff)?
Comment by Urfaust (Urfaust) - Tuesday, 06 April 2010, 19:01 GMT
Same Problem here. Arch 64 with Compiz starting via "Autostart without fusion-icon" http://wiki.archlinux.org/index.php/Compiz#Autostart_.28without_.22fusion-icon.22.29_2 and GDM with "inittab method".

.xsession-errors:

/etc/gdm/Xsession: Beginning session setup...
/etc/gdm/Xsession: Setup done, will execute: /usr/bin/ssh-agent -- gnome-session
GNOME_KEYRING_CONTROL=/tmp/keyring-pa0bza
GNOME_KEYRING_PID=4440
GNOME_KEYRING_CONTROL=/tmp/keyring-pa0bza
SSH_AUTH_SOCK=/tmp/keyring-pa0bza/ssh
GNOME_KEYRING_CONTROL=/tmp/keyring-pa0bza
SSH_AUTH_SOCK=/tmp/keyring-pa0bza/ssh
Warnung der Fensterverwaltung:Gespeicherte Sitzungsdatei /home/urfaust/.config/metacity/sessions/10cb1f7aa18a55a9e5127057720213482000000043840029.ms konnte nicht gelesen werden: Datei »/home/urfaust/.config/metacity/sessions/10cb1f7aa18a55a9e5127057720213482000000043840029.ms« konnte nicht geöffnet werden: Datei oder Verzeichnis nicht gefunden

(polkit-gnome-authentication-agent-1:4488): GLib-GObject-WARNING **: cannot register existing type `_PolkitError'

(polkit-gnome-authentication-agent-1:4488): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed
Arbeitsflächen-Datei evolution.desktop konnte nicht für Panel-Starter geöffnet werden

(gnome-power-manager:4490): GLib-GObject-WARNING **: gsignal.c:2273: signal `proxy-status' is invalid for instance `0x1c81b30'
** Message: Initializing gksu extension...

(nautilus:4475): GdkPixbuf-CRITICAL **: gdk_pixbuf_format_get_name: assertion `format != NULL' failed
set zoom: 1,00
Warnung der Fensterverwaltung:Ungültiges WM_TRANSIENT_FOR-Fenster 0x340009a festgelegt für 0x34000bd (/media/nsa).
Found Metastream: KPX_CUSTOM_ICONS_4
Found Metastream: KPX_GROUP_TREE_STATE
Comment by Jonathan De Nil (ulukai) - Thursday, 08 April 2010, 11:38 GMT
Is there any progress from the devs on this issue? Has it been reproduced already? Do you need more logs?
Should we file a bug with gnome or is it Arch related?
Comment by Jonathan De Nil (ulukai) - Monday, 12 April 2010, 11:30 GMT
Updated to newest versions incl. 2.6.33 kernel, still having same problem... :(
Comment by Stefan Linn (SteLi) - Monday, 12 April 2010, 12:02 GMT
I don't think that it is related to kernel version, x-server or login manager (gdm or xdm). More likely it is an bug of gnome-session. By the way, it appeared first time with my computer when upgrading to gnome 2.30 by the end of March, not before. In another blog I saw some considerations on TCP port 6000 as possible reason but I could not find the article again.
Regards, Stefan L.
Comment by Jonathan De Nil (ulukai) - Monday, 12 April 2010, 12:41 GMT
Updated to newest versions incl. 2.6.33 kernel, still having same problem... :(

EDIT: Sorry for double post, something went wrong refreshing the page.
Comment by Spyros Stathopoulos (Foucault) - Monday, 12 April 2010, 17:05 GMT
This happens for me as well. No compiz, no compositing. Gnome stalls for 10-15 secs during which there is *constant* disk activity (so no surprise that an SSD loads very fast). I noticed that even from the very first time I installed gnome with no additional configuration. I'm using SLIM as my login manager but same happens with GDM as well. Second login is lightning fast of course (cache?). Possibly relevant /var/log/slim.log data follows...

=====================8<==========================
X.Org X Server 1.7.6
Release Date: 2010-03-17
X Protocol Version 11, Revision 0
Build Operating System: Linux 2.6.33-ARCH x86_64
Current Operating System: Linux pendulum 2.6.33-ARCH #1 SMP PREEMPT Sun Apr 4 10:27:30 CEST 2010 x86_64
Kernel command line: root=/dev/disk/by-uuid/3decde7f-4ccc-4a78-8a6f-46d9bff12558 vga=791 ro
Build Date: 01 April 2010 05:28:33PM

Current version of pixman: 0.18.0
Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Mon Apr 12 19:51:22 2010
(==) Using config file: "/etc/X11/xorg.conf"
/usr/bin/xauth: creating new authority file /home/foucault/.Xauthority
GNOME_KEYRING_CONTROL=/tmp/keyring-L568EH
GNOME_KEYRING_PID=1838
GNOME_KEYRING_CONTROL=/tmp/keyring-L568EH
SSH_AUTH_SOCK=/tmp/keyring-L568EH/ssh
GNOME_KEYRING_CONTROL=/tmp/keyring-L568EH
SSH_AUTH_SOCK=/tmp/keyring-L568EH/ssh

(polkit-gnome-authentication-agent-1:1877): GLib-GObject-WARNING **: cannot register existing type `_PolkitError'

(polkit-gnome-authentication-agent-1:1877): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed
=====================>8==========================

Comment by Jonathan De Nil (ulukai) - Tuesday, 13 April 2010, 07:59 GMT
If this would be a gnome-session bug, then every distro with gnome 2.30 would be suffering of this, right?
I tried it with a daily build of Ubuntu 10.04 and ther problem is not there.

Maybe the way this package is compiled for Arch?
Comment by Francisco Pina (Stunts) - Tuesday, 13 April 2010, 08:07 GMT
OK, so this seems to be the part that is common to all of us:

GNOME_KEYRING_CONTROL=/tmp/keyring-L568EH
GNOME_KEYRING_PID=1838
GNOME_KEYRING_CONTROL=/tmp/keyring-L568EH
SSH_AUTH_SOCK=/tmp/keyring-L568EH/ssh
GNOME_KEYRING_CONTROL=/tmp/keyring-L568EH
SSH_AUTH_SOCK=/tmp/keyring-L568EH/ssh

There have been some bugs recently regarding Gnome Keyring that introduced some lag (in shutdown if my memory is not failing me). Is there anyway to start a gnome session without the keyring?
Or alternatively is there a way to measure how long it takes between the writing of each line in .xsession-errors (eg. timestamped log)?
Comment by Francisco Pina (Stunts) - Tuesday, 13 April 2010, 08:13 GMT
@ulukai:
The thing is that for some of us this bug has been present since at least Gnome 2.26.
I remember this bug also being present in Ubuntu, but somewhere along the way it got corrected.
Maybe we could learn something from the patches they apply?
http://packages.ubuntu.com/karmic/gnome-session
http://packages.ubuntu.com/karmic/gnome-session-bin
http://packages.ubuntu.com/lucid/gnome-session
http://packages.ubuntu.com/lucid/gnome-session-bin

I believe the patches can be found on these links. Can anyone more experienced than me take a look please?
Comment by Jonathan De Nil (ulukai) - Tuesday, 13 April 2010, 08:42 GMT
Thanks Francisco, you have some good ideas.

When you go to system - preferences - startup applications, you can disable a bunch of keyring services, but it makes no difference to me.
Googling for timestamped logs didn't give me any possibilities.

Unfortunately my knowledge of the patch files is not sufficient either :( I'm willing to try things out, but I'm lacking experience in this.
Comment by Francisco Pina (Stunts) - Tuesday, 13 April 2010, 10:17 GMT
Here is some more info:
https://bugs.launchpad.net/ubuntu/+source/udisks/+bug/551712
I don't think this was the bug report I had read earlier, but it also seems to be the same problem. There are also come references to gnome keyring, although the culprit here seemed to be a non-existing floppy drive...
Comment by Jonathan De Nil (ulukai) - Tuesday, 13 April 2010, 10:43 GMT
Just read through the ubuntu bug report you posted, it might just solve my problem: Gnome shows me a non-existent floppy drive in Nautilus although it is disabled in fstab. So the BIOS might be the cause of trouble of this and the login delay.

Will try tonight at home when I'm at my PC, i'm working atm :) Thank you for the hint.
Comment by Michael Kogan (Photon) - Tuesday, 13 April 2010, 11:26 GMT
Concerning gnome-keyring: I have another problem with it. When I open pdf files with a password evince sometimes crashes. Maybe a related issue?
Comment by 甘露(Lu Gan) (ganlu) - Tuesday, 13 April 2010, 13:31 GMT
To Jonathan De Nil (ulukai): if it's related to non-existing floppy why relogin goes so fast? And I confirm the Fedora 13 beta has the almost same problem here.
Comment by 甘露(Lu Gan) (ganlu) - Tuesday, 13 April 2010, 13:51 GMT
I disabled non-existing floppy in BIOS, but it doesn't help.
Comment by Jonathan De Nil (ulukai) - Tuesday, 13 April 2010, 13:53 GMT
@ ganlu: I've been working at a IT service desk for several years now and if there's one thing I've learnt over the years, it is that problems can't always be solved by logic ;-) Sometimes you can expect the unexpected. Eager to try it tonight ^^
Comment by Jonathan De Nil (ulukai) - Tuesday, 13 April 2010, 18:21 GMT
Hello all,

I have disabled the floppy drive in my BIOS (since I have none installed) and it got me rid of the login delay.
Thanks to anyone for helping me out, expecially to Francisco Pina for the information of the non-existing floppy drive :)

For those of you that still have the issue and you disabled the floppy drive in BIOS, do you also have it disabled in fstab?
Comment by Francisco Pina (Stunts) - Tuesday, 13 April 2010, 20:18 GMT
You are very welcome ulukai. I'm glad I could help.
However, this does not solve the problem for me as in my laptops there is no BIOS option regarding the floppy drives.
How long does your login take now? Is the first login as fast as any subsequent logins?
I'm still going to research further the gnome keyring issue... Anyone took a look at those patches yet?
Comment by Stefan Linn (SteLi) - Tuesday, 13 April 2010, 20:36 GMT
Thanks to ulukai as well! Disabling the floppy from bios did made the job, both on my computer and on that of my mother in law, which is even more important as all her windows using friends are keen on hearing about "problems" with linux systems. Some more details for further bug tracing: I had no hard disk activity during the "sleeping time" and removing of all key-ring-related issues from gnome start up did not help. And very strange: On the computer the screen was simply gray during "sleeping phase", while on the other system at least the wallpaper appeared.
Comment by Jonathan De Nil (ulukai) - Wednesday, 14 April 2010, 06:19 GMT
@Francisco: First login is a couple of seconds longer than the subsequent logins because all data is read from the HDD into memory. But there is no moment where there is no disc activity anymore. Subsequent logins are read from memory and there is almost no HDD activity, so it will always be faster. So first login from Slim to loaded desktop = 4-5 seconds, subsequent logins = 1-2 seconds.

@Stefan: One of my machines also displays grey screen during loading session and wallpaper only comes when the panels appear, but my other machine displays the wallpaper immediately when session is still loading. Don't know why and it's not a problem to me. As long as the loading is fast I'm happy :)
Comment by Jeroen van der Wal (Jayden) - Wednesday, 14 April 2010, 16:00 GMT
Disabling the floppy drive in the bios did the trick.
Comment by Jan de Groot (JGC) - Wednesday, 14 April 2010, 16:12 GMT
Having a CD in your drive might also cause slowdowns for a while, but you'll notice the spinning CD drive in that case.
Comment by David Couzelis (drcouzelis) - Wednesday, 14 April 2010, 17:33 GMT
Now that we have an idea for a workaround (disable the floppy drive in the BIOS), can we find whatever Ubuntu does to fix this? Is GNOME checking for a floppy drive, or could it be a problem with HAL or something similar instead?
Comment by Jan de Groot (JGC) - Wednesday, 14 April 2010, 17:37 GMT
gnome-session launches startup processes one after the other until they're all finished. Ubuntu has patched their GNOME to support delayed startup, meaning that anything that blocks loading the desktop can be deferred for later startup.
Comment by Alf (sege) - Wednesday, 14 April 2010, 20:06 GMT
Disabling the floppy in bios works for me too. :)
Comment by John (graysky) - Thursday, 15 April 2010, 00:08 GMT
No floppy drive at all in my system (disabled in BIOS) but delay is still there :(
Comment by João Vieira (Vieira) - Thursday, 15 April 2010, 02:15 GMT
Disabling floppy drive in BIOS is no solution for me either.
Comment by Alf (sege) - Thursday, 15 April 2010, 17:35 GMT
graysky and Viera: Have you tried to blacklist floppy in the hardware section in rc.conf? I know I had to do that with Fedora 11 (Disable in bios and blacklist).

In "MODULES" you should type !floppy = MODULES=(!floppy)

That's what made it work for me.
Comment by John (graysky) - Thursday, 15 April 2010, 20:26 GMT
@Alf - blacklisting the floppy module as you suggested DID in fact speed up the initial log in. It now takes approx 10 sec to log in for the first time. Thank you! Still, that 10 sec wait is about 10x longer than it takes to login after I have logged out; it literally goes from the GDM screen to my desktop in 1 second flat after my initial login.

Here is the ~/.xsession-errors with the floppy kernel module blacklisted:

/etc/gdm/Xsession: Beginning session setup...
/etc/gdm/Xsession: Setup done, will execute: /usr/bin/ssh-agent -- gnome-session
GNOME_KEYRING_CONTROL=/tmp/keyring-POCXNd
GNOME_KEYRING_CONTROL=/tmp/keyring-POCXNd
GNOME_KEYRING_CONTROL=/tmp/keyring-POCXNd
SSH_AUTH_SOCK=/tmp/keyring-POCXNd/ssh
Window manager warning: Failed to read saved session file /home/username/.config/metacity/sessions/10d1f754065734eb35127136303240452400000041220020.ms: Failed to open file '/home/username/.config/metacity/sessions/10d1f754065734eb35127136303240452400000041220020.ms': No such file or directory

(polkit-gnome-authentication-agent-1:4211): GLib-GObject-WARNING **: cannot register existing type `_PolkitError'

(polkit-gnome-authentication-agent-1:4211): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed

(gnome-power-manager:4212): GLib-GObject-WARNING **: gsignal.c:2273: signal `proxy-status' is invalid for instance `0x23ba720'
Initializing nautilus-image-converter extension
** Message: Initializing gksu extension...
Comment by Francisco Pina (Stunts) - Thursday, 15 April 2010, 20:55 GMT
I am in the same situation as graysky.
I always have high disk activity, but the 1st login takes 10 seconds and subsequent logins take about 2 seconds. Is it really designed to be like this? I'm using readahead, I think this was not supposed to happen with readahead.
Also, this workaround is working for some people, maybe it should be added to the wiki?
Comment by John (graysky) - Thursday, 15 April 2010, 23:55 GMT
@stunts - We (and you too) are all authors of the wiki. If you feel something adds value by all means edit a page with the info!
Comment by Francisco Pina (Stunts) - Friday, 16 April 2010, 08:54 GMT
@graysky:
Thank you for your wake-up call. I made my first wiki edit... =-)

http://wiki.archlinux.org/index.php/Gnome_2.28_Changes
Comment by Marius Ladegård Meyer (mariusmeyer) - Saturday, 24 April 2010, 22:07 GMT
Disabling in BIOS and !ing floppy in MODULES did the trick for me.
Comment by Spyros Stathopoulos (Foucault) - Saturday, 24 April 2010, 22:10 GMT
Yes, disabling floppy from BIOS and not loading the floppy module does help. Still the login does not fly, but there is a distinct 25-30% increase in login time.

Loading...