Arch Linux

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#16787 - kde 4.3.2 stuck at screwdriver in spalshscreen

Attached to Project: Arch Linux
Opened by Carlos Lorenzo Matés (clmates) - Thursday, 22 October 2009, 20:03 GMT
Last edited by Andrea Scarpino (BaSh) - Tuesday, 03 November 2009, 18:39 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Pierre Schmitz (Pierre)
Andrea Scarpino (BaSh)
Architecture x86_64
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No



kde new version dont finish to start it get stuck at splash screen (second icon, screwdriver)

(please read discussion on forum: )

I have readed in the nvidia forum something similar, but they related kde working if start with the nv or vesa driver, but in my test this fails also

so I dont know what to test

any help appreciated

This task depends upon

Closed by  Andrea Scarpino (BaSh)
Tuesday, 03 November 2009, 18:39 GMT
Reason for closing:  Not a bug
Additional comments about closing:  not related to KDE
Comment by ray (Chrysalis) - Thursday, 29 October 2009, 06:09 GMT
What about your xorg.conf? kwin can be picky with some gpu options... and have you tried without a xorg.conf?

Also, inittab is recommended to start kdm and not rc.conf, ive seen some weird stuff fixed after people had switched.

Just throwing out some ideas while passing by :)
Comment by jussi haverinen (klikklak) - Friday, 30 October 2009, 00:07 GMT
I'm facing the same error. Mine however also includes hard crashes when trying to run kdm with multiple monitors. With two it starts, but the other one doesn't show anything. My report is in forums DE, multihead not working with 2.6.31 and nvidia 185. With all the relevant files.
Comment by Carlos Lorenzo Matés (clmates) - Monday, 02 November 2009, 18:27 GMT
tested without xorg.conf = fails the same

tested from initab and from xterm startkde = fails the same

tested to recompile the latest nvidia drivers using abs = fails the same

tested to start kde, list the process runing with ps axuf then kill processes one by one from bottom to top at some point after killing the 2 kbuildsyscoca4 and the kded4 and the kconf_update and a plasma_desktop (there was 2 running), the kde comes up, and seems fully functional. but if I clses session it never closes again cpu full with a new pair of kbuildsyscoca4 a kded and a plasma_desktop

and if I reboot and try to start it again, the same hunged processes, seems an endless loop


Comment by Gerardo Exequiel Pozzi (djgera) - Monday, 02 November 2009, 22:28 GMT
Please use attachs next time. This task is very very difficult to read.
Comment by Carlos Lorenzo Matés (clmates) - Tuesday, 03 November 2009, 18:37 GMT
Downloading the nvidia drivers from the nvidia website (or using the ones downloaded by the official packages), but installed by running the nvidia executable instead of using pacman fixed the issue, so you can close this case.

Summary: installing the Nvidia oficial drivers by running the executable instead of using pacman fixed this error