Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#16772 - [deluge] Split package or make the GTK stuff optdepends

Attached to Project: Arch Linux
Opened by JD (jdhore) - Wednesday, 21 October 2009, 18:31 GMT
Last edited by Ionut Biru (wonder) - Monday, 11 January 2010, 19:35 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Hugo Doria (hdoria)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 4
Private No

Details

Description:

Deluge doesn't require pygtk and pyxdg and librsvg to build since it can run as a daemon, a console client and a WebUI, none of which depend on any of those packages and if you want to run say just the daemon on a server, thats a lot of extra dependencies for the GTKUI that you don't need.

I propose either splitting the deluge packages like Debian/Ubuntu do into deluge-web, deluge-core, deluge-gtk and deluge-console or just making the GTK/GUI dependencies into optdepends.

Perhaps this should be 1.1.9-3 or wait for 1.2.0 to hit...hmm....
This task depends upon

Closed by  Ionut Biru (wonder)
Monday, 11 January 2010, 19:35 GMT
Reason for closing:  Implemented
Additional comments about closing:  in 1.2.0. As deluge doesn't provide a clean way to split i decided to move all UIs related dependency to optdepends
Comment by Nezmer (Nezmer) - Thursday, 22 October 2009, 11:55 GMT
Agreed .
I use deluge in a headless machine . the pygtk dependency chain is annoying .
Comment by Matthew Gyurgyik (pyther) - Saturday, 07 November 2009, 20:14 GMT
AFAIK there is no official supported way to break up these pkgs. (Just throwing this out there)
Comment by Jelle van der Waa (jelly) - Monday, 09 November 2009, 10:23 GMT
 FS#15949  - [deluge] 'python-notify' should be optdepend.
This bug report is related to splitting up the package, it would be nice to have a deluge and deluge-gtk package. If i am bored i will see if i can make something.

Loading...