Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#16760 - [pcmanfm] incompatible with shared-mime-info 0.70

Attached to Project: Arch Linux
Opened by Leo Solaris (LeoSolaris) - Wednesday, 21 October 2009, 00:44 GMT
Last edited by Jürgen Hötzel (juergen) - Sunday, 25 October 2009, 21:14 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jürgen Hötzel (juergen)
Architecture x86_64
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 12
Private No

Details

shared-mime-info-0.70-1_x86-64

Upon update, pcmanfm ceased recognizing mimes and accepting default program saves. From conversation on the forum, it only effects 64-bit.

A downgrade to shared-mime-info-0.60-1 solved the issue.

Forum conversation on the topic:
http://bbs.archlinux.org/viewtopic.php?id=82786

There remains the possibility that it is pcmanfm's fault.
This task depends upon

Closed by  Jürgen Hötzel (juergen)
Sunday, 25 October 2009, 21:14 GMT
Reason for closing:  Fixed
Additional comments about closing:  0.5.2 is out
Comment by Greg (dolby) - Wednesday, 21 October 2009, 02:14 GMT
This is happening only in x86_64 cause the i686 version is still 0.60
I think this is how this can be solved:http://alien.slackbook.org/blog/gtk-icons-suddenly-missing/
Comment by Jan de Groot (JGC) - Wednesday, 21 October 2009, 06:47 GMT
glib 2.22.x and gtk2 2.18.x are fully compatible with shared-mime-info 0.70. As noted in the comment by Greg, there could be issues with caches in your profile. We can't alter profile data from the package, so you need to fix the cache files in your profile yourself.
Comment by Sam Weston (sweston) - Wednesday, 21 October 2009, 08:36 GMT
I'm pretty sure I deleted all my caches with no success when I first discovered the problem. But if it will fix this, would you mind telling me where the files can be found?
Comment by Jan de Groot (JGC) - Wednesday, 21 October 2009, 08:45 GMT
update-mime-database ~/.local/share/mime

That should fix your problems.
Note that the cache format has changed, and older versions of glib, gtk and gnome-vfs have problems with the new format. Reading the forum post, I see people downgraded their GTK because of flash problems. This is not a supported configuration.
Comment by Sam Weston (sweston) - Wednesday, 21 October 2009, 08:50 GMT
Sorry. After upgrading again and running that command I still have the same problem.
Comment by Jan de Groot (JGC) - Wednesday, 21 October 2009, 10:11 GMT
Does pcmanfm have its own parser for the mime cache? With the previous update we also had these problems, which was caused by the same problem.
Comment by Nezmer (Nezmer) - Wednesday, 21 October 2009, 10:16 GMT
Confirmed .
I don't have a "~/.local/share/mime" dir .
I deleted everything not owned by a package(everything but packages/) in "/usr/share/mime" then ran "update-mime-database /usr/share/mime" .
The problem still persists in PCManFM .

Only downgrading fixes the bug.
Comment by Jan de Groot (JGC) - Wednesday, 21 October 2009, 10:20 GMT
This gentoo bug describes the same problem:
http://bugs.gentoo.org/show_bug.cgi?id=288820

It appears shared-mime-info 0.70 introduces a new cache format, which is not supported by PCManFM.
Comment by Sam Weston (sweston) - Wednesday, 21 October 2009, 11:46 GMT Comment by Frank Carlyle McLaughlin (frankspace) - Wednesday, 21 October 2009, 12:28 GMT
According to this:
https://launchpad.net/bugs/444962
(note: retrieved from Google cache because the site itself isn't responding to me)
...the problem is in glib, and it has supposedly been fixed in glib:
http://git.gnome.org/cgit/glib/commit/?id=7c27df1feeea1d6ab8b927285cecc4ac34db8b06
http://git.gnome.org/cgit/glib/commit/?id=e1643fd76daf66ccffd9e6818e4f4ec8272e2a51

Also suggested at that link was the somewhat more specific fix, "update-mime-database.real -V ~/.local/share/mime/", which I haven't tried because I also downgraded to solve this problem when I experienced it. (And which, by the way, seemed to affect rox-filer as well as pcmanfm for me, so on my box, it isn't just a pcmanfm issue.)
Comment by Jan de Groot (JGC) - Wednesday, 21 October 2009, 12:34 GMT
I think rox-filer also contains custom code for the mime cache. The glib commits have been applied to the 2.22.2 release, which is the current version in our repositories.
Comment by Fabio Zanini (iosonofabio) - Friday, 23 October 2009, 21:28 GMT
The bug report on the PCManFM sourceforge page states "fixed" now (from this afternoon). Maybe an upgrade of the package solves the issue.
Comment by Alyssa Hung (Deciare) - Saturday, 24 October 2009, 18:07 GMT
Attached is the patch that was committed to upstream pcmanfm SVN.

Loading...