Arch Linux

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#16744 - [kernel26] No wireless connection with Ralink RT2500 since update to kernel 2.6.31

Attached to Project: Arch Linux
Opened by Filipp Andjelo (scorp) - Monday, 19 October 2009, 19:41 GMT
Last edited by Paul Mattal (paul) - Saturday, 07 November 2009, 23:38 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To Thomas Bächler (brain0)
Architecture i686
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No


After the kernel update to 2.6.31 my wireless network is dead. Till now, I didn't find anything that could bring a solution or even s.t. about the root of the problem.

Additional info:
See attachment or

I had to fallback to kernel 2.6.30 first
This task depends upon

Closed by  Paul Mattal (paul)
Saturday, 07 November 2009, 23:38 GMT
Reason for closing:  Upstream
Additional comments about closing:  Upstream, and reported there.
Comment by Gerardo Exequiel Pozzi (djgera) - Monday, 19 October 2009, 22:09 GMT
  • Field changed: Summary (No wireless connection with Ralink RT2500 since update to kernel 2.6.31 → [kernel26] No wireless connection with Ralink RT2500 since update to kernel 2.6.31)
  • Field changed: Status (Unconfirmed → Assigned)
  • Field changed: Severity (Critical → High)
  • Task assigned to Tobias Powalowski (tpowa)
Please report this to upstream. This is the correct way to these type of issue can be solved. Thanks.
Comment by Filipp Andjelo (scorp) - Tuesday, 20 October 2009, 20:05 GMT
What kind of upstream report should it be? Kernel?
Where/How can I do this? I've never did it before.
Comment by Mr. K. (KitchM) - Tuesday, 20 October 2009, 22:26 GMT
Did this happen right after the upgrade to the latest kernel? Did you do anything other than reboot?
Comment by Filipp Andjelo (scorp) - Wednesday, 21 October 2009, 13:49 GMT
Yes, It has definitely s.t. to do with the new kernel. I was trying to find some hints, but no success.
If I do fallback to 2.6.30 everything is ok. I tried the update and fallback for 4 or 5 times, each time
I had another idea, how I possibly could find the root of the problem :)

I would appreciate any kind of help, thx.
Comment by Mr. K. (KitchM) - Wednesday, 21 October 2009, 15:40 GMT
If you are able to fall back to the .30 kernel, and that solves the problem, I would do so and leave it at that for a while. There is some flaw in the most recent kernel upgrade and it appears to be causing all sorts of serious problems. I certainly wouldn't trust it with my important data. My problem is that I can't fall back. I think we have to wait until the upgrade process is fixed. Good luck.
Comment by Filipp Andjelo (scorp) - Thursday, 29 October 2009, 21:47 GMT
I made an upstream report for this issue:
Comment by Thomas Bächler (brain0) - Monday, 02 November 2009, 13:32 GMT
I can not reproduce this problem. I have recently tested the rt2500pci driver, and a friend uses it for his primary internet access.
Comment by Filipp Andjelo (scorp) - Monday, 02 November 2009, 13:48 GMT
I've tested it on Ubuntu 9.10 with the same result. Interface is up, that creepy messages in the dmesg and scanning for Wireless Networks says, that nothing was found. So it is not a problem of ArchLinux, it is definitely kernel or hardware bug. If it is a hardware bug, then there was a workaround for it before 2.6.31 came. I never had as much problems as I have with 2.6.31, no WiFi, no CardReader, no Suspend. Everything is ok if I make a fallback to 2.6.30