Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#16740 - [sim] remove kdelibs3 dependence

Attached to Project: Arch Linux
Opened by Andrea Scarpino (BaSh) - Monday, 19 October 2009, 15:44 GMT
Last edited by Tobias Powalowski (tpowa) - Saturday, 02 January 2010, 09:48 GMT
Task Type Feature Request
Category Packages: Extra
Status Closed
Assigned To Tobias Powalowski (tpowa)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
Sim can be built without kdelibs3 dependence simply adding '--disable-kde' to ./configure.
Prefix will be /usr.
Can you remove kdelibs3 dependence?

Additional info:
* sim 0.9.4.3-3
This task depends upon

Closed by  Tobias Powalowski (tpowa)
Saturday, 02 January 2010, 09:48 GMT
Reason for closing:  Fixed
Additional comments about closing:  removed from extra repository
Comment by Laszlo Papp (djszapi) - Saturday, 07 November 2009, 07:00 GMT
checking for kde-config... not found
configure: error: The important program kde-config was not found!
Please check whether you installed KDE correctly

Without installed kdelibs3. Did you removed kdelibs3 ?
Comment by Dan Griffiths (Ghost1227) - Saturday, 07 November 2009, 07:48 GMT
Builds fine for me with the --disable-kde option
Comment by Laszlo Papp (djszapi) - Saturday, 07 November 2009, 07:52 GMT
checking for perl... /usr/bin/perl
checking for Qt... configure: error: Qt (>= Qt 3.0) (headers and libraries) not found. Please check your installation!
For more details about this problem, look at the end of config.log.

Yeah, but then Qt has got problems.
Comment by Andrea Scarpino (BaSh) - Saturday, 07 November 2009, 11:14 GMT
change kdelibs3 with qt3 and add --disable-kde to configure. sim works.
Comment by Laszlo Papp (djszapi) - Saturday, 07 November 2009, 11:23 GMT
yeah, on x86_64, x86 too.
   PKGBUILD (0.9 KiB)
Comment by Eric Belanger (Snowman) - Saturday, 05 December 2009, 01:43 GMT Comment by Paul Mattal (paul) - Sunday, 06 December 2009, 20:04 GMT
tpowa, do you want to remove this to unsupported?
Comment by Laszlo Papp (djszapi) - Sunday, 06 December 2009, 20:19 GMT
According to this, yes ->aur-general@archlinux.org/msg06114.html"> http://www.mail-archive.com/aur-general@archlinux.org/msg06114.html
Comment by Tobias Powalowski (tpowa) - Saturday, 02 January 2010, 09:48 GMT
package removed from the extra repository

Loading...