Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#16731 - Brasero shows that there is no writable DVD disk

Attached to Project: Arch Linux
Opened by João Marcos Menezes (stremer) - Monday, 19 October 2009, 03:21 GMT
Last edited by Allan McRae (Allan) - Sunday, 25 October 2009, 00:59 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Tobias Powalowski (tpowa)
Allan McRae (Allan)
Architecture x86_64
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
Brasero shows that there is no writable disk

After create a ISO image (legal content), or with any iso image, when insert a blank DVD and click in the iso file, then write to disk, works great with the first iso. Then, place a new disk, and try to write again, brasero shows that there is no disk, but the disk mount (blank disk) appears in the desktop. Just logoff and logon again (gnome 2.28) and it works (just the first time). The second time it shows the message that there is no disk again.

I dont know if this is a real bug or just occurs in my computer (Athlon X2, Dell Inspiron 531n)
Using x86-64 version. All updated.

Additional info:
* package version(s)
* config and/or log files etc.

Here is the errors.log output after insert a blank disk:
Oct 19 01:12:11 hacksys kernel: end_request: I/O error, dev sr0, sector 0
Oct 19 01:12:11 hacksys kernel: Buffer I/O error on device sr0, logical block 0
Oct 19 01:12:11 hacksys kernel: end_request: I/O error, dev sr0, sector 0
Oct 19 01:12:11 hacksys kernel: Buffer I/O error on device sr0, logical block 0

Here the messages.log:
Oct 19 01:12:11 hacksys kernel: cdrom: This disc doesn't have any tracks I recognize!
Oct 19 01:12:11 hacksys kernel: sr 1:0:0:0: [sr0] Result: hostbyte=0x00 driverbyte=0x08
Oct 19 01:12:11 hacksys kernel: sr 1:0:0:0: [sr0] Sense Key : 0x5 [current]
Oct 19 01:12:11 hacksys kernel: sr 1:0:0:0: [sr0] ASC=0x21 ASCQ=0x0
Oct 19 01:12:11 hacksys kernel: sr 1:0:0:0: [sr0] Result: hostbyte=0x00 driverbyte=0x08
Oct 19 01:12:11 hacksys kernel: sr 1:0:0:0: [sr0] Sense Key : 0x5 [current]
Oct 19 01:12:11 hacksys kernel: sr 1:0:0:0: [sr0] ASC=0x21 ASCQ=0x0

Steps to reproduce:
Insert a blank DVD, click burn in a ISO file. Wait to burn. Then, insert a new blank DVD, try to burn the iso again. If brasero says there is no disk, try to logoff/logon gnome session and try to burn again. Maybe work.

Sorry about my poor english...
This task depends upon

Closed by  Allan McRae (Allan)
Sunday, 25 October 2009, 00:59 GMT
Reason for closing:  Fixed
Comment by Gerardo Exequiel Pozzi (djgera) - Monday, 19 October 2009, 08:25 GMT
Looks like a hardware issue (or maybe a combination by kernel issue with your hardware), rather than a brasero issue: "Buffer I/O error on device sr0, logical block 0"

Linux kernel version?
Comment by João Marcos Menezes (stremer) - Monday, 19 October 2009, 21:20 GMT
Kernel 2.6.31-ARCH. From repo...
Any blank DVD I use report the errors to logs, but when place the DVD after the burn, nothing is reported to logs...
I dont think its a hardware issue, because logoff/logon gnome shows the disk by brasero and burn occurs...
I will test with another burn software to confirm that is a brasero bug. But can be a issue with my hardware.
Comment by Allan McRae (Allan) - Thursday, 22 October 2009, 08:20 GMT
Status with 2.28.2?
Comment by João Marcos Menezes (stremer) - Sunday, 25 October 2009, 00:54 GMT
It works fine with 2.28.2.
The bug can be closed!

COOL!

Loading...