Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#1672 - arch doesn't set LANG environment variable by default

Attached to Project: Arch Linux
Opened by Tobias Powalowski (tpowa) - Saturday, 23 October 2004, 12:21 GMT
Last edited by Tobias Powalowski (tpowa) - Saturday, 23 October 2004, 12:21 GMT
Task Type Bug Report
Category System
Status Closed
Assigned To Judd Vinet (judd)
Architecture not specified
Severity High
Priority Normal
Reported Version 0.7 Wombat
Due in Version Undecided
Due Date Undecided
Percent Complete 0%
Votes 0
Private No

Details

hi
would it be possible to include this in rc.conf
else every user has to modify its /etc/profile
LANG=...
an option in rc.conf would be a great thing
the openoffice issue was caused by this and noone was able to write accents
This task depends upon

Closed by  Judd Vinet (judd)
Monday, 25 October 2004, 17:11 GMT
Reason for closing:  Fixed
Comment by Judd Vinet (judd) - Monday, 25 October 2004, 17:09 GMT
rc.conf isn't really a good place for an environment variable. The other locale-type variables in rc.conf are not actually exported to the environment, they're used by utility programs during bootup.

exports should be in /etc/profile instead. I'll add a default LANG to bash's /etc/profile.

Loading...