FS#16701 - [synfigstudio] Mouse pointer does nothing in canvas window

Attached to Project: Community Packages
Opened by Julien (ganymede) - Friday, 16 October 2009, 20:29 GMT
Last edited by Andrea Scarpino (BaSh) - Sunday, 25 October 2009, 10:57 GMT
Task Type Bug Report
Status Closed
Assigned To Sergej Pupykin (sergej)
Architecture x86_64
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No


In the canvas window, the mouse pointer has no effect : when I click somewhere, nothing visible happens. The object selected in the toolbox (circle, text, bline...) seem to be created since they appear in the history panel. But when I run a preview, nothing appears (the preview window stays empty). The only visible thing I could create was a shaded background color, but the two-handle line supposed to configure this shading was not displayed. I could also import an exernal image but not resize it.
I tried to tweak parameters in File -> Input devices, without success.
Another user of the french forum tried to use synfigstudio but had the same bug. We both use KDE4 as desktop environment.
I tried to run synfigstudio in a minimal X environment (only a xterm was launched) but I got the same result.
I also tried to recompile the package myself but it did not change anything.
This task depends upon

Closed by  Andrea Scarpino (BaSh)
Sunday, 25 October 2009, 10:57 GMT
Reason for closing:  Works for me
Comment by Julien (ganymede) - Sunday, 18 October 2009, 12:33 GMT
I compiled and installed the previous version of synfig and synfigstudio (0.61.09) by reusing the PKGBUILDs for this version (I restored these PKGBUILDs from http://www.archlinux.org/packages/, using the svn diff features). This old version seems to be plainly functional on my system : I didn't test everything, but at least I could create and display objects in canvas window.

I noticed that, in version 0.61.09, in menu File -> Input devices, all input devices were deactivated by default. But applying these settings, and also reusing the ~/.synfig/ dir from version 0.61.09 with version 0.62.00 did not solve the problem.
I also tried to launch synfigstudio-0.62.00 with LANG=C and LC_ALL=C but it didn't change anything (except the language used in the UI, of course).

Conclusion : only version 0.62.00 of synfigstudio is affected by this bug, regardless of the settings and locale. The versions of the dependencies (gtkmm, etl, libsigc++2.0, libxml++2...) were exactly the same when I compiled / run the two versions.
Comment by Julien (ganymede) - Sunday, 25 October 2009, 08:12 GMT
After another recompilation of synfigstudio and by deactivating ALL input devices in File -> Input devices (including the Logitech USB mouse I'm using), the problem was solved. I can now use version 0.62.00 without trouble.