Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#16693 - [cups] USB Printer doesn't print anymore

Attached to Project: Arch Linux
Opened by Daniel (Doehni) - Friday, 16 October 2009, 14:51 GMT
Last edited by Andreas Radke (AndyRTR) - Friday, 16 October 2009, 16:43 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Andreas Radke (AndyRTR)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:
Since the update of cups to version 1.4.1-1 my printer doesn't print anymore.
I followed the instructions on the news and removed the usblp module.
Also tried to reinstall after the update.

The printer can be seen on the cups page (localhost:631);
but when printing a test page, the status says: "Waiting for printer to become available..."


My printer: Brother DCP 7010L
It is also a scanner, which works perfectly.

Installation was made using this wiki page (with the files for 7010): http://wiki.archlinux.org/index.php/Brother_DCP-7020


Additional info:
* package version(s)
cups 1.4.1-1

* config and/or log files etc.

cups: Connection: usb:/dev/usb/lp0

lsusb | grep Brother
Bus 001 Device 002: ID 04f9:0182 Brother Industries, Ltd Composite Device

ls -al /dev/bus/usb/001/
drwxr-xr-x 2 root root 100 2009-10-16 15:23 .
drwxr-xr-x 3 root root 60 2009-10-16 15:23 ..
crw-rw-r-- 1 root root 189, 0 2009-10-16 15:23 001
crw-rw-r-- 1 root scanner 189, 1 2009-10-16 15:23 002
crw-rw-r-- 1 root root 189, 2 2009-10-16 15:23 003

Steps to reproduce:
Update cups to version 1.4.1
This task depends upon

Closed by  Andreas Radke (AndyRTR)
Friday, 16 October 2009, 16:43 GMT
Reason for closing:  Not a bug
Additional comments about closing:  see comment. easy fixable with a custom udev rule.
Comment by Gerardo Exequiel Pozzi (djgera) - Friday, 16 October 2009, 15:14 GMT
Do you read the news on front page [#1]?

"USB-Printers:
In order to get usb printers working,
you need to disable usblp module in your rc.conf file.
Please blacklist usblp module in your /etc/rc.conf file, eg:
MODULES=(!usblp)"


[#1] http://www.archlinux.org/news/469/
Comment by Daniel (Doehni) - Friday, 16 October 2009, 15:32 GMT
As written above:
> I followed the instructions on the news and removed the usblp module.

Just checked again: Module usblp is blacklisted and not loaded.
Comment by Gerardo Exequiel Pozzi (djgera) - Friday, 16 October 2009, 15:46 GMT
oops! sorry.

Enable a debug mode in cups.conf, and see if there are any error message on error_log.
Comment by Daniel (Doehni) - Friday, 16 October 2009, 16:10 GMT
No problem! :-)

Part of /var/log/cups/error_log (whole file attached):

D [16/Oct/2009:17:59:50 +0200] [Job 274] usb_find_busses=0
D [16/Oct/2009:17:59:50 +0200] [Job 274] usb_find_devices=0
D [16/Oct/2009:17:59:50 +0200] [Job 274] STATE: +connecting-to-device
D [16/Oct/2009:17:59:50 +0200] [Job 274] Failed to set configuration 1 for 04f9:0182
D [16/Oct/2009:17:59:50 +0200] [Job 274] Failed to claim interface 0 for 04f9:0182: Operation not permitted
D [16/Oct/2009:17:59:50 +0200] [Job 274] STATE: -connecting-to-device
I [16/Oct/2009:17:59:50 +0200] [Job 274] Waiting for printer to become available...
   error_log (105.4 KiB)
Comment by Gerardo Exequiel Pozzi (djgera) - Friday, 16 October 2009, 16:19 GMT
I assume that you are on the group "scanner" true? Because scanner works.

crw-rw-r-- 1 root scanner 189, 1 2009-10-16 15:23 002

anyway try to set chmod 777 /dev/bus/usb/001/002 # (or the current that is your printer)
Comment by Andreas Radke (AndyRTR) - Friday, 16 October 2009, 16:43 GMT
you will need a custom udev rule to set proper "lp" permission. see all the threads in our forum. multi devices are not well detected by udev. this is not a packaging bug. it's upstream "design" :S sry.

Loading...