Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#16647 - [truecrypt] PKGBUILD download and build dependancy !

Attached to Project: Arch Linux
Opened by solsTiCe (zebul666) - Wednesday, 14 October 2009, 15:37 GMT
Last edited by Paul Mattal (paul) - Sunday, 08 November 2009, 15:53 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Paul Mattal (paul)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
i had to build my own package to have a .desktop file cough.. cough..

<digression> http://bugs.archlinux.org/task/12366
how hard is that to include a .desktop file. this has been done for other package !
</digression>

and i notice that that wonderfull PKGBUILD has wxgtk as a dependancy BUT it DOWNLOADDS and COMPILES wxgtk !!!
and i wonder why ? i hope there is a very good reason for that ??

because it works perfectly without ...
This task depends upon

Closed by  Paul Mattal (paul)
Sunday, 08 November 2009, 15:53 GMT
Reason for closing:  Implemented
Additional comments about closing:  Implemented in truecrypt 6.3-2.
Comment by Gerardo Exequiel Pozzi (djgera) - Friday, 16 October 2009, 02:58 GMT
  • Field changed: Summary ([truecrypt-6.2a] PKGBUILD download and build dependancy ! → [truecrypt] PKGBUILD download and build dependancy !)
  • Field changed: Status (Unconfirmed → Assigned)
  • Task assigned to Paul Mattal (paul)
I will avoid any discussion. But for next time, first try to "request reopen" your previous ticket, or use the mailing list/forum to discus about this type of issues. Thanks ;)
Comment by solsTiCe (zebul666) - Friday, 16 October 2009, 10:56 GMT
it should be noted i had nothing to do with "that" previous ticket/bug. i just mentionnned it (in the wrong place, i know)
Comment by solsTiCe (zebul666) - Saturday, 24 October 2009, 18:02 GMT
what about the compilation of wxgtk in truecrypt PKGBUILD ?
Comment by Paul Mattal (paul) - Saturday, 07 November 2009, 22:27 GMT
When building this way, I then can't launch the GUI.
Comment by solsTiCe (zebul666) - Sunday, 08 November 2009, 08:24 GMT
strange, it works for me.
then close the bug report
Comment by solsTiCe (zebul666) - Sunday, 08 November 2009, 08:27 GMT
why can't you launch the GUI ? errors ? which ones ?
Comment by Paul Mattal (paul) - Sunday, 08 November 2009, 12:45 GMT
Actually I was mistaken in my test. It does work.

Now I'm building for x86_64 but got an error linking to fuse-- will push once that's resolved.

Loading...