Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#16631 - [xf86-video-vmware] makes X server crash.

Attached to Project: Arch Linux
Opened by Lee.MaRS (leemars) - Wednesday, 14 October 2009, 06:05 GMT
Last edited by Jan de Groot (JGC) - Monday, 02 November 2009, 21:48 GMT
Task Type Bug Report
Category Packages: Testing
Status Closed
Assigned To Jan de Groot (JGC)
Architecture x86_64
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
After xorg-server upgrading today, I found that I can't start X server any more. I checked /var/log/Xorg.0.log, it said:
.....
(II) LoadModule: "vmware"
(II) Loading /usr/lib/xorg/modules/drivers/vmware_drv.so
(II) Module vmware: vendor="X.Org Foundation"
compiled for 1.7.0.901, module version = 10.16.8
Module class: X.Org Video Driver
ABI class: X.Org Video Driver, version 6.0

Then the file ended.

So I think the problem is xf86-video-vmware. It makes X server crash. I removed it and start X server with vesa driver, then it works again.

Additional info:
local/xorg-server 1.7.0.901-1 (xorg)
X.Org X servers
local/xf86-video-vmware 10.16.8-1 (xorg-video-drivers)
X.org vmware video driver

And the log file is in the attachment.
This task depends upon

Closed by  Jan de Groot (JGC)
Monday, 02 November 2009, 21:48 GMT
Reason for closing:  Fixed
Additional comments about closing:  Fixed in 10.16.8-2.
Comment by Gerardo Exequiel Pozzi (djgera) - Wednesday, 14 October 2009, 12:20 GMT
  • Field changed: Summary (xf86-video-vmware makes X server crash. → [xf86-video-vmware] makes X server crash.)
  • Field changed: Status (Unconfirmed → Waiting on Response)
  • Task assigned to Jan de Groot (JGC)
So please report this to upstream at http://bugs.freedesktop.org/ if not already reported.
Comment by Lee.MaRS (leemars) - Thursday, 15 October 2009, 03:47 GMT Comment by Lee.MaRS (leemars) - Tuesday, 27 October 2009, 01:29 GMT
Hi, I'm so stupid that until today I tried to run X directly and got this error.

X: symbol lookup error: /usr/lib/xorg/modules/drivers/vmware_drv.so: undefined symbol: LoaderRefSymLists

I recompiled the driver but still not solved.

Any hints?
Comment by Lee.MaRS (leemars) - Monday, 02 November 2009, 02:45 GMT
I just found that xf86-video-vmware has entered extra and it still made my X broken again.

I got this error again:

X: symbol lookup error: /usr/lib/xorg/modules/drivers/vmware_drv.so: undefined symbol: LoaderRefSymLists

Am I missing some packages? Or any other help?

Nobody has this problem either, just me?
Comment by Vincent (vinvin) - Monday, 02 November 2009, 09:40 GMT
Yeah I have the same problem. My virutal machine goes black screen when I launch X. Using ssh I can see the same log file.
Comment by Filipp Andjelo (scorp) - Monday, 02 November 2009, 13:49 GMT
Same problem here!

Loading...