Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#16547 - [cvs] needs inetutils

Attached to Project: Arch Linux
Opened by Kyle Keen (keenerd) - Friday, 09 October 2009, 19:51 GMT
Last edited by Eric Belanger (Snowman) - Saturday, 06 February 2010, 10:02 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Douglas Soares de Andrade (dsa)
Architecture All
Severity Low
Priority Normal
Reported Version 3.3.1
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Summary and Info:
CVS needs rsh, part of inetutils, to download files. This should be added to the dependencies.

Steps to Reproduce:
cvs checkout [anything]
This task depends upon

Closed by  Eric Belanger (Snowman)
Saturday, 06 February 2010, 10:02 GMT
Reason for closing:  Fixed
Additional comments about closing:  fixed in svn
Comment by √ėyvind Heggstad (Mr.Elendig) - Tuesday, 27 October 2009, 20:48 GMT
Should probably be an optdepend, since it's only needed for cvs over ssh/rsh
Comment by Kyle Keen (keenerd) - Tuesday, 27 October 2009, 20:52 GMT
On a related note, how the do I check out
anoncvs@anoncvs.freedaemon.com:/scrotwm

This is the repo that is giving trouble. Nothing but time outs.
Comment by Kyle Keen (keenerd) - Wednesday, 28 October 2009, 07:24 GMT
Well, I feel like an idiot.

export CVS_RSH=ssh

For some unknown reason, we default to rsh. No one uses rsh. We don't even include the rsh dependency.

The bug fix is changing the default secure protocol to ssh.
Comment by Kyle Keen (keenerd) - Wednesday, 28 October 2009, 07:51 GMT
And adding ssh as an optdep.
Comment by Thomas Dziedzic (tomd123) - Saturday, 07 November 2009, 23:51 GMT
This bug has to wait for the next cvs release.
This is because the cvs release is incompatible with the current glibc and gives compiler errors.
I can confirm that it compiles with the sources from the cvs repository.

Notes:
cvs 1.11.23-3
glibc 2.10.1-5

Loading...