Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#16467 - [texlive-core] fmtutil: Error! Not all formats have been built successfully.

Attached to Project: Arch Linux
Opened by Robson Roberto Souza Peixoto (robsonpeixoto) - Monday, 05 October 2009, 11:57 GMT
Last edited by Francois Charette (Firmicus) - Wednesday, 07 October 2009, 19:27 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Francois Charette (Firmicus)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 3
Private No

Details

Description:
( 3/18) installing texlive-core [########################################################################################################################] 100%
>>> texlive: updating the filename database...
mktexlsr: Updating /usr/share/texmf/ls-R...
mktexlsr: Updating /usr/share/texmf-config/ls-R...
mktexlsr: Updating /usr/share/texmf-dist/ls-R...
mktexlsr: Updating /usr/share/texmf-var/ls-R...
mktexlsr: Done.
>>> texlive: updating the fontmap files with updmap...
done.
Error: `luatex -ini -jobname=dvilualatex -progname=dvilualatex dvilualatex.ini' failed
Error: `luatex -ini -jobname=lualatex -progname=lualatex lualatex.ini' failed
Error: `luatex -ini -jobname=luatex -progname=luatex luatex.ini' failed
Error: `luatex -ini -jobname=dviluatex -progname=dviluatex dviluatex.ini' failed

###############################################################################
fmtutil: Error! Not all formats have been built successfully.
Visit the log files in directory
/usr/share/texmf-var/web2c
for details.
###############################################################################

This is a summary of all `failed' messages:
`luatex -ini -jobname=dvilualatex -progname=dvilualatex dvilualatex.ini' failed
`luatex -ini -jobname=lualatex -progname=lualatex lualatex.ini' failed
`luatex -ini -jobname=luatex -progname=luatex luatex.ini' failed
`luatex -ini -jobname=dviluatex -progname=dviluatex dviluatex.ini' failed
creating all formats... done.
(logs are under /usr/share/texmf-var/web2c/<engine>/<formatname>.log)
Optional dependencies for texlive-core
perl
ruby
ghostscript
psutils
t1utils

Steps to reproduce: pacman -S texlive-most
This task depends upon

Closed by  Francois Charette (Firmicus)
Wednesday, 07 October 2009, 19:27 GMT
Reason for closing:  Not a bug
Additional comments about closing:  See comments
Comment by Francois Charette (Firmicus) - Tuesday, 06 October 2009, 14:00 GMT
This does not occur on my system. Could you attach one of the log files for the failed formats? (E.g. /usr/share/texmf-var/web2c/luatex/luatex.log)
Note that unless you do use luatex, you can safely ignore this ;)
Comment by Robson Roberto Souza Peixoto (robsonpeixoto) - Tuesday, 06 October 2009, 14:26 GMT
A did it
$find texmf* -name '*.log' -exec grep -i fail {} \;
on /usr/share and no fail was found.

So, i ran:
$sudo fmtutil-sys --all > out 2> err

$cat err
Error: `luatex -ini -jobname=dvilualatex -progname=dvilualatex dvilualatex.ini' failed
Error: `luatex -ini -jobname=lualatex -progname=lualatex lualatex.ini' failed
Error: `luatex -ini -jobname=luatex -progname=luatex luatex.ini' failed
Error: `luatex -ini -jobname=dviluatex -progname=dviluatex dviluatex.ini' failed

###############################################################################
fmtutil: Error! Not all formats have been built successfully.
Visit the log files in directory
/usr/share/texmf-var/web2c
for details.
###############################################################################

This is a summary of all `failed' messages:
`luatex -ini -jobname=dvilualatex -progname=dvilualatex dvilualatex.ini' failed
`luatex -ini -jobname=lualatex -progname=lualatex lualatex.ini' failed
`luatex -ini -jobname=luatex -progname=luatex luatex.ini' failed
`luatex -ini -jobname=dviluatex -progname=dviluatex dviluatex.ini' failed

Do you want yet the log files ?
Sorry my english!
Comment by Francois Charette (Firmicus) - Tuesday, 06 October 2009, 22:12 GMT
Yes, please attach the file /usr/share/texmf-var/web2c/luatex/luatex.log !
You have to help me, otherwise I really can't help you!
Btw I believe this is not a bug, because I cannot reproduce it.
But I would still like to know the reason for your problem, so I can possibly add the solution to the wiki.

Comment by Robson Roberto Souza Peixoto (robsonpeixoto) - Wednesday, 07 October 2009, 00:21 GMT
I only ask you it because on the log don't have any substring with err and fail.
I didn't want to offend.

Thank you for your attention.
Comment by Francois Charette (Firmicus) - Wednesday, 07 October 2009, 10:16 GMT
Well, your attachment is empty! :)

Here's what you should do:
1. make sure that you get the following output:
$ fmtutil-sys --catcfg | grep luatex
dvilualatex luatex language.dat dvilualatex.ini
dviluatex luatex language.def dviluatex.ini
lualatex luatex language.dat lualatex.ini
luatex luatex language.def luatex.ini

Now run this:
$ sudo fmtutil-sys --byfmt luatex
and check carefully the output, which you could attach here or post on some pastebin. It could well be that your language.def (or language.dat for latex-based formats) contains outdated lines, i.e. references to unavailable hyphenation patterns. Be sure to compare the files /usr/share/texmf-config/tex/generic/config/language.{def,dat} with their corresponding .pacnew, if any. Hope this helps.
Comment by Robson Roberto Souza Peixoto (robsonpeixoto) - Wednesday, 07 October 2009, 12:03 GMT
# fmtutil-sys --byfmt luatex
The first step are ok, I'm get the same output.

On second step had this problem:
# fmtutil-sys --byfmt luatex
http://paste.archlinux-br.org/1332

I doesn't have /usr/share/texmf-config/tex/generic/config/language.def on my box.

[root@robinho ~]# locate language.def
/usr/share/texmf/tex/generic/config/language.def
My only language.def.

I try make a symlink but don't resolve que problem.
Comment by Francois Charette (Firmicus) - Wednesday, 07 October 2009, 12:28 GMT
/usr/share/texmf/tex/generic/config/language.def is OK. Your problem is rather with the experimental hyphenation patterns for german, which you most probably do not need! (I don't know why it fails on your system – I have no such problem...).

In any case, please do this:
$ sudo cp /usr/share/texmf/tex/generic/config/language.def /usr/share/texmf-config/tex/generic/config/language.def
$ sudo vim /usr/share/texmf-config/tex/generic/config/language.def
and comment out the line(s) with the string "dehypht-x"

Do exactly as above with the file /usr/share/texmf/tex/generic/config/language.dat

Then run
$ sudo fmtutil-sys --missing
That's it :)
Comment by Robson Roberto Souza Peixoto (robsonpeixoto) - Wednesday, 07 October 2009, 18:54 GMT
Thanks =)

I make it:
sudo ln -s /usr/share/texmf/tex/generic/config/language.def /usr/share/texmf-config/tex/generic/config/language.def

edit ....

E now, work =)
Comment by Francois Charette (Firmicus) - Wednesday, 07 October 2009, 19:27 GMT
Great! But instead of symlinking, please do make a *copy* to texmf-config instead, which is where you are supposed to edit your own config files. The files under texmf are the default ones provided upstream and are overwritten on each update.


EDIT: See http://wiki.archlinux.org/index.php/TeXLive#Error_with_.22formats_not_generated.22_upon_update

Loading...