Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#16413 - [kernel26] Atheros ath9k module is not working with 2.6.31.1 on an Acer Extensa 7630EZ.

Attached to Project: Arch Linux
Opened by Bernhard (dw) - Wednesday, 30 September 2009, 17:48 GMT
Last edited by Tobias Powalowski (tpowa) - Sunday, 28 February 2010, 10:03 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Tobias Powalowski (tpowa)
Thomas Bächler (brain0)
Architecture x86_64
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 4
Private No

Details

Description:
The Atheros ath9k module is not working with [testing]-kernel 2.6.31.1 on an Acer Extensa 7630EZ.

This could probably a bios/acpi bug (see attached dmesg output for 2.6.31 boot -> PCI A disabled!), a problem with the rfkill state (device doesn't get initiated) as the rfkill-state is different -> see output from /sys/class/rfkill/rfkillX/state) or something else

Additional info:
* package version(s)
kernel 2.6.31.x

[bernhard@wallaby ~]$ uname -a
Linux wallaby 2.6.30-ARCH #1 SMP PREEMPT Wed Sep 9 14:16:44 CEST 2009 x86_64 Pentium(R) Dual-Core CPU T4200 @ 2.00GHz GenuineIntel GNU/Linux

* config and/or log files etc.

lsmod |grep ath shows the same modules for 2.6.30 and 2.6.31 kernels

#################################################
#### Log with 2.6.30 Kernel (Wifi is working) ###
#################################################
[bernhard@wallaby proc]$ cat /sys/class/rfkill/rfkill1/name
ath9k-phy0::rfkill
[bernhard@wallaby proc]$ cat /sys/class/rfkill/rfkill1/state
1

[bernhard@wallaby ~]$ lsmod |grep ath
ath9k 356404 0
mac80211 211488 1 ath9k
cfg80211 78152 2 ath9k,mac80211
rfkill 13108 4 ath9k,acer_wmi
led_class 5112 2 ath9k,acer_wmi

[bernhard@wallaby ~]$ dmesg |grep ath
ath9k 0000:05:00.0: enabling device (0000 -> 0002)
ath9k 0000:05:00.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17
ath9k 0000:05:00.0: setting latency timer to 64
phy0: Selected rate control algorithm 'ath9k_rate_control'
Registered led device: ath9k-phy0::radio
Registered led device: ath9k-phy0::assoc
Registered led device: ath9k-phy0::tx
Registered led device: ath9k-phy0::rx
#################################################


#####################################################
#### Log with 2.6.31 Kernel (Wifi is not working) ###
#####################################################
-> /sys/class/rfkill/rfkill1/ does not exist any longer

[bernhard@wallaby ~]$ cat /sys/class/rfkill/rfkill0/name
acer-wireless

[bernhard@wallaby ~]$ cat /sys/class/rfkill/rfkill0/state
0

[bernhard@wallaby ~]$ dmesg |grep ath
ath9k 0000:05:00.0: enabling device (0000 -> 0002)
ath9k 0000:05:00.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17
ath9k 0000:05:00.0: setting latency timer to 64
ath9k 0000:05:00.0: PCI INT A disabled
#####################################################

Steps to reproduce:
Upgrade to 2.6.31 kernel from testing.

If any further information would be useful, I will happily provide it.
This task depends upon

Closed by  Tobias Powalowski (tpowa)
Sunday, 28 February 2010, 10:03 GMT
Reason for closing:  Fixed
Comment by Thomas Bächler (brain0) - Wednesday, 30 September 2009, 20:41 GMT
Could add a -C5 to the grep command? I think we are missing some important messages here.
Comment by Bernhard (dw) - Thursday, 01 October 2009, 12:23 GMT
Hi Thomas. Attached you will find the dmesg |grep -C5 output for working (2.6.30) and non-working kernel (2.6.31)

Additionally I attach complete dmesg-output for both working and non-working kernel versions

[Working]
dmesg |grep -C5 ath -> http://pastebin.com/f37bd2273
dmesg (full) -> http://pastebin.com/ff451c78

[Non-Working]
dmesg |grep -C5 ath -> http://pastebin.com/m4c1977d4
dmesg (full) -> http://pastebin.com/m3db5ba1e

Bernhard
Comment by Thomas Bächler (brain0) - Thursday, 01 October 2009, 12:35 GMT
Funny, I would have thought there's more between the "ath9k 0000:05:00.0: setting latency timer to 64" and "ath9k 0000:05:00.0: PCI INT A disabled", but there isn't. It seems to find the device and immediately disable it again, for no reason I can think of.
Comment by Bernhard (dw) - Thursday, 01 October 2009, 12:38 GMT
Do you think this should be reported upstream? If so, where? Wireless? Acpi?
Comment by Adriano Moura (MaMuS) - Thursday, 01 October 2009, 20:10 GMT
I`m experiencing the same problems.
It should be related with this: http://bugzilla.kernel.org/show_bug.cgi?id=13807
Comment by Bernhard (dw) - Thursday, 01 October 2009, 20:48 GMT
hi adriano. I am not sure, if the kernel-bugzilla bug is the same as what i am experiencing here. what i experience is that with 2.6.31 the wlan0 interface is detected and instantly disabled again. i have no chance do do somthing like iwlist wlan0 scan or the like. the device is just not present. so in my case there is nothing about signal strength or disconnects since the device is just not present.
Comment by Thomas Bächler (brain0) - Thursday, 01 October 2009, 21:00 GMT
Yes, it's a different bug ... you should report to linux-wireless - if it's an ACPI problem, they will refer you there.
Comment by Adriano Moura (MaMuS) - Friday, 02 October 2009, 00:57 GMT
Sorry for my failing at comparing both problems. It`s indeed a lot different!
Comment by Gerardo Exequiel Pozzi (djgera) - Monday, 05 October 2009, 23:55 GMT
Probably this problem is solved now in 2.6.31.2 [#1]

"...big fixes, as does the ath5k and iwlwifi drivers. One might say that the patches for the iwlwifi drivers are a bit "bigger" than normal -stable material, but the wifi maintainer wants them, so he can handle the fallout..."

[#1] http://lwn.net/Articles/355485/
Comment by Bernhard (dw) - Tuesday, 06 October 2009, 15:07 GMT
unfortunately, upgrading to 2.6.31.2 doesn't solve this problem. it is still exactly the same as with 2.6.31. the ar928x-based card is recognized and immediately disabled again by the kernel.
Comment by Bernhard (dw) - Wednesday, 14 October 2009, 08:12 GMT
Neither with 2.6.31.3 nor with 2.6.31.4 the problem is fixed. I have also gotten no response on the linux-wireless mailing list (where bugs concerning ath9k should be reported as I read). What else could I do aside from holding kernel-updates back?
Comment by Giorgio (uastasi) - Saturday, 31 October 2009, 12:14 GMT
I seem to experience a similar problem, since my card randomly disconnects apparently without a precise cause.
Now I've tried to set power to 15 dbm (# iwconfig wlan0 power 15) and maybe the situation is getting better.

FYI:
$ lspci -v | grep Ath
06:00.0 Network controller: Atheros Communications Inc. AR928X Wireless Network Adapter (PCI-Express) (rev 01)
Subsystem: Atheros Communications Inc. Device 0200
Comment by Kevin Piche (kpiche) - Thursday, 05 November 2009, 20:19 GMT
I had similar problems with my AR928X wifi card randomly disassociating. Consensus on the web is that it's caused by changes to powersaving and rfkill features. Disable powersaving using iwconfig or modify your kernel. I disabled rfkill with a patch suggested on the kernel bugzilla. It's much better now but I still have the occasional problem.
Comment by Andrea Zucchelli (zukka) - Thursday, 05 November 2009, 22:22 GMT
using the patch posted by kpiche the situation got much better here...
Comment by Russ Adams (rustushki) - Wednesday, 11 November 2009, 16:28 GMT
I use ath9k for an AR5416 chipset. ath9k has been broken for me since 2.6.29. The wlan0 inteface would not initialize after
$ sudo modprobe ath9k
$ ifconfig wlan0
wlan0: error fetching interface information: Device not found

And so I've been hanging out on 2.6.28.

After reading this bug report: http://bugzilla.kernel.org/show_bug.cgi?id=14402, I decided to upgrade to the then testing kernel 2.6.31-6 and found that it has fixed ath9k.
Comment by Daniel (phoenix89) - Monday, 16 November 2009, 19:41 GMT
I think I am having a similar issue with the atheros AR928X card, but my problem is it works but only for a few minutes and then my computer will lock up.

My wireless card works fine in 2.6.30
Comment by Gerardo Exequiel Pozzi (djgera) - Sunday, 28 February 2010, 00:20 GMT
  • Field changed: Status (Assigned → Waiting on Response)
status with 2.6.33?
Comment by Freek (teek) - Sunday, 28 February 2010, 09:42 GMT
I had this problem but now everything works again however I'm not the original poster...

Loading...