Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#16410 - [phpmyadmin] /srv/www or better /srv/http as installation location?

Attached to Project: Community Packages
Opened by Andreas Baumann (andreas_baumann) - Wednesday, 30 September 2009, 15:52 GMT
Last edited by Sergej Pupykin (sergej) - Monday, 05 October 2009, 09:03 GMT
Task Type Bug Report
Category
Status Closed
Assigned To Sergej Pupykin (sergej)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description: phpMyAdmin for instance installs in /srv/http


Additional info:
* package version(s)
* config and/or log files etc.


Steps to reproduce:
This task depends upon

Closed by  Sergej Pupykin (sergej)
Monday, 05 October 2009, 09:03 GMT
Reason for closing:  Fixed
Comment by Pierre Schmitz (Pierre) - Wednesday, 30 September 2009, 17:27 GMT
FYI: No package should install anything into /srv.
Comment by Sergej Pupykin (sergej) - Friday, 02 October 2009, 04:16 GMT Comment by Pierre Schmitz (Pierre) - Friday, 02 October 2009, 06:04 GMT
/srv is like /home for services. I added that to the Wiki page; it looks like that page is not complete. It was discussed on the mailing list, but I cannot find it right now.
Comment by Sergej Pupykin (sergej) - Friday, 02 October 2009, 06:33 GMT
/srv and /home are different cases

/home often network or --bind mounted.

for example I use 4 chrooted environment to build packages with single /home (mounted with --bind key)

Most of distros I know (for example suse, alt, debian) use /srv (or /var/www) in packages. (I can not remember distro which disable it)

I want to discuss it again on ML: http://mailman.archlinux.org/pipermail/arch-general/2009-October/007800.html
Comment by Sergej Pupykin (sergej) - Friday, 02 October 2009, 12:02 GMT
please check phpmyadmin-3.2.2-2 in community-testing
Comment by Laszlo Papp (djszapi) - Saturday, 03 October 2009, 13:32 GMT
I agree with Sergej, because you can see the lamp wikipage too (installed into the /srv/http/), or maybe I'm wrong:
http://wiki.archlinux.org/index.php/LAMP#Advanced_Options
Comment by Roman Kyrylych (Romashka) - Saturday, 03 October 2009, 13:42 GMT
I don't see how that wiki page is an argument here.

Loading...