Release Engineering

This project is intented for all release related issues (isos, installer, etc), under the umbrella of the ArchLinux Release Engineers
Tasklist

FS#16374 - 2009.8 CDr does not boot properly with a SATA DVDr

Attached to Project: Release Engineering
Opened by John (graysky) - Sunday, 27 September 2009, 18:34 GMT
Last edited by Dieter Plaetinck (Dieter_be) - Monday, 05 April 2010, 20:08 GMT
Task Type Bug Report
Category Hardware Issues
Status Closed
Assigned To No-one
Architecture All
Severity Medium
Priority Normal
Reported Version 2009.08
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

Neither my Sony Optiarc AD-7240S-0B (SATA) nor my Plextor PX-880AS (SATA) will properly boot the 2009.8 iso burned to CDr (either architecture). I have burnt several discs from the isos at different speeds and they all act the same giving long delay on booting after selecting the first menu option from GRUB. That said, the very same media works fine on IDE-based DVDROM machines.

A bunch of stuff flys by, one relevant line reads:

<Code>
driver `sr` needs updating - please use the bus_type methods
</code>

Then there is a ~20 sec pause and the following message gets repeated:

<Code>
Buffer I/O error, dev sr0, logical block 93084
sr 4:0:0:0: [sr0] Result: hostbyte=0x00 driverbyte=0x08
sr 4:0:0:0: [sr0] Sense Key : 0x5 [current]
Info fld=0x2d739
sr 4:0:0:0: [sr0] ASC=0x64 ASCQ=0x0
end_request: I/O error, dev, sr0, sector 744672
</code>

This gets repeated many times and there is a delay of about 2 min before it boots properly into the (#) prompt or just hangs indefinitely.

I don't think the problem is with the physical drive because it reads/boots the 2009.2 x86_64/i686 CDs just fine; I also downloaded and burn a Jaunty CDROM which also works just fine. Wish I could post the entire dmseg but lately, I can't get to the (#) prompt.

Another person has confirmed this in the forums, see [[http://bbs.archlinux.org/viewtopic.php?pid=626777|this post]] for more.

Steps to reproduce: Boot of the CD, select the 1st GRUB menu option.

Hardware details:
DFI LP LT P35-TR2 (BIOS: LP35D919)
Intel X3360 @ 8.5x400=3.40 GHz
266/667 MHz Strap CPU Vcc=1.12500
NB Core=1.370 CPU VTT=1.310
Corsair Dominator DDR2-1066 | (TWIN2X4096-8500C5D)
4 x 2Gb @ 5-5-5-15 (performance level 6) @ 1,000 MHz (4:5) @ 2.100V

I have tried both SATA controllers on my board and was met with the same result (Intel ICH9R or JMicron JMB363). SATA mode is AHCI to match the HDDs in the box.
This task depends upon

Closed by  Dieter Plaetinck (Dieter_be)
Monday, 05 April 2010, 20:08 GMT
Reason for closing:  Not a bug
Additional comments about closing:  bad burning tools
Comment by Stefan Wilkens (stefanwilkens) - Sunday, 27 September 2009, 23:30 GMT
Simmilar I/O Errors on my server system (IDE COMPAQ CD-ROM LTN486S CD-ROM) when using a burnt image. This does not seem to happen when the image is loaded into virtualbox.

image used: archlinux-2009.08-core-i686.iso
Comment by Dieter Plaetinck (Dieter_be) - Wednesday, 11 November 2009, 12:25 GMT
and you're sure you can burn any other distro on the same media and use the same drive and they work fine?
Comment by John (graysky) - Wednesday, 11 November 2009, 18:41 GMT
@Dieter - yeah, tried ubuntu 9.04 and no problems. Also, the Arch 2009.2 image works just fine. It's only the 2009.8 image that does this.
Comment by Sven-Hendrik Haase (Svenstaro) - Saturday, 14 November 2009, 01:33 GMT
Does a recent USB version work fine?
Comment by John (graysky) - Saturday, 14 November 2009, 11:22 GMT
I can confirm this bug on a new machine I just built (P45-based system).

end_request: I/O error on device fd0, logical block 0

It pauses for about 30 sec, then continues.
Comment by Gerardo Exequiel Pozzi (djgera) - Wednesday, 18 November 2009, 14:33 GMT
  • Field changed: Category (Packages: Core → Hardware Issues)
  • Field changed: Reported Version ( → 2009.08)
  • Field changed: Architecture (All → All)
What is your optical disc: CD-R/CD-RW/DVD-R/DVD+R/DVD-RW/etc...?
With what program you burned the medium cdrkit/cdrtools/cdrdao/growisofs/other ?
What are the settings about DAO(SAO)/TAO others?
Comment by Kad Mann (kadaitcha_man) - Friday, 04 December 2009, 06:15 GMT
This doesn't look like a bug to me. I'd say it's a burn error. Where brasero failed, wodim succeeded:

wodim -v dev=/dev/sr0 speed=8 -sao -data -tsize=186168s driveropts=burnfree ~/Downloads/archlinux-2009.08-netinstall-i686-isolinux.iso

Comment by Heiko Baums (cyberpatrol) - Friday, 04 December 2009, 06:46 GMT
This is not and can't be a burn error. I burned it with cdrskin and with K3b/wodim. Both the same. I rebuilt the image several times and I don't have this problem with any other LiveCD. If this were a burn error then I had this problem with any other LiveCD. And if this were a burn error then it would mean that the drive couldn't read something. This would mean that udevadm trigger at ramfs$ prompt wouldn't be able to create the /dev/archiso link.

And it's pretty improbable that the same burn error occurs on several tries. I'm, btw, not the only one who has this issue. See the thread "Unable to install Arch on Server" in the mailing list arch-general.
Comment by Heiko Baums (cyberpatrol) - Friday, 04 December 2009, 06:49 GMT
Ups... Sorry. Posted to the wrong bug report. MIstook this bug report with my  FS#17231 . I guess both are quite different issues. So forget what I've written. ;-)
Comment by Marc Mongenet (mongenet) - Saturday, 05 December 2009, 09:51 GMT
Similar problem with a PATA Plextor PleXCombo PX-320A with x86_64 2009.08 core Live CD:

During Arch Linux kernel boot, an error is displayed 8 times just after the Uniform CD-ROM driver Revision: 3.20.

sr 2:0:0:0: [sr0] Unhandled sense code
sr 2:0:0:0: [sr0] Result: hostbyte=0x00 driverbyte=0x08
sr 2:0:0:0: [sr0] Sense key : 0x3 [current]
Info fld=0x2d7ce
sr 2:0:0:0: [sr0] ASC=0x6 ASCQ=0x0
end_request: I/O error, dev sr0, sector 745272
Buffer I/O error on device sr0, logical block 93159

Then the boot sequence goes on as if nothing happened.
Comment by Ivaylo Petrov (infestdead) - Tuesday, 16 February 2010, 13:52 GMT
Same here with dell e5500. 2009.8 does not work and gives the same errors.
The CD is 100% fine - md5sums and everything double/triple checked.
I'm trying 2009.2 now.
Comment by Gerardo Exequiel Pozzi (djgera) - Thursday, 04 March 2010, 04:37 GMT
Please test the latest iso builds at http://build.archlinux.org/isos/
Comment by John (graysky) - Thursday, 04 March 2010, 21:20 GMT
@Gerardo - glad to do so... are there no x86_64 versions at this point?
Comment by Dieter Plaetinck (Dieter_be) - Thursday, 04 March 2010, 21:25 GMT
John, I'll try to build some for you. stay tuned
Comment by John (graysky) - Thursday, 04 March 2010, 21:36 GMT
@Dieter - No big deal, just curious. I will try out the archlinux-2010.03.02-core-i686.iso right now.
Comment by John (graysky) - Thursday, 04 March 2010, 21:53 GMT
Nope... archlinux-2010.03.02-core-i686.iso gives the similar errors to those that I reported originally.

Info fld=0x2d601
sr 3:0:0:0 [sr0] ASC=0x64 ASQC=0x0
sr 3:0:0:0 [dr0] CDB: cdb[0]=0x28: 28 00 00 02 d6 00 00 00 02 00
end_request: I/O error on device sr0, sector 743424
Buffer I/O error on device sr0, logical block 92928
sr 3:0:0:0 [sr0] Result: hostbyte=0x00 driverbyte=0x08
sr 3:0:0:0 [sr0] Sense Key : 0x5 [current]
Info fld=0x2d601

There's a bunch more like the above.
Comment by Dieter Plaetinck (Dieter_be) - Friday, 05 March 2010, 20:24 GMT
that's odd. there are 64bit isos now also btw.
can you try different burning tools? brasero, k3b, wodim, ..
Comment by Stefan Wilkens (stefanwilkens) - Saturday, 06 March 2010, 11:34 GMT
This is interesting:

Burnt using brasero -> errors during boot from the cd
Burnt using burnimg on win32 -> no errors

archlinux-2010.03.02-netinstall-i686.iso was used on both occasions, both where verified before burn.

Could the current sr (2009.8) have some flaws that cause the burning of new images to mess up?
Comment by John (graysky) - Saturday, 06 March 2010, 13:21 GMT
Just burnt archlinux-2010.03.04-core-x86_64.iso with gnomebaker @ 8x with no errors. Here is the result:

http://img62.imageshack.us/img62/7281/94827682.jpg
Comment by Gerardo Exequiel Pozzi (djgera) - Saturday, 06 March 2010, 16:19 GMT
brasero is just a frontend, you use cdrkit? In this case test cdrtools (from AUR) ;)

PS: if you compare the md5sum of .iso and what is burned both are the same?

md5sum archxyz.iso
head -c $(isosize /dev/yourcdrom) /dev/yourcdrom | md5sum
Comment by Dieter Plaetinck (Dieter_be) - Monday, 05 April 2010, 20:08 GMT
okay so both John, Kad and Stefan confirm that with different burning tools the problem goes away.
As the problem is burning tool, not iso file I will close this ticket.

Loading...