Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#16300 - [vim-omnicppcomplete] lacks help documentation

Attached to Project: Arch Linux
Opened by Tareq A. Khandaker (LordRaiden) - Monday, 21 September 2009, 09:21 GMT
Last edited by Eric Belanger (Snowman) - Sunday, 06 December 2009, 23:40 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Tobias Kieslich (tobias)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

The help text for omnicppcomplete is missing. This problem is evidently a packaging problem because it can be fixed by doing:

1) sudo vim
2) :helptags /usr/share/vim/vimfiles/doc

To fix this problem, the vimdoc.install file needs to be modified so that post_install()
becomes (fixing the path)

post_install() {
echo -n "Updating vim help tags..."
/usr/bin/vim --noplugins -u NONE -U NONE \
--cmd ":helptags /usr/share/vim/vimfiles/doc" --cmd ":q" > /dev/null 2>&1
echo "done."
}


Additional info:
* package version(s): vim-omnicppcomplete 0.4.1-3

Steps to reproduce:
1) Install vim-omnicppcomplete with pacman
2) Run vim
3) Type ":h omnicppcomplete"
This task depends upon

Closed by  Eric Belanger (Snowman)
Sunday, 06 December 2009, 23:40 GMT
Reason for closing:  Fixed
Additional comments about closing:  vim-omnicppcomplete-0.4.1-4
Comment by Laszlo Papp (djszapi) - Saturday, 03 October 2009, 18:42 GMT
Yeah, because with the new vim update, the documentation must be in the /usr/share/vim/vimfiles/doc dir, in the vimdoc.install file.
I corrected it and attached.

Comment by Laszlo Papp (djszapi) - Saturday, 03 October 2009, 18:45 GMT
Sorry, I didn't realised the middle of the report, because the reported provided the fix for it too.
Well, the new vim location for doc,plugin,autoload,etc.. in the /usr/share/vim/vimfiles folder, sorry once more time.

Loading...