Community Packages

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#16254 - cannot resolve "perl-test-simple", a dependency of "perl-test-warn"

Attached to Project: Community Packages
Opened by Krzysztof (Christopher) AS (3ED_0) - Saturday, 19 September 2009, 11:41 GMT
Last edited by Francois Charette (Firmicus) - Saturday, 19 September 2009, 11:48 GMT
Task Type Bug Report
Category
Status Closed
Assigned To No-one
Architecture i686
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
:: Starting full system upgrade...
resolving dependencies...
warning: cannot resolve "perl-test-simple", a dependency of "perl-test-warn"
:: the following package(s) cannot be upgraded due to unresolvable dependencies:
perl-test-warn

Do you want to skip the above package(s) for this upgrade? [Y/n] n
error: failed to prepare transaction (could not satisfy dependencies)
:: perl-test-warn: requires perl-test-simple
zsh: exit 1 LANGUAGE=C sudo pacman -Su


Additional info:
% LANGUAGE=C pacman -Si perl-test-warn > /dev/null; echo "--- Pacman exit $?"
--- Pacman exit 0

% LANGUAGE=C pacman -Si perl-test-simple > /dev/null; echo "--- Pacman exit $?"
error: package 'perl-test-simple' was not found
zsh: exit 1 LANGUAGE=C sudo pacman-color -Si perl-test-simple > /dev/null
--- Pacman exit 1

Steps to reproduce:
"pacman -Syu" (from ftp.archlinux.org) and "pacman -S perl-test-warn"
This task depends upon

Closed by  Francois Charette (Firmicus)
Saturday, 19 September 2009, 11:48 GMT
Reason for closing:  Duplicate
Additional comments about closing:  See  FS#16249  which is already fixed.

Loading...