Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#16193 - [kde] 2.6.31 makes desktop refresh of kde 4.3.1 misfunctional

Attached to Project: Arch Linux
Opened by mikes (mechmg93) - Monday, 14 September 2009, 19:00 GMT
Last edited by Andrea Scarpino (BaSh) - Tuesday, 09 February 2010, 22:02 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Pierre Schmitz (Pierre)
Andrea Scarpino (BaSh)
Architecture x86_64
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 4
Private No

Details

I installed kernel26 from testing (version 2.6.31) and nvidia driver. After the upgrade, desktop refresh does not work automatically. I have to press f5 or right click on the screen after copying or deleting a file to desktop.

After reading the changelogs of 2.6.31 here :

http://kernelnewbies.org/LinuxChanges#head-0c30611399be8bbb1b2c618211b8bf2d342527fb


I read about a reimplementation of inotify and dnotify on top of a new
filesystem notification infrastructure.

so it may be a possible reason.

Downgrading to kernel26 of core and nvidia of extra makes everything work perfect again.

I have already reported a bug to kde bugzilla :

https://bugs.kde.org/show_bug.cgi?id=207361

and i have also created a forum topic in archlinux forums :

http://bbs.archlinux.org/viewtopic.php?id=80132


This task depends upon

Closed by  Andrea Scarpino (BaSh)
Tuesday, 09 February 2010, 22:02 GMT
Reason for closing:  Fixed
Additional comments about closing:  kdebase 4.4.0
Comment by Pierre Schmitz (Pierre) - Monday, 14 September 2009, 19:13 GMT
This works fine here. I enabled folder view for the desktop, opened a console and create/deleted files in ~/Desktop. The change was immediately visible on the desktop.

Could you be more precisely what you did?

PS: You are using KDE from [extra]?
Comment by mikes (mechmg93) - Monday, 14 September 2009, 19:23 GMT
i did nothing i have kde 4.3 installed from extra since months. i once had configured folder view and it worked like a charm until i upgraded to 2.6.31. after this upgrade i started having issues with copying/deleleting files from desktop.
Comment by Panos Filip (Flamelab) - Wednesday, 16 September 2009, 07:25 GMT
It's OK here as well (2.6.31 & KDE 4.3)
Comment by mikes (mechmg93) - Wednesday, 16 September 2009, 08:58 GMT
In order to be sure if what i described above is correct, i upgraded again kernel26 kernel26-firmware and nvidia packages from testing. The result is that i get exactly the same error.
Comment by mikes (mechmg93) - Wednesday, 16 September 2009, 09:00 GMT
Panos, if i remember correctly, you are a kernel26-bfs and radeon user. have you tried also with the official kernel26 package from testing??
Comment by Panos Filip (Flamelab) - Wednesday, 16 September 2009, 09:33 GMT
Yes, both of them. No problem. I think your issue is a graphics' driver issue. Try experimenting with xorg.conf (by adjusting the options in Device Section or by deleting the whole file).
Comment by mikes (mechmg93) - Wednesday, 16 September 2009, 10:03 GMT
i did the following tests after installing kernel 2.6.31 :

1. removed xorg.conf --------> problem
2. installed nvidia-beta and nvidia-utils beta with no xorg.conf ---------> problem (also tried without composite enabled)
3. used nvidia-beta and nvidia-utils with xorg.conf --------> problem (also tried without composite enabled)
4. used xf86-video-nv with nv enabled in xorg.conf ---------> problem

so i don't think that it is an nvidia issue. all the symptoms show kernel26.
Comment by Panos Filip (Flamelab) - Wednesday, 16 September 2009, 10:07 GMT
Have you tried another DE ? Xfce , GNOME, or a standalone WM ?
Comment by mikes (mechmg93) - Sunday, 27 September 2009, 07:57 GMT
i just tested kernel 2.6.31.1 and i keep having the same problem.
Comment by Thomas B├Ąchler (brain0) - Sunday, 27 September 2009, 09:13 GMT
What's your filesystem? This sounds like inotify fails.
Comment by mikes (mechmg93) - Sunday, 27 September 2009, 09:23 GMT
i use ext4.
Comment by mikes (mechmg93) - Tuesday, 06 October 2009, 07:33 GMT
i keep having the same problem while testing new kernel 2.6.31.2 from testing repo.
Comment by mikes (mechmg93) - Wednesday, 07 October 2009, 14:56 GMT
i tasted kernel 2.6.31.2 with latest kde 4.3.2 and it works fine while deleting files. the problem remains only when i do cut n paste.
Comment by mikes (mechmg93) - Saturday, 10 October 2009, 13:44 GMT
tested with new kernel 2.6.31.3 and the problem remains.
Comment by mikes (mechmg93) - Saturday, 10 October 2009, 15:23 GMT
i deleted my .kde4 in order to test with a clean profile but nothing changed.
Comment by Panos Filip (Flamelab) - Saturday, 10 October 2009, 15:46 GMT
No problem here, with Nvidia card, and nvidia-beta
Comment by Federico Stafforini (fede) - Saturday, 17 October 2009, 14:25 GMT
I also had this problem, kernel 2.6.31.4, kde 4.3.2. I'd had it with all 2.6.31 versions, official or self compiled.
I have now solved it by turning on nepomuk, which I had disabled (System settings > Desktop Search > Enable Nepomuk Semantic Desktop), a solution suggested in the forums: http://bbs.archlinux.org/viewtopic.php?id=60787. Perhaps it should be filed as a KDE bug, if this is confirmed
Comment by Jeremy LaCroix (jlacroix) - Monday, 19 October 2009, 16:36 GMT
I am having the exact same problem. I haven't tried enabling Nepomuk yet, but I can try that when I get home.
Comment by Jeremy LaCroix (jlacroix) - Wednesday, 21 October 2009, 15:23 GMT
Same problem even after enabling Nepomuk.
Comment by Kamil Neczaj (kneczaj) - Friday, 30 October 2009, 18:53 GMT
Making dir using konsole and mkdir refreshes view in dolphin, but when I download file with firefox, unpack file using ark or download file using linuxdc++ doesn't with or without nepomuk. However I've noticed that it works in kubuntu 9.10 so mayby we should search the solution there.
Comment by Kamil Neczaj (kneczaj) - Friday, 30 October 2009, 20:56 GMT
So on kubuntu 9.10 64 bit edition it works. There is kernel 2.6.31 with nvidia drivers 185.18.36.
Comment by Thomas Dziedzic (tomd123) - Saturday, 07 November 2009, 22:31 GMT
Same problem with the refresh of folder plasmoid.

kernel26 2.6.31.5-1
kdebase-runtime 4.3.3-1
Comment by Jeremy LaCroix (jlacroix) - Sunday, 08 November 2009, 21:49 GMT
Same problem with KDE 4.3.3.
Comment by Kamil Neczaj (kneczaj) - Friday, 13 November 2009, 19:23 GMT
It's not only folderview plasmoid. The issue can be noticed also in dolphin. If you rename, delete files using dolphin it refreshes the view, but if you use an external application, for example download file using firefox dolphin doesn't refresh unless you hit F5.
Comment by Jeremy LaCroix (jlacroix) - Friday, 13 November 2009, 21:41 GMT
I wonder, is it only GTK applications that have this problem? We may have discovered a new issue altogether.
Comment by Cedric Bellegarde (gnumdk) - Friday, 04 December 2009, 08:27 GMT
It's now fixed in Kde SVN for 4.4 release:
http://websvn.kde.org/?revision=1058169&view=revision
Comment by Andrea Scarpino (BaSh) - Friday, 15 January 2010, 12:57 GMT
is this still present with 2.6.32?

Loading...