Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#16155 - [amarok] Missing files in amarok collection

Attached to Project: Arch Linux
Opened by Federico Chiacchiaretta (baghera) - Saturday, 12 September 2009, 10:54 GMT
Last edited by Roman Kyrylych (Romashka) - Tuesday, 22 September 2009, 08:11 GMT
Task Type Bug Report
Category Packages: Testing
Status Closed
Assigned To Tobias Powalowski (tpowa)
Architecture x86_64
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
I just upgraded to amarok 2.1.80 in testing, removed all my old config and let amarok rebuild my collection from scratch. Now I miss something like 500 songs in my collection.

Additional info:
* amarok 2.1.80


Steps to reproduce:
1. Install amarok from testing
2. Rebuild collection.
This task depends upon

Closed by  Roman Kyrylych (Romashka)
Tuesday, 22 September 2009, 08:11 GMT
Reason for closing:  Upstream
Additional comments about closing:  fixed upstream, latest git version works properly
Comment by Tobias Powalowski (tpowa) - Saturday, 12 September 2009, 15:11 GMT
Could it be that you have no names for them?
You need to modify the playlist to list file names too, it tags are missing simply nothing is shown.
Comment by Federico Chiacchiaretta (baghera) - Sunday, 13 September 2009, 01:49 GMT
Filenames are in the same format for every single file in my collection, and they all have correct and complete id3 tags.
I can actually see missing files in Files section on the left, I can add them to playlist and they play just fine, but they're not added to Local Music.

Missing files are even from the same artist (i.e. I can find only 5 of the 7 albums from Radiohead I have) and they don't have any special font in filename.

I miss entire folders, not single files (I just noticed that now :)

Permissions are 644 on every single file.

And it worked just fine since I had amarok 2.1.1 . I also tried to build amarok from git but the problem is still there. (I just tried to downgrade now to amarok in [extra] and I don't miss any track: 2999 vs 2521 with 2.1.80).

If you need more info just ask, and really thank you for your help.

Loading...