Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#16138 - [kernel26] atheros wifi not functional with kernel 2.6.31

Attached to Project: Arch Linux
Opened by mikes (mechmg93) - Friday, 11 September 2009, 07:52 GMT
Last edited by Tobias Powalowski (tpowa) - Sunday, 28 February 2010, 10:03 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Tobias Powalowski (tpowa)
Thomas Bächler (brain0)
Isenmann Daniel (ise)
Architecture x86_64
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 4
Private No

Details

Description:

I upgraded my kernel26 from testing repo, in order to have 2.6.31 and although ath5k module is enabled, wicd finds no wireless spots. (with iwconfig i see a wlan0 interface )
I downgraded to latest kernel26 from core and everything is fine.

I cannot understand if it's a modules problem or wicd problem but i believe that the most possible is that it is an ath5k issue.




This task depends upon

Closed by  Tobias Powalowski (tpowa)
Sunday, 28 February 2010, 10:03 GMT
Reason for closing:  Fixed
Comment by Tobias Powalowski (tpowa) - Friday, 11 September 2009, 15:29 GMT
i use also ath5k it work still
Comment by Bernhard (dw) - Saturday, 12 September 2009, 19:16 GMT
I can confirm this. According to lspci I have an Atheros Communications Inc. AR928X Wireless Network Adapter (PCI-Express) (rev 01) which works well under 2.6.30 using the ath9k module. When upgrading to 2.6.31, I don't see a wlan0 device with iwconfig. Downgrading to 2.6.30 again makes the device working again.
Comment by Bernhard (dw) - Monday, 28 September 2009, 17:02 GMT
still doesn't work with 2.6.31.1 just for info :(
Comment by Thomas Bächler (brain0) - Wednesday, 30 September 2009, 16:21 GMT
lspci? dmesg? lsmod? any other useful info? It's really not useful to post a bug report without any information in it.
Comment by Bernhard (dw) - Wednesday, 30 September 2009, 17:17 GMT
ok, i didn't provide any info because I was afraid I was high-jacking this bugreport since I realized after posting that this was about ath5k not working. I will now open a seperate bug-report providing the needed info.
Comment by Bernhard (dw) - Wednesday, 30 September 2009, 17:48 GMT Comment by Gerardo Exequiel Pozzi (djgera) - Monday, 05 October 2009, 23:55 GMT
Probably this problem is solved now in 2.6.31.2 [#1]

"...big fixes, as does the ath5k and iwlwifi drivers. One might say that the patches for the iwlwifi drivers are a bit "bigger" than normal -stable material, but the wifi maintainer wants them, so he can handle the fallout..."

[#1] http://lwn.net/Articles/355485/
Comment by mikes (mechmg93) - Saturday, 10 October 2009, 13:53 GMT
i just upgraded to kernel 2.6.31.3 from core and the problem remains resulting in not having functional wireless.
Comment by Thomas Bächler (brain0) - Saturday, 10 October 2009, 14:03 GMT
Just re-stating this fact here won't change anything, you have to actually report this to the linux wireless developers and/or try if compat-wireless fixes it. There is nothing we can do here, except google for fixes and talk to upstream developers - which you can also do yourself, as you are the only one able to produce this bug.
Comment by mikes (mechmg93) - Saturday, 10 October 2009, 14:12 GMT
Dear Thomas,

when you know that ath5k and ath9k, two of the most common and famous modules in use today are not functional with latest kernel and move kernel 2.6.31.3 to core leaving a lot of people with no wireless there is no point in submitting bug reports in archlinux. It seems that i wasted my time since the beginning. Thanks for the tip. I will report upstream.
Comment by Thomas Bächler (brain0) - Saturday, 10 October 2009, 14:59 GMT
ath5k and ath9k work fine, for everyone except two people. These are two isolated issues which will not hold Arch's movement back.

That said, you didn't post any valuable information on tracking down the problem. dw did, but he has an obviously different bug.
Comment by mikes (mechmg93) - Saturday, 10 October 2009, 15:04 GMT
my duty is to report the bug. Arch developers duty is to ask me for further information. Excuse me for not knowing what info is needed here, but be sure that if someone asked me to post logs, command outputs etc.. i would have already done it.
Comment by Thomas Bächler (brain0) - Saturday, 10 October 2009, 15:13 GMT
I did ask for furhter information, but you didn't reply - dw replied, but his report was (as already mentioned) unrelated.
Comment by mikes (mechmg93) - Sunday, 11 October 2009, 10:25 GMT
yesterday i had the time to search again for this problem (fortunately i have a backup of previous kernel package in order to do my job).

So searching google i found that lots of people have problems with newer kernels, using different wireless modules.

At first i stopped using wicd, thinking that it may be the problem and set up my wireless connection through /etc/rc.conf. Trying to start network daemon giving :

#/etc/rc.d/network start

i got the following error :

SIOCSIFFLAGS: Unknown error 132

As you can see here :

https://bugs.launchpad.net/ubuntu/+source/linux/+bug/435141
http://bbs.archlinux.org/viewtopic.php?id=81930

this error is a common issue.

So after reading launchpad comments, i built rfkill from aur and gave the command :

#rfkill list

the output was :

0: tpacpi_bluetooth_sw: Bluetooth
Soft blocked: yes
Hard blocked: yes
1: phy0: Wireless LAN
Soft blocked: yes
Hard blocked: no



so after this i tried :

#rfkill unblock 1

and after that command i was able to scan for networks again. The problem now is that i see networks but i cannot connect(using wicd). Another issue is that wireless interface seems being down after a little time.

the following pastebin has all the information about my machine (dmesg and lspci)

http://pastebin.com/m50e9b905
Comment by Thomas Bächler (brain0) - Sunday, 11 October 2009, 11:51 GMT
I am currently trying to find out why a wireless interface would start in "soft blocked" mode - apparently, it has to do with the platform, not only the wireless. Still no idea why you wouldn't be able to connect.
Comment by Thomas Bächler (brain0) - Sunday, 11 October 2009, 11:58 GMT
I've been told this might be a bug in the thinkpad acpi driver - also not that on the launchpad report you posted, some guy said he had to enable his bluetooth to get wireless working, and yours is "hard blocked", so this might be related. Also, it's not supposed to start in soft killed mode. I don't have more than that right now.
Comment by c b (cb474) - Monday, 12 October 2009, 08:33 GMT
I'm also experiencing this problem with 2.6.31.3-1. I also get the "SIOCSIFFLAGS: Unknown error 132" error when running "ifconfig wlan0 up." I have an AR5212 card on a ThinkPad T61.

I'm having no trouble with madwifi though. And I had no trouble with ath5k in kernel 2.6.30 (except that it was really slow to scan).

If you look at the following thread, it seems like a lot more than two people are having this problem: http://bbs.archlinux.org/viewtopic.php?pid=634835. And it seems likely now that 2.6.31.3 has moved out of testing even more people are going to be effected.
Comment by Nicky726 (Nicky726) - Wednesday, 14 October 2009, 16:53 GMT
With 2.6.31.3 I also had "SIOCSIFFLAGS: Unknown error 132" with atheros AR8132 using ath9k driver on ASUS eee 1005. As my LAN was also not working I downgraded back to .30 kernel.
Comment by Freek (teek) - Wednesday, 18 November 2009, 14:58 GMT
Have the same but only on waking up from suspend to ram:
http://bugs.archlinux.org/task/16413
Comment by Gerardo Exequiel Pozzi (djgera) - Sunday, 28 February 2010, 00:20 GMT
status with latest 2.6.33?
Comment by mikes (mechmg93) - Sunday, 28 February 2010, 07:48 GMT
i just tested it with 2.6.33 and i keep having the same problem which is the following:

1. if i do not run rfkill unblock ath0 i cannot even see wireless networks via wicd
2. when i run rfkill unblock ath0, i am able to see all the wireless networks but when i try to connect, after some time i get a bad password error.

So once again i am back to madwifi. With ath_pci everything is ok.
Comment by c b (cb474) - Sunday, 28 February 2010, 09:23 GMT
I was having this problem and then, as stupid as it may sound, I realized the wireless switch on my ThinkPad was off. Madwifi works regardless of what position the switch is in. And ath5k didn't care about the switch position either, with older versions of the kernel. I'm not really sure if when I first had the problem with 2.6.31 it had anything to do with the switch. I don't recall, because that was months ago, but I'm pretty sure I checked the switch when the problem first developed. But now with 2.6.32 and the switch on ath5k seems to be okay. Madwifi still scans and makes much faster connections though. But occasionally a few access points won't work with madwifi and I have to switch to ath5k.
Comment by Freek (teek) - Sunday, 28 February 2010, 09:42 GMT
For me also everything works again niceliy with the newest kernel.

Loading...