Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#16110 - Kernel modules corrupted?

Attached to Project: Arch Linux
Opened by Lex Rivera (x-demon) - Wednesday, 09 September 2009, 11:53 GMT
Last edited by Tobias Powalowski (tpowa) - Sunday, 20 September 2009, 10:07 GMT
Task Type Bug Report
Category Kernel
Status Closed
Assigned To Tobias Powalowski (tpowa)
Thomas B├Ąchler (brain0)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

I can't insert i915 module as well as i810. First gives me "unknown symbol in module" sometimes with unknown symbol drm_* (basically drm-related troubles), and second gives backtrace log.
Intel gme945, arch installed from 2009.08 iso and fully upgraded.
Just got some mtrr related error? something like no mtrr found.

UPD: module loads on alternative kernel (kernel26-ice from aur)
This task depends upon

Closed by  Tobias Powalowski (tpowa)
Sunday, 20 September 2009, 10:07 GMT
Reason for closing:  Fixed
Comment by Jan de Groot (JGC) - Wednesday, 09 September 2009, 12:17 GMT
How do you load the modules? With insmod? or with modprobe? Insmod doesn't resolve module dependencies.
Comment by Lex Rivera (x-demon) - Wednesday, 09 September 2009, 12:30 GMT
modprobe. of course i tried running depmod -ae before inserting.
Comment by Jan de Groot (JGC) - Wednesday, 09 September 2009, 12:34 GMT
Is the kernel that you installed the same one that was booted? I can't reproduce your problems on my x86_64 and i686 systems, so this must be something specific to your setup.
Comment by Lex Rivera (x-demon) - Wednesday, 09 September 2009, 12:47 GMT
yes. With standart kernel i can't load intel (only intel) video modules. With -ice all works flawlessly. Btw, i get this error sometimes, maybe this is connected somehow?
ldconfig: file /usr/lib/libmcpp.so is truncated

ldconfig: file /usr/lib/libmcpp.so.0.3.0 is truncated

ldconfig: file /usr/lib/libmcpp.so.0 is truncated
Comment by Jan de Groot (JGC) - Wednesday, 09 September 2009, 12:51 GMT
I guess something is just corrupted on your system. Try reinstalling at least kernel26 and mcpp.
Comment by Lex Rivera (x-demon) - Wednesday, 09 September 2009, 13:02 GMT
i reinstalled world, huh. By the way, reinstalling mcpp solved problems with ldconfig. With kernel26 - nope. I even tried downloading it from another mirror. Filesystem is ext4, checked, clean.
Comment by Lex Rivera (x-demon) - Wednesday, 09 September 2009, 13:03 GMT
And another thing, installation performed fron netinst liveusb if this info needed.
Comment by Jan de Groot (JGC) - Wednesday, 09 September 2009, 13:16 GMT
Can you attach the output of dmesg after trying to modprobe the modules?
Comment by Tobias Powalowski (tpowa) - Sunday, 20 September 2009, 09:58 GMT
still an issue?
Comment by Lex Rivera (x-demon) - Sunday, 20 September 2009, 10:05 GMT
fixed in .31

Loading...