Pacman

Welcome to the Pacman bug tracker. Please search the current bugs and feature requests before filing a new one! Use advanced search and select "Search in Comments".

* Please select the correct category and version.
* Write a descriptive summary, background info, and provide a reproducible test case whenever possible.
Tasklist

FS#16108 - command to install optional dependencies

Attached to Project: Pacman
Opened by mattia (nTia89) - Wednesday, 09 September 2009, 08:06 GMT
Last edited by Rémy Oudompheng (remyoudompheng) - Tuesday, 24 May 2011, 06:16 GMT
Task Type Feature Request
Category Backend/Core
Status Closed
Assigned To No-one
Architecture All
Severity Medium
Priority Normal
Reported Version 3.3.0
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 6
Private No

Details

hi

why not implement a command , like "pacman -Sd ..."
that install optional dependencies ?
since "optdepends" is already implemented !!!
This task depends upon

Closed by  Rémy Oudompheng (remyoudompheng)
Tuesday, 24 May 2011, 06:16 GMT
Reason for closing:  Duplicate
Additional comments about closing:  Duplicate of FS#11337
Comment by Xavier (shining) - Wednesday, 09 September 2009, 08:21 GMT
Look at pacman -Sh . pacman -Sd already exists.

And how hard is it to do : pacman -S <optdepends> ?
Comment by Xavier (shining) - Wednesday, 09 September 2009, 08:25 GMT
In any cases, we need to wait for makepkg 3.4 which will ensure strict optdepends :
http://projects.archlinux.org/?p=pacman.git;a=commit;h=0845b2f13cef6db23a4a281976ec1374e93b7c4e

This will prevent all the problems listed there :  FS#16052  ,  FS#16053 

Then we will see for pacman 3.5 if we implement something like this.
So don't hold your breath.
Comment by mattia (nTia89) - Wednesday, 09 September 2009, 08:39 GMT
thanks

Loading...