Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#16037 - [texlive-bin] Dangling symlinks in /usr/bin

Attached to Project: Arch Linux
Opened by Patrick McCarty (pnorcks) - Saturday, 05 September 2009, 18:59 GMT
Last edited by Francois Charette (Firmicus) - Friday, 11 September 2009, 09:09 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Francois Charette (Firmicus)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

In texlive-bin 2009.1-1, there are some dangling symlinks in /usr/bin. They are harmless, of course, but they are serving no purpose (AFAIK).

Steps to reproduce:
1) Run the command "chkdupexe" (part of the util-linux-ng package)
2) Many dangling symlinks are found that belong to texlive-bin. Below is the list, with the non-existent path that each symlink to.

/usr/bin/ht -> /usr/share/texmf-dist/scripts/tex4ht/ht.sh
/usr/bin/htcontext -> /usr/share/texmf-dist/scripts/tex4ht/htcontext.sh
/usr/bin/htlatex -> /usr/share/texmf-dist/scripts/tex4ht/htlatex.sh
/usr/bin/htmex -> /usr/share/texmf-dist/scripts/tex4ht/htmex.sh
/usr/bin/httex -> /usr/share/texmf-dist/scripts/tex4ht/httex.sh
/usr/bin/httexi -> /usr/share/texmf-dist/scripts/tex4ht/httexi.sh
/usr/bin/htxelatex -> /usr/share/texmf-dist/scripts/tex4ht/htxelatex.sh
/usr/bin/htxetex -> /usr/share/texmf-dist/scripts/tex4ht/htxetex.sh
/usr/bin/mkgrkindex -> /usr/share/texmf-dist/scripts/mkgrkindex/mkgrkindex
/usr/bin/mk4ht -> /usr/share/texmf-dist/scripts/tex4ht/mk4ht.pl
/usr/bin/epspdftk -> /usr/share/texmf-dist/scripts/epspdf/epspdftk
/usr/bin/pst2pdf -> /usr/share/texmf-dist/scripts/pst2pdf/pst2pdf.pl
/usr/bin/epspdf -> /usr/share/texmf-dist/scripts/epspdf/epspdf
/usr/bin/ulqda -> /usr/share/texmf-dist/scripts/ulqda/ulqda.pl
/usr/bin/htcontext -> /usr/share/texmf-dist/scripts/tex4ht/htcontext.sh
/usr/bin/ebong -> /usr/share/texmf-dist/scripts/bengali/ebong.py
This task depends upon

Closed by  Francois Charette (Firmicus)
Friday, 11 September 2009, 09:09 GMT
Reason for closing:  Fixed
Additional comments about closing:  Those symlinks have now been moved from texlive-bin to their respective packages.
Comment by Francois Charette (Firmicus) - Tuesday, 08 September 2009, 07:50 GMT
This is not a bug, this is a feature! :) Well, sort of...
texlive-bin contains a bunch of symlinks for scripts in texlive-core, but also a few other for some texlive-* packages, such as texlive-htmlxml.
Currently they are all put under texlive-bin for convenience, but with the next release of texlive-bin I will indeed move them to their respective packages.

Loading...