Pacman

Welcome to the Pacman bug tracker. Please search the current bugs and feature requests before filing a new one! Use advanced search and select "Search in Comments".

* Please select the correct category and version.
* Write a descriptive summary, background info, and provide a reproducible test case whenever possible.
Tasklist

FS#1592 - IgnoreGroup

Attached to Project: Pacman
Opened by Nikos Kouremenos (zeppelin) - Tuesday, 05 October 2004, 18:18 GMT
Last edited by Dan McGee (toofishes) - Wednesday, 14 November 2007, 22:38 GMT
Task Type Feature Request
Category General
Status Closed
Assigned To Aaron Griffin (phrakture)
Dan McGee (toofishes)
Architecture All
Severity Low
Priority Normal
Reported Version 2.9.8
Due in Version 3.1.0
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

so gnome (80MB) moved from testing to current.
well I have to redownload to get the exact packages? Well I don't think so.
I tried
IgnorePkg = gnome gnome-extra

but doens't like me
so a feature request would be IgnoreGroup
cause it really hurted to manually type all this:
IgnorePkg = atk bug-buddy control-center eel eog evolution evolution-data-server IgnorePkg = file-roller gail gal gcalctool gconf gconf-editor gedit
IgnorePkg = gnome-applets gnome-common gnome-desktop gnome-games gnome-icon-theme
IgnorePkg = gnome-keyring gnome-media gnome-panel
IgnorePkg = gnome-session gnome-system-monitor
IgnorePkg = gnome-terminal gnome-themes gnome-themes-extras gnome-utils gnome-vfs IgnorePkg = gpdf gst-plugins
IgnorePkg = gthumb gtkhtml gtksourceview hal
IgnorePkg = libbonobo libbonoboui libgnome
IgnorePkg = libgnomecanvas libgnomecups libgnomeprint
IgnorePkg = libgnomeprintui libgnomeui libgtop
IgnorePkg = libidn librsvg libsoup libwnck
IgnorePkg = libxklavier nautilus nautilus-cd-burner
IgnorePkg = yelp zenity
This task depends upon

This task blocks these from closing
 FS#8109 - Pacman 3.1 Release Roadmap 
Closed by  Dan McGee (toofishes)
Wednesday, 14 November 2007, 22:38 GMT
Reason for closing:  Implemented
Additional comments about closing:  Implemented and tested in GIT (3.1)
Comment by Sebastian Pigulak (dreameen) - Saturday, 19 March 2005, 14:12 GMT
It's been a while since this feature request was opened. I'm really looking forward to its implementation. It is not so nice to guess/add all packages related to kde/gnome/xfce4 etc.. and then adding them to IgnorePkg line. Just imagine how ugly it looks now;) Anyway, I just wanted to refresh this request as i'm sure many users will appreciate it, it shouldn't be too hard implement either.

Regards.
Comment by Nikos Kouremenos (zeppelin) - Saturday, 19 March 2005, 14:25 GMT
Sebastian, I while waiting got a DSL :) so not a problem now eventhough I know a lot of people (most of the people) in Greece having Dialup (56k or 64k ISDN)

To the devs: If you have a enough generalized way of doing this, then plz add HoldGroup too
Comment by arjan timmerman (blaasvis) - Sunday, 26 March 2006, 11:43 GMT
hmmm this is a bug left over from the -t1 packages stuff...

Judd, do you think this is still needed ?
Comment by Nikos Kouremenos (zeppelin) - Sunday, 26 March 2006, 18:53 GMT
my reason was testing repo yea. but it's good to have IgnoreGroup and HoldGroup, else the concept of groups is not used 100%
Comment by Judd Vinet (judd) - Monday, 27 March 2006, 06:10 GMT
This one can wait til pacman3 comes out. I'm trying to avoid new features in pacman2 now that pacman3 is the focus of development.
Comment by Dan McGee (toofishes) - Tuesday, 08 May 2007, 07:12 GMT
This one is old but seems like a decent idea. Anyone willing to give it a try for implementation in pacman3? It isn't on the top of my priority list.
Comment by h├ęctor (hacosta) - Sunday, 17 June 2007, 05:23 GMT
a commandline option would be nice too pacman -Su --ignore-group <group>
Comment by Aaron Griffin (phrakture) - Friday, 28 September 2007, 16:01 GMT
This looks worthwhile for 3.1
Comment by Dan McGee (toofishes) - Sunday, 11 November 2007, 18:10 GMT
  • Field changed: Status (Assigned → Requires Testing)
Finally in GIT thanks to Nathan. Yay for closing way old requests.

Loading...