Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#15917 - [pinentry] Version 0.7.6 segfaults

Attached to Project: Arch Linux
Opened by Adrian C. (anrxc) - Wednesday, 12 August 2009, 14:18 GMT
Last edited by Tobias Powalowski (tpowa) - Sunday, 29 August 2010, 11:08 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Tobias Powalowski (tpowa)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description: With the last pinentry upgrade came a new problem. The entry window crashes if it looses focus while waiting for input. I can reproduce it every time, if I focus another window it will crash. I am using pinentry-gtk2. Rebuilding the package didn't help.

Additional info:
* Packages: pinentry 0.7.6-1, ncurses 5.7-2, libcap 2.16-3
* GTK version: gtk2 2.16.5-1
* System log:
kernel: pinentry-gtk-2[7311]: segfault at 50 ip b7c675be sp bfabc8c0 error 4 in libgdk-x11-2.0.so.0.1600.5[b7c09000+88000]
kernel: pinentry-gtk-2[7315]: segfault at 50 ip b7b875be sp bfd331e0 error 4 in libgdk-x11-2.0.so.0.1600.5[b7b29000+88000]
kernel: pinentry-gtk-2[7317]: segfault at 50 ip b7cb55be sp bfc289a0 error 4 in libgdk-x11-2.0.so.0.1600.5[b7c57000+88000]
This task depends upon

Closed by  Tobias Powalowski (tpowa)
Sunday, 29 August 2010, 11:08 GMT
Reason for closing:  Fixed
Additional comments about closing:  0.8.0-2
Comment by Adrian C. (anrxc) - Sunday, 01 November 2009, 14:06 GMT
Still happens with pinentry 0.7.6 and gtk2 2.18.3. Problem only appears if the "no-grab" option is used (i.e. in gpg-agent.conf).

Reproducing the problem:

$ echo "GETPIN" | pinentry-gtk-2 -g

- it segfaults on focus change
- avoiding the problem is a matter of omitting -g



Comment by Gerardo Exequiel Pozzi (djgera) - Sunday, 01 November 2009, 20:55 GMT
  • Field changed: Category (Packages: Extra → Upstream Bugs)
There is a fix for this issue here (but is for old version 0.7.4): http://marc.info/?l=gpa-dev&m=120198836601383&w=2
Comment by Thomas Dziedzic (tomd123) - Friday, 08 January 2010, 19:19 GMT
I can still reproduce this bug.
Comment by Adrian C. (anrxc) - Wednesday, 24 February 2010, 17:34 GMT
> There is a fix for this issue here (but is for old version 0.7.4)

That code is already in 0.7.6 (and it doesn't make a difference as we already know).
Comment by Tobias Powalowski (tpowa) - Friday, 30 April 2010, 06:39 GMT
status in 0.8?
Comment by Thomas Dziedzic (tomd123) - Friday, 30 April 2010, 06:45 GMT Comment by Thomas Dziedzic (tomd123) - Wednesday, 07 July 2010, 05:02 GMT Comment by Thomas Dziedzic (tomd123) - Wednesday, 07 July 2010, 05:15 GMT
Attached patch for pinentry and also the source package that has the patch applied.
Comment by Thomas Dziedzic (tomd123) - Wednesday, 07 July 2010, 15:45 GMT
btw, I'm not sure if I was clear, but the patch fixes the bug.

Loading...