Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#15779 - Upgrade to kde 4.3.0 fails due to conflicts with existing 4.2 plasma packages

Attached to Project: Arch Linux
Opened by Stefan (Wauzenplauz) - Tuesday, 04 August 2009, 07:53 GMT
Last edited by Pierre Schmitz (Pierre) - Thursday, 06 August 2009, 02:32 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Pierre Schmitz (Pierre)
Architecture i686
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 4
Private No

Details

Description:
When trying to upgrade from kde 4.2 to 4.3 pacman complains about conflicting libs (kde-plasma-addons-libs)
(...)
:: kde-meta-kdeplasma-addons: steht im Konflikt mit kdeplasma-addons-libs
(...)

Additional info:
* kdeplasma-addons 4.2.4-1 (current installation)


Steps to reproduce:
Run pacman -Syu with uptodate mirror (e.g. ftp.archlinux.org)
This task depends upon

Closed by  Pierre Schmitz (Pierre)
Thursday, 06 August 2009, 02:32 GMT
Reason for closing:  Fixed
Comment by Pierre Schmitz (Pierre) - Tuesday, 04 August 2009, 07:57 GMT
Could you try with kde-meta-* 4.3-5?
Comment by Holger Vogel (Skittles) - Tuesday, 04 August 2009, 08:21 GMT
The conflict still exists. I think the problem is that kde-meta-kdeplasma-addons AND kdeplasma-addons-libs
provide kdeplasma-addons-dataengines and conflict with this package.
Comment by Holger Vogel (Skittles) - Tuesday, 04 August 2009, 08:23 GMT
well, but i tried it with -4, -5 isn't in the repos yet
Comment by Holger Vogel (Skittles) - Tuesday, 04 August 2009, 09:19 GMT
seems to work here
Comment by Philipp Ruess (iDeJ) - Tuesday, 04 August 2009, 13:21 GMT
i can confirm, having the same problem here
Comment by Pierre Schmitz (Pierre) - Tuesday, 04 August 2009, 15:25 GMT
This does not really help. Just tell me if it does work with kde-meta-* 4.3-5 or not. I know that previuos versions are broken.
Comment by Stefan (Wauzenplauz) - Tuesday, 04 August 2009, 17:57 GMT
Currently this seems to work on my side. No change in mirror or kde-packages. The only difference between those two attempts was to run the second upgrade from within kde some hours later.
Comment by Jon (mimir) - Tuesday, 04 August 2009, 19:01 GMT
Just wanted to add that for me the update works. It didnt earlier today but i tried to change mirror and now works when using:
ftp://mir1.archlinuxfr.org/archlinux/$repo/os/i686

Loading...