Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#15665 - [virtualbox-ose] 2.6.30 kernel in arch linux causes virtualbox to crash if used as a guest

Attached to Project: Community Packages
Opened by Anish Bhatt (anish) - Friday, 24 July 2009, 08:02 GMT
Last edited by Ionut Biru (wonder) - Friday, 14 August 2009, 15:31 GMT
Task Type Bug Report
Category
Status Closed
Assigned To Ionut Biru (wonder)
Geoffroy Carrier (gcarrier)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description: the 2.6.30 kernel in arch linux does not play well as a guest in virtualbox. Using the 2.6.30 kernel results in vbox crashing.

bug report from virtualbox here http://www.virtualbox.org/ticket/2149

the bug report only has archlinux guests. might be a problem with the 2.6.30 kernel as a whole, no other distros are shipping 2.6.30, which might explain the lack of other guest distros. Problem is seen only after upgrade to 2.6.30, the iso installs & runs fine until then, which would suggest it many not be a virtualbox issue.

Crash is seen right in the initial stages of kernel boot, not sure what log files can be obtained at that stage, but cab provide any if needed.

Additional info:
* package version(s)
* config and/or log files etc.


Steps to reproduce:
This task depends upon

Closed by  Ionut Biru (wonder)
Friday, 14 August 2009, 15:31 GMT
Reason for closing:  Fixed
Additional comments about closing:  3.0.4-2
Comment by Roman Kyrylych (Romashka) - Saturday, 25 July 2009, 15:56 GMT
From crash logs in upstream bugreport it looks like a problem is in VirtualBox, not in our kernel package.
I'm moving this to Community Packages project to keep track of this so fix virtualbox-ose can be fixed with a patch as soon as it appears in VirtualBox SVN repo, without waiting for a bugfix release.
Comment by Ionut Biru (wonder) - Friday, 07 August 2009, 12:43 GMT
still present in 3.0.4?
Comment by Andre Ramaciotti (andreramaciotti) - Sunday, 09 August 2009, 22:44 GMT
It still crashes here.
Comment by Matti Eiden (snaipperi) - Wednesday, 12 August 2009, 18:20 GMT
"fixed in SVN/3.0.6" (VirtualBox)
Comment by Martin Imobersteg (bugix) - Friday, 14 August 2009, 12:20 GMT
please apply the attached patch.
Comment by Ionut Biru (wonder) - Friday, 14 August 2009, 13:52 GMT
try virtualbox-ose-3.0.4-2 and report back
Comment by maxi jac (maxi_jac) - Friday, 14 August 2009, 15:30 GMT
3.0.4-1 was not working with 2.6.30 installer
Now 3.0.4-2 works ! ;)

Loading...