Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#15552 - [xbmc] Severe slowdown after upgrade to libjpeg7

Attached to Project: Community Packages
Opened by Ralf Barth (Haggy) - Friday, 17 July 2009, 23:55 GMT
Last edited by Dan Griffiths (Ghost1227) - Tuesday, 12 January 2010, 06:38 GMT
Task Type Bug Report
Category
Status Closed
Assigned To Sergej Pupykin (sergej)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 8
Private No

Details

Description:

After the upgrade to libjpeg7, xbmc/xbmc-svn suffers from a severe slowdown in loading jpeg images. While loading, cpu maxes out at 100% and it takes about 2-3 seconds to load a 1920x1080 image in the GUI. Previous release 6b had no issues and loading was practically instant with this release.

Additional info:
libjpeg 7-1 installed via pacman from [extra]

Steps to reproduce:
* Compile xbmc-svn against libjpeg6 (http://aur.archlinux.org/packages.php?ID=20156)
* Have it use some fanart images / album covers (get fetched automatically)
* Result: Snappy gui, no slowdown while browsing albums/movies
* Then build xbmc-svn against libjpeg7
* Browse through the albums/movies
* Result: Sluggish, unresponsive, high cpu load.

Maybe this can only be fixed upstream. I would be pleased if anyone can at least confirm the slowdown for any other package.
This task depends upon

Closed by  Dan Griffiths (Ghost1227)
Tuesday, 12 January 2010, 06:38 GMT
Reason for closing:  Fixed
Additional comments about closing:  Fixed with gigapikseli's patch, thanks!
Comment by Florian Engelhardt (flowcontrol) - Sunday, 19 July 2009, 19:26 GMT
Same here
Comment by Matt Wagner (Echo) - Sunday, 19 July 2009, 19:48 GMT
Pretty much same situation here. Higher than normal cpu usage & slow response re:loading background images.
Comment by Ralf Barth (Haggy) - Sunday, 19 July 2009, 19:52 GMT
Note: Problem is most obvious with skins that have a "wall view" or lots of smaller thumbnails like Aeon or Mediastream. However, this is not skin dependent.
Comment by Philippe Cherel (Aerandir53) - Sunday, 26 July 2009, 09:28 GMT
Same problem here with Aeon skin.
Comment by Tiago Teixeira (TigTex) - Tuesday, 28 July 2009, 17:29 GMT
Same problem with my pentium 4 3.0HT. Used to be smooth. Now it's slow.
Comment by Ralf Barth (Haggy) - Thursday, 30 July 2009, 10:10 GMT
Just a shot in the dark: Does anyone of you guys have this problem with a different gpu than nvidia and/or the nvidia drivers installed? I cannot reproduce the slowdown on an old P4 with the FOSS radeon drivers.
Comment by Hans-Peter Sarstrom (hps) - Thursday, 30 July 2009, 12:21 GMT
The issue is, like Haggy said, most notable using Wall View in I.E. Aeon.

You can literally see every image load. And we established that the speed of your system doesn't really matter as I'm on a quite recent system with I7 and GTX260 gfx.
Also I'm running XFCE.

And as I am using NVIDIA drivers, that might just be the case, I've seen all kinds of strangeness associated with those before.
Comment by Hans-Peter Sarstrom (hps) - Thursday, 30 July 2009, 12:50 GMT
Just tested upgrading to latest beta drivers (190.18). That didn't change anything.
Comment by Philippe Cherel (Aerandir53) - Friday, 31 July 2009, 15:44 GMT
Tried with a laptop using Intel integrated graphics controller (GM965/GL960) and Core 2 Duo T7250@2.00GHz. Same problem with aeon skin and wall view , this is the only non-nvidia card I have.
Comment by ViNS (vins) - Monday, 07 September 2009, 10:25 GMT
Same problem here on asrock ION 330 nettop with VDPAU enabled.
Comment by Brad Gordon (rpgcyco) - Wednesday, 09 September 2009, 07:13 GMT
I am also experiencing this issue. I have a NVIDIA graphics card (8400GS).
Comment by Laszlo Papp (djszapi) - Saturday, 07 November 2009, 08:23 GMT
same issue with nvidia integrated vga card, nvidia driver, and core2duo 2Ghz intel processor.
Comment by Glenn Matthys (RedShift) - Sunday, 22 November 2009, 15:33 GMT
Has anyone reported this upstream?
Comment by Ralf Barth (Haggy) - Monday, 23 November 2009, 11:06 GMT
Not yet - and not to libjpeg. I talked to the xbmc devs about the problem so they're aware. But as Arch and Gentoo seem to be the only distros that ship libjpeg7 (even Ubuntu 10.04 will still ship libjpeg6) there's little to no priority for this issue. Anyway i'll create a ticket over at xbmc.org.
Comment by Antti Oja (gigapikseli) - Monday, 11 January 2010, 17:18 GMT
Patch which fixes the problem. It has not been committed to the trunk yet.
Comment by Ralf Barth (Haggy) - Monday, 11 January 2010, 17:20 GMT
OMFG! Really? Thanks a ton... is this from official xbmc repository or your patch?
Comment by Antti Oja (gigapikseli) - Monday, 11 January 2010, 17:21 GMT
Patch was originally posted on http://xbmc.org/trac/ticket/7810#comment:4

Loading...