Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#15531 - packages depend on libjpeg.so.6

Attached to Project: Arch Linux
Opened by Andreas Baumann (andreas_baumann) - Thursday, 16 July 2009, 14:55 GMT
Last edited by Roman Kyrylych (Romashka) - Thursday, 16 July 2009, 17:25 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description: jpeg major release change in library

ldd `which ristretto` | grep 'not found'
libjpeg.so.62 => not found

So many things break upstream after an upgrade to major library
release 7. How do we guarantee that all packages using libjpeg-6
produce new packages?

This task depends upon

Closed by  Roman Kyrylych (Romashka)
Thursday, 16 July 2009, 17:25 GMT
Reason for closing:  Not a bug
Comment by Allan McRae (Allan) - Thursday, 16 July 2009, 15:04 GMT
Make sure your system is fully up to date. All packages in [extra] and most in [community] have been rebuilt.
Comment by Ionut Biru (wonder) - Thursday, 16 July 2009, 15:49 GMT
are you sure that ristretto binary come from a package that is in core/extra/community?
if is in aur you should rebuild it.
Comment by Andreas Baumann (andreas_baumann) - Thursday, 16 July 2009, 17:06 GMT
My ristretto is from 'extra'..
Comment by Andreas Baumann (andreas_baumann) - Thursday, 16 July 2009, 17:09 GMT
a pacman -R ristretto, pacman -S ristretto solved the problem.
Most likely I had an old version lying around somehow. Sorry for the trouble.

Loading...