Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#15521 - Libjpeg.so.62 not present

Attached to Project: Arch Linux
Opened by Patrick Kelly (kameo76890) - Wednesday, 15 July 2009, 19:14 GMT
Last edited by Roman Kyrylych (Romashka) - Wednesday, 15 July 2009, 20:14 GMT
Task Type Bug Report
Category System
Status Closed
Assigned To No-one
Architecture x86_64
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description: libjpeg.so.62 is not present on a basic install. Extreme usability issues in KDE.


Additional info:
Package Version: libjpeg 7-1


Steps to reproduce:
FTP install from archlinux's base server. 2 hard disks, 1 80GB IDE (/ EXT4) and 1 320GB SATA (/home EXT4). Base packages installed only. Both US locals, and all three de_DE locals. All other config files left untouched. Upon a finished installation fsck reported /dev/sda (/) was 0.1% uncontiguous, and rebooted. No issues upon reboot, and logged in as root. Added the Charkra-project hosted KDEmod repos to my pacman.conf. Then used to following commands; pacman -Syu, pacman -S xorg, pacman -S nvidia, nvidia-xconfig --add-argb-glx-visuals, pacman -S kdemod, adduser, reboot. During all installations, adduser, and upon reboot no issues were reported. KDM ran normally and upon loading KDE there was no background. Loading Konqueror raised the following error:

There was an error loading the module About-Page for Konqueror.
The diagnostics is:
Cannot load library /usr/lib/kde4/konq_aboutpage.so: (libjpeg.so.62: cannot open shared object file: No such file or directory)

I attempted to build from source, both with Archlinux's packagebuild and strait from the source. Both attempts at compilation resulted in kernel panics.
This task depends upon

Closed by  Roman Kyrylych (Romashka)
Wednesday, 15 July 2009, 20:14 GMT
Reason for closing:  Not a bug
Additional comments about closing:  please report this to KDEmod developers
Comment by Aaron Griffin (phrakture) - Wednesday, 15 July 2009, 19:34 GMT
Does this happen with the official KDE packages? If so then you're going to have to report this bug to the Chakra guys
Comment by Eric Belanger (Snowman) - Wednesday, 15 July 2009, 19:59 GMT
official package is OK:
$ ldd /usr/lib/kde4/konq_aboutpage.so |grep jpeg
libjpeg.so.7 => /usr/lib/libjpeg.so.7 (0x00007f0b2c1af000)


As Aaron said, report that bug to the Chackra guys.

Loading...