Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#15506 - [thunar] broken with new libjpeg

Attached to Project: Arch Linux
Opened by Bruno Schmidt Marques (bruno.marques.br) - Tuesday, 14 July 2009, 17:31 GMT
Last edited by Allan McRae (Allan) - Wednesday, 15 July 2009, 02:05 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Andreas Radke (AndyRTR)
Allan McRae (Allan)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:
I upgrade Arch Linux and it upgrades libjpeg from 6b to 7-1. When I try to start Xfdesktop, it returns that error:

xfdesktop: error while loading shared libraries: libjpeg.so.62: cannot
open shared object file: No such file or directory

Additional info:
* libjpeg 7-1

Steps to reproduce:
-Install XFCE
-Upgrade libjpeg to 7-1, that's in the repositories
-Start XFCE
-Open a terminal
-Try "xfdesktop"
This task depends upon

Closed by  Allan McRae (Allan)
Wednesday, 15 July 2009, 02:05 GMT
Reason for closing:  Fixed
Additional comments about closing:  thunar-1.0.1-4
Comment by Roman Kyrylych (Romashka) - Tuesday, 14 July 2009, 17:39 GMT
do you have all Xfce packages and their dependencies updated to the latest versions?
Comment by Bruno Schmidt Marques (bruno.marques.br) - Tuesday, 14 July 2009, 17:46 GMT
Yes, I have all XFCE's dependencies correctly installed. I was using the newer version of repositories (core, extra and community), upgrade all system (pacman -Syu), and Xfdesktop don't start anymore. A temporary solution is create a symlink:
ln -s /usr/lib/libjpeg.so.7 /usr/lib/libjpeg.so.62
Comment by Roman Kyrylych (Romashka) - Tuesday, 14 July 2009, 17:53 GMT
Andy, can you confirm this?
Comment by Gerardo Exequiel Pozzi (djgera) - Tuesday, 14 July 2009, 18:20 GMT
run with the application with

LD_DEBUG=files xfdesktop

to see what is the library that tries to load the old libjpeg.
Comment by Gerardo Exequiel Pozzi (djgera) - Tuesday, 14 July 2009, 18:38 GMT
  • Field changed: Summary ([xfdesktop] broken with new libjpeg → [thunar] broken with new libjpeg)
  • Field changed: Status (Unconfirmed → Assigned)
  • Task reassigned to Allan McRae (Allan), Andreas Radke (AndyRTR)
@Bruno probably you have thunar-1.0.1-3 and not -2 (that is the new and linked with libjpeg)

18089: file=libjpeg.so.62 [0]; needed by /usr/lib/libthunar-vfs-1.so.2 [0]

mmm, rare, seems that some is wrong in the movement testing -> extra

old mirrors have thunar-1.0.1-3 (that have an additional patch) but the new pkg is thunar-1.0.1-2 (without the patch)

in the thunar trunk is @ -3, in the repo is @ -2

Assigning to Allan because is the latest packager.

Solution: rebuild thunar from trunk updating to revision -4
Comment by Bruno Schmidt Marques (bruno.marques.br) - Tuesday, 14 July 2009, 20:16 GMT
Gerardo Exequiel Pozzi (djgera)

You's right. I'm using thunar 1.0.1-3 package. I removed package 1.0.1-3, and installed 1.0.1-2 and all is working now.
Thanks
Comment by Gavin Bisesi (Daenyth) - Tuesday, 14 July 2009, 22:03 GMT
Why is -2 the new package?
Comment by Gerardo Exequiel Pozzi (djgera) - Tuesday, 14 July 2009, 22:12 GMT
@Daenyth, by race condition between Andy and Allan :P

........
r43907 | allan | 2009-06-30 06:49:48 +0000 (Di, 30 Jun 2009) | 2 lines

upgpkg: thunar 1.0.1-2
libjpeg soname bump rebuild
........
r45465 | andyrtr | 2009-07-12 10:04:32 +0000 (So, 12 Jul 2009) | 2 lines

upgpkg: thunar 1.0.1-3
fix #15460

Loading...