Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#15420 - [archboot] Archboot requires unexisting portmap package

Attached to Project: Arch Linux
Opened by Mihai Militaru (akephalos) - Monday, 06 July 2009, 21:00 GMT
Last edited by Tobias Powalowski (tpowa) - Wednesday, 16 September 2009, 07:08 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Tobias Powalowski (tpowa)
Architecture x86_64
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

Description:
'Archboot' installation fails with this error:

error: cannot resolve "portmap>=6.0-2", a dependency of "archboot"
error: failed to prepare transaction (could not satisfy dependencies)
:: archboot: requires portmap>=6.0-2

Additional info:
* archboot version: extra/archboot 2009.05-2; portmap version: unexistent
* I'm running arch x86-64 version


Steps to reproduce:
* Install the 'archboot' package with pacman.

Please change architecture to 'all' if you can reproduce it on 32 bit, as well.
This task depends upon

Closed by  Tobias Powalowski (tpowa)
Wednesday, 16 September 2009, 07:08 GMT
Reason for closing:  Fixed
Additional comments about closing:  archboot-2009.09-1
Comment by Gerardo Exequiel Pozzi (djgera) - Monday, 06 July 2009, 21:04 GMT
Use the git version of archboot, there are many fixes.

git clone git://projects.archlinux.org/archboot.git
Comment by Roman Kyrylych (Romashka) - Monday, 06 July 2009, 23:47 GMT
@Tobias: can this be closed as Fixed?
Comment by Xavier (shining) - Tuesday, 07 July 2009, 08:06 GMT
The archboot package always have missing dependencies : http://www.archlinux.org/pipermail/arch-dev-public/2009-July/012232.html
Is it really necessary to have this package in the repo?

Comment by Gerardo Exequiel Pozzi (djgera) - Tuesday, 07 July 2009, 19:33 GMT
Adding to comment from Xavier: yes and maybe the same is applied to 'archiso' pkg in the repo (is not update since 2008-09). Always is needed to use the git repo to works correctly.
Comment by Tobias Powalowski (tpowa) - Friday, 10 July 2009, 09:09 GMT
shining, the problem is that i cannot move archboot because of vi/vim in testing, the depends have been fixed in testing already
Comment by Xavier (shining) - Saturday, 05 September 2009, 11:07 GMT
what about only having the package in testing then ?

I still don't understand the benefit of a package in extra which is always broken dependency-wise and never installable.

there was again a report on the ML : http://mailman.archlinux.org/pipermail/arch-general/2009-September/007306.html
and of course archboot keep showing up in all my integrity check runs.

By the way, I have nothing against archboot itself : I think it's good to have an alternative iso when the official one fails or is a bit outdated.
Only against the extra/archboot package :)
Comment by Tobias Powalowski (tpowa) - Saturday, 05 September 2009, 14:54 GMT
Well, i try to keep it up to date with testing, the only reason why it is not working right now is still the vim package which is in testing since may or so.
I hope this get solved very soon now.
Comment by Tobias Powalowski (tpowa) - Wednesday, 16 September 2009, 07:08 GMT
finally vim moved bump to new sane depends :)

Loading...