Arch Linux

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#15386 - [foomatic-db] /usr/lib/cups/filter/foomatic-rip failed

Attached to Project: Arch Linux
Opened by solsTiCe (zebul666) - Sunday, 05 July 2009, 17:35 GMT
Last edited by Andreas Radke (AndyRTR) - Wednesday, 05 August 2009, 18:25 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Tobias Powalowski (tpowa)
Andreas Radke (AndyRTR)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No



when i try to print i got nothing, and i found on the printer page in cups(localhost:631 printer tab) that the printer is stopped with error "/usr/lib/cups/filter/foomatic-rip failed"

i have foomatic-filter installed. and hplip too (using 3.9.6b hoping it will fix this issue i already got with 3.9.4b)
it seems to begin to happen since the last upgrade of foomatic-filters (or foomatic-db-hpijs or foomatic-db).

i have a problem with a cartridge filled but shown as empty by hp-levels. so it seems to have a hardware problem on the printer but don't think that cause that weird foomatic-rip failed error. because i could print in ubuntu 9.04 without problem. and without the printer to stop every time i try to print.

so something is wrong (again) on archlinux.

when i set the loglevel of cupsd to debug i can see something like
[...D [05/Jul/2009:18:41:28 +0200] [Job 206] Starting renderer with command: "gs -sstdout=%stderr -dBATCH -dPARANOIDSAFER -dQUIET -dNOPAUSE -sDEVICE=ijs -sIjsServer=hpijs -sDeviceManufacturer="HEWLETT-PACKARD" -sDeviceModel="deskjet 5600" -dDEVICEWIDTHPOINTS=595 -dDEVICEHEIGHTPOINTS=842 -dDuplex=false -r300 -sIjsParams=Quality:Quality=4,Quality:ColorMode=2,Quality:MediaType=0,Quality:PenSet=2,PS:MediaPosition=7 -dIjsUseOutputFD -sOutputFile=%stdout -_"
D [05/Jul/2009:18:41:28 +0200] [Job 206] Starting process "kid3" (generation 1)
D [05/Jul/2009:18:41:28 +0200] [Job 206] Starting process "kid4" (generation 2)
D [05/Jul/2009:18:41:28 +0200] [Job 206] JCL: 12345X@PJL
D [05/Jul/2009:18:41:28 +0200] [Job 206] <job data>
D [05/Jul/2009:18:41:28 +0200] [Job 206]
D [05/Jul/2009:18:41:28 +0200] [Job 206] Starting process "renderer" (generation 2)
D [05/Jul/2009:18:41:28 +0200] [Job 206]
D [05/Jul/2009:18:41:28 +0200] [Job 206] Closing renderer
D [05/Jul/2009:18:41:28 +0200] [Job 206] sh: hpijs : commande introuvable
D [05/Jul/2009:18:41:28 +0200] [Job 206] GPL Ghostscript 8.64: Can't start ijs server "hpijs"
D [05/Jul/2009:18:41:28 +0200] [Job 206] **** Unable to open the initial device, quitting.
D [05/Jul/2009:18:41:28 +0200] [Job 206] renderer exited with status 1
D [05/Jul/2009:18:41:28 +0200] [Job 206] Possible error on renderer command line or PostScript error. Check options.kid3 exited with status 3
D [05/Jul/2009:18:41:28 +0200] [Job 206] Process is dying with "Error closing renderer
D [05/Jul/2009:18:41:28 +0200] [Job 206] ", exit stat 3
D [05/Jul/2009:18:41:28 +0200] [Job 206] Cleaning up...
E [05/Jul/2009:18:41:28 +0200] PID 2351 (/usr/lib/cups/filter/foomatic-rip) stopped with status 3!

so it tries to use hpijs but did not find it.
i was thinking that hpijs was not needed with hplip.
i have a photosmart C3180
This task depends upon

Closed by  Andreas Radke (AndyRTR)
Wednesday, 05 August 2009, 18:25 GMT
Reason for closing:  Fixed
Comment by solsTiCe (zebul666) - Sunday, 05 July 2009, 17:38 GMT
a snippet of /var/log/cups/error_log
   error.log (21.2 KiB)
Comment by Andreas Radke (AndyRTR) - Sunday, 12 July 2009, 09:54 GMT
what ppd file is the driver using?
Comment by solsTiCe (zebul666) - Sunday, 12 July 2009, 11:15 GMT
how/where do i find this ?
is it not in the log i posted already ?
Comment by solsTiCe (zebul666) - Sunday, 12 July 2009, 11:37 GMT
i even tried with a hp Deskjet 5740 and i got the same problem.
either with the foomatic ppd or the other one ?

i can't print ! i can't believe i am the only one to have that problem..
Comment by solsTiCe (zebul666) - Sunday, 12 July 2009, 12:45 GMT
it works now.
i reinstalled all archlinux packages. pacman -S cups hplip foomatic-db ghostscript.

i don't know. may be it was because of an unclean shutdown some weeks ago after a power cut
/o\ sorry
Comment by David (alleluia20) - Monday, 03 August 2009, 15:53 GMT
  • Field changed: Percent Complete (100% → 0%)
I also had the same problem today (3 August 2009), and hplip was upgraded a couple of days ago. I solved the issue by reinstalling the same packages as the submitter mentioned, and then going to http://localhost:631, selecting the printer, and printing a test page.

So there are now two different people with the problem, so I think the bug is confirmed.
Comment by Roman Kyrylych (Romashka) - Monday, 03 August 2009, 15:54 GMT
Is this reported upstream?
Comment by David (alleluia20) - Monday, 03 August 2009, 19:22 GMT
I do not know, I do not find a bug tracking in the upstream. This search does not seem to yield any relevant result. On the other hand, if you google the problem you see a lot of results for different distros, so I should think that someone has already reported it upstream.

But I do not know, honestly.
Comment by Brian Hall (hallbw) - Monday, 03 August 2009, 21:00 GMT
I am having the same problem, but "pacman -S cups hplip foomatic-db ghostscript" and restarting cups didn't help.

For me, the problem appears to be a missing hpijs binary, I think it should be at /usr/bin/hpijs but doesn't seem to be there- locate and which don't find it either.

D [03/Aug/2009:16:57:16 -0400] [Job 583] sh: hpijs: command not found
D [03/Aug/2009:16:57:16 -0400] [Job 583] GPL Ghostscript 8.64: Can't start ijs server "hpijs"
Comment by David (alleluia20) - Monday, 03 August 2009, 22:35 GMT
@Brian: if you do as I said in my previous post: open the web browser, go to http://localhost:631, manage printers, I saw an error message on my printer about a missing PPD file. But then, after clicking on the printing and doing nothing else, the error message was gone. I could print the test page and then I could print the PDF I wanted to print at the beginning.
Comment by David (alleluia20) - Monday, 03 August 2009, 22:36 GMT
sorry, "after clicking on the PRINTER" (I think on the "properties" button, I am not sure)
Comment by Brian Hall (hallbw) - Tuesday, 04 August 2009, 00:14 GMT
I didn't have a problem with a missing PPD file. My problem was with a missing /usr/bin/hpijs.

However, a recent update via pacman an hour or so ago seems to have fixed this, it updated hplip to 3.9.6b-2.