Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#15351 - broken dependence readline6

Attached to Project: Arch Linux
Opened by Luis Sarmiento (donpicoro) - Friday, 03 July 2009, 00:06 GMT
Last edited by Roman Kyrylych (Romashka) - Friday, 03 July 2009, 00:15 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture x86_64
Severity Critical
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description: When upgrading firefox 3.0.8 to 3.5-1 it requires to update readline5 to readline6. If you do that blindly. You will end up with a not-working bash.

-bash: error while loading shared libraries: libreadline.so.5: cannot open shared object file: No such file or directory

Additional info:
* package version(s)
firefox 3.0.8
firefox 3.5-1
bash 4.0.024-1
bash (the installed from the USB image 2009.02)
* config and/or log files etc.
/lib/libreadline.so.6
/lib/libreadline.so.5
/lib/libhistory.so.6
/lib/libhistory.so.5

Steps to reproduce:
When upgrading firefox 3.0.8 to 3.5-1 it requires to update readline5 to readline6. If you do that blindly. You will end up with a not-working bash.
Every bash application will claim a wrong readline version.
-bash: error while loading shared libraries: libreadline.so.5: cannot open shared object file: No such file or directory
I could not login as root nor anything else. I manage to use the already root console (lucky me I didn't issue that with sudo)

and create a symlink from libreadline.so.5 to libreadline.so.6...
I though I was almost there but I got then a similar error for libhistory.so.5. And I create another symlink for it. And now I was able to login again.
-bash: error while loading shared libraries: libhistory.so.5: cannot open shared object file: No such file or directory

I realize that that should be a bash problem and I decided to go and notice that bash 4.0.024-1 depends on readline6. I upgraded bash, deleted the symlinks and went back to normal.

Bottomline: Include a bash upgrade dependence when upgrading readline to 6.
This task depends upon

Closed by  Roman Kyrylych (Romashka)
Friday, 03 July 2009, 00:15 GMT
Reason for closing:  None
Comment by Roman Kyrylych (Romashka) - Friday, 03 July 2009, 00:15 GMT
This is kind of duplicate of  FS#15335 .

> Bottomline: Include a bash upgrade dependence when upgrading readline to 6.
I don't think this is possible in pacman.
The fact is that it is bash that depends on readline, and there is no way to force upgrade of bash when upgrading readline
(unless old bash package would contain dependency on a specific readline version - then you would not be able to upgrade readline without upgrading bash too).
Comment by Gerardo Exequiel Pozzi (djgera) - Friday, 03 July 2009, 00:15 GMT
When you upgrade the system in parts (not with pacman -Syu) you need to know what are you doing to avoid these problems. This is because how dependencies are managed in Arch Linux.
Comment by xduugu (xduugu) - Friday, 03 July 2009, 00:15 GMT
You should always upgrade the whole system not only some packages. see  FS#15335 

Loading...