Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#15350 - [evolution-data-server] requires inexistent version of gnome-keyring

Attached to Project: Arch Linux
Opened by Roman Kyrylych (Romashka) - Thursday, 02 July 2009, 23:05 GMT
Last edited by Jan de Groot (JGC) - Friday, 03 July 2009, 06:45 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Architecture x86_64
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 6
Private No

Details

Description:

There is gnome-keyring-2.26.1-1 in Extra but evolution-data-server-2.26.3-1 in Extra x86_64 requires gnome-keyring>=2.26.3

The problem does not exist in Extra i686 because there is evolution-data-server-2.26.2-1 there which requires gnome-keyring>=2.26.1

Steps to reproduce:

on x86_64 do
$ sudo pacman -Syu
:: Synchronizing package databases...
testing is up to date
core is up to date
extra is up to date
community is up to date
:: Starting full system upgrade...
resolving dependencies...
error: cannot resolve "gnome-keyring>=2.26.3", a dependency of "evolution-data-server"
error: failed to prepare transaction (could not satisfy dependencies)
:: evolution-data-server: requires gnome-keyring>=2.26.3

This task depends upon

Closed by  Jan de Groot (JGC)
Friday, 03 July 2009, 06:45 GMT
Reason for closing:  Fixed
Additional comments about closing:  uploaded 2.26.3 a few minutes ago.
Comment by Jacob S (Gourdcaptain) - Friday, 03 July 2009, 02:30 GMT
Confirmed on x86_64.
Comment by Mihai Militaru (akephalos) - Friday, 03 July 2009, 03:46 GMT
The system with GNOME apps which require evolution-data-server cannot be upgraded because of this missing dependency. Confirmed.
Comment by Börje Holmberg (linfan) - Friday, 03 July 2009, 06:19 GMT
same here, too x86_64, not that I much long for the upgrade - hate the and get shivers from the mere mentioning of stupid messy crap gnome-keyring nuisance.

Loading...