Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#15301 - [windowmaker] install binary file under /usr/share

Attached to Project: Arch Linux
Opened by Gerardo Exequiel Pozzi (djgera) - Sunday, 28 June 2009, 21:48 GMT
Last edited by Isenmann Daniel (ise) - Sunday, 07 March 2010, 11:08 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Isenmann Daniel (ise)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description: windowmaker install ELF executable file "/usr/share/GNUstep/Applications/WPrefs.app/WPrefs". This file should be moved to another location outside /usr/share that is for architecture independent files [FHS].

Maybe a better location can be "/usr/lib/GNUstep/Applications/WPrefs.app/".

Additional info:
windowmaker-0.92.0-5
This task depends upon

Closed by  Isenmann Daniel (ise)
Sunday, 07 March 2010, 11:08 GMT
Reason for closing:  Fixed
Additional comments about closing:  Fixed in new package release.
Comment by Laszlo Papp (djszapi) - Saturday, 07 November 2009, 13:03 GMT
It's a proof of concept PKGBUILD, feel free to modify it, namcap gives back only perl warning because it's missing from depends line, but JGC told me not to include such an application from base group.
   PKGBUILD (1.4 KiB)
Comment by Isenmann Daniel (ise) - Monday, 21 December 2009, 06:11 GMT
I have fixed that in the windowmaker-crm-git package. Your PKGBUILD has an error, you must set the GNUstep dir to the new location, not only do an install command and delete the old directory.

I don't close this bug, because I'm waiting for a new official windowmaker release before closing this.
Comment by Isenmann Daniel (ise) - Tuesday, 26 January 2010, 12:15 GMT
I think there will be no new version in the near future. I will close this bug with an updated package for windowmaker asap.

Loading...