Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#15289 - [pcmanfm] segmentation fault

Attached to Project: Arch Linux
Opened by Simon (RonnyF) - Saturday, 27 June 2009, 21:48 GMT
Last edited by Jürgen Hötzel (juergen) - Saturday, 11 July 2009, 14:35 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jürgen Hötzel (juergen)
Architecture i686
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
When I type /usr/share/themes in the PCManFM adress bar, the programm quits and on the console, I see an error: "Speicherzugriffsfehler", german word for "segmentation fault".


Additional info:
package version(s): 0.5.1-1


Steps to reproduce: I reproduced this with sudo and as normal user, i tried other directories, some directories also crash, some do not. But i don't have any idea, what the crashing directorys have in common.
This task depends upon

Closed by  Jürgen Hötzel (juergen)
Saturday, 11 July 2009, 14:35 GMT
Reason for closing:  Won't fix
Additional comments about closing:  Also commited upstream
Comment by Gerardo Exequiel Pozzi (djgera) - Saturday, 27 June 2009, 22:56 GMT
  • Field changed: Summary (PcManFM segmentation fault → [pcmanfm] segmentation fault)
  • Field changed: Status (Unconfirmed → Assigned)
  • Task assigned to Jürgen Hötzel (juergen)
can you run under gdb and provide a backtrace? (need to compile pcmanfm with debug symbols)
Comment by Simon (RonnyF) - Sunday, 28 June 2009, 17:17 GMT
Sorry, I've tried that today about 2 hours in different ways but didn't get the job done.
But there are a lot of errors when i try to run "gcc -g main.c" in the src directory, you can see them here: http://nopaste.org/p/aeOZrnmipb

I hope, I could help.
Comment by Jürgen Hötzel (juergen) - Monday, 29 June 2009, 19:44 GMT
Couldn't reproduce. Please try this version (with debug info):
http://dev.archlinux.org/~juergen/pcmanfm-0.5.1-1-i686.pkg.tar.gz

Before starting pcmanfm. Use:
ulimit -c unlimited
so core gets dumped

Thanks
Comment by Simon (RonnyF) - Wednesday, 01 July 2009, 11:39 GMT
I tried it as you told me and the error was called "Speicherzugriffsfehler (Speicherabzug geschrieben)" in english: "Memory access violation (memory dumped)".
Comment by Jürgen Hötzel (juergen) - Wednesday, 01 July 2009, 11:51 GMT
Can you please attach or send me the core file?
Comment by Simon (RonnyF) - Wednesday, 01 July 2009, 14:29 GMT
I can't attach here, it's too big. How should I send it?
Comment by Jürgen Hötzel (juergen) - Wednesday, 01 July 2009, 17:46 GMT
Please gzip the file. This should shrink it pretty good. You can send it to me via eMail-Attachement.

Comment by Simon (RonnyF) - Wednesday, 01 July 2009, 18:42 GMT
I attached the gzipped file here, to make it available for everyone.
(application/x-gzip)    core.gz (781.8 KiB)
Comment by Jürgen Hötzel (juergen) - Wednesday, 01 July 2009, 21:14 GMT
Could you try a view without big icons (list view)
Comment by Simon (RonnyF) - Thursday, 02 July 2009, 15:51 GMT
Of course...
(application/x-gzip)    core2.gz (787.3 KiB)
Comment by Jürgen Hötzel (juergen) - Thursday, 02 July 2009, 19:18 GMT
There seems to be an issue about reference counting. Directory Icon:

{parent_instance = {g_type_instance = {g_class = 0x75565d86}, ref_count = 165644368, qdata = 0x9dfd550}, colorspace = GDK_COLORSPACE_RGB, n_channels = 0, bits_per_sample = 0, width = -1, height = 0, rowstride = 0, pixels = 0x0, destroy_fn = 0, destroy_fn_data = 0x0, has_alpha = 0}

ref_count = 165644368 is really obscure.

I tracked down an issue related to internal pixbuf loading. Please try the update:

http://dev.archlinux.org/~juergen/
Comment by Simon (RonnyF) - Thursday, 02 July 2009, 19:32 GMT
Thank you very much! The 0.5.1-2 seems to work so far, the old problem wasn't detected anymore:). Have I been the only one to have this problem?
Comment by Jürgen Hötzel (juergen) - Thursday, 02 July 2009, 19:36 GMT
Yes. Maybe you use a special theme?
Comment by Simon (RonnyF) - Friday, 03 July 2009, 18:11 GMT
Hmm, i don't think so, my themes seems to be normal;). It could be that my "GTK+-Symbolschema" isn't prepared in the right way anymore... But I don't mind, I'm happy now, that it works:). Thank you for the help.

Loading...