Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#15284 - cannot switch to ondemand governor

Attached to Project: Arch Linux
Opened by emrah nizam (emrahnzm) - Saturday, 27 June 2009, 08:48 GMT
Last edited by Jan de Groot (JGC) - Saturday, 27 June 2009, 12:12 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:
I have a Intel(R) Pentium(R) 4 CPU 2.66GHz
im using p4-clockmod with ondemand and performance governors, but after upgrading to kernel 2.6.30, i cannot switch to ondemand governor

from dmesg output i see:
"ondemand governor failed, too long transition latency of HW, fallback to performance governor"

Additional info:
kernel26 2.6.30-5

Steps to reproduce:
cpufreq-set -g ondemand
This task depends upon

Closed by  Jan de Groot (JGC)
Saturday, 27 June 2009, 12:12 GMT
Reason for closing:  Not a bug
Additional comments about closing:  http://git.kernel.org/?p=linux/kernel/gi t/torvalds/linux-2.6.git;a=commitdiff;h= 36e8abf3edcd2d207193ec5741d1a2a645d470a5
Comment by Samed Beyribey (ras0ir) - Saturday, 27 June 2009, 08:52 GMT
i can confirm this issue, there's a topic on the bbs related to this problem:
http://bbs.archlinux.org/viewtopic.php?id=74710
but it's not helpful.
Comment by Jan de Groot (JGC) - Saturday, 27 June 2009, 11:33 GMT
You should not use ondemand with clockmod. The clockmod module has a very high switching latency, that's why it's disabled in 2.6.30. The error message says it all I think.

Loading...