AUR web interface

**This is the bug tracker for the AUR web interface.**

Use this tracker to report bugs or make feature requests regarding the behaviour or implementation of the AUR software.
Please read the Reporting Bug Guidelines before filing a new task.
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

- Please report bugs related to Arch Linux official packages here: http://bugs.archlinux.org/index.php?project=1
- Please report bugs for [community] packages here: http://bugs.archlinux.org/index.php?project=5
- For any packages in the AUR contact the maintainer or leave a comment on the package's detail page.

Source Code:
https://projects.archlinux.org/aurweb.git/
Tasklist

FS#15265 - Remove comments from the AUR completely

Attached to Project: AUR web interface
Opened by Greg (dolby) - Friday, 26 June 2009, 00:29 GMT
Last edited by Loui Chang (louipc) - Friday, 26 June 2009, 01:38 GMT
Task Type Feature Request
Category Backend
Status Closed
Assigned To No-one
Architecture All
Severity Medium
Priority Normal
Reported Version 1.5.6.2
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

My suggestion is to remove the notify button and the comments. Add a box where the maintainer can add the notes that he feels might be useful to the users.
Discussion regarding the way the script builds the package, bugs, etc should be done between the interested party and the maintainer.
I dont see the need to add anything special to handle that. Like a "contact maintainer button".
If the user is too lazy to follow the maintainer link and then the link to his email, then he shouldnt be motivated enough to comment either.
If there is need for further discussion, the script is horribly outdated and unmaintained, should be done, like its done now, on the mailing list or the bbs.
This task depends upon

Closed by  Loui Chang (louipc)
Friday, 26 June 2009, 01:38 GMT
Reason for closing:  Won't implement
Additional comments about closing:  Silly idea. No way José.
This issue has already been discussed to death. If you have any specific ways that comments can be improved please file a new feature request. Good day!
Comment by Heiko Baums (cyberpatrol) - Friday, 26 June 2009, 00:38 GMT
Is it possible to remove the vote? I clicked on it accidentally.

I don't think, that this is a good idea. See my arguments in the thread "Removing comments from AUR" on the aur-general mailing list.
Comment by Angel Velasquez (angvp) - Friday, 26 June 2009, 01:27 GMT
The problem is, if the maintainer is a ... (I don't want to say slacker) lets say .. *slow* with the updates or fixing bugs.. but he is a dev or tu, and the users are more (dedicated) *quickest* than the maintainer and they might to add a comment on a package to say to the rest of the users something like "Dude this package shouldn't depend on bla" or "Dude let's apply this patch because of XXX bug" or "Dude this package doesn't build against the new gcc"

The fact is, sometimes a maintainer can be on "vacations" and maybe he won't be able to see their mails or fixing bugs, then should be fair than the community can be able to add a note on the package.

Just my opinion (as I expresed before on the ML).

Thanks
Comment by Greg (dolby) - Friday, 26 June 2009, 01:34 GMT
@Angel: Does your comment apply to the official packages as well? What if the developer (or the TU) is ...a slacker, what should the users do about that? (these are mostly rhetorical questions)
All those dude issues should be addressed to the maintainer by personal email.

Loading...