Community Packages

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#15179 - [cdemu-daemon] broken

Attached to Project: Community Packages
Opened by Papadopoulos, Mihail (scarecrow) - Saturday, 20 June 2009, 06:53 GMT
Last edited by Andrea Scarpino (BaSh) - Sunday, 21 June 2009, 10:20 GMT
Task Type Bug Report
Category
Status Closed
Assigned To Mateusz Herych (Partition)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
cdemu does not start after the last package upgrade

Additional info:
* package version(s)
1.1.0-3
* config and/or log files etc.
From /var/log/daemon.log

Jun 20 07:41:37 core2lin cdemud[7163]: open(/usr/var/run/cdemud.pid): No such file or directory
Jun 20 07:41:37 core2lin cdemud[7163]: Could not create PID file: No such file or directory.

Steps to reproduce: -

Apparently the daemon wants to create its PID to the nonexisting directory /usr/var/run
Creating this directory by hand does allow the daemon to start, but it should be fixed in a cleaner way.
This task depends upon

Closed by  Andrea Scarpino (BaSh)
Sunday, 21 June 2009, 10:20 GMT
Reason for closing:  Not a bug
Additional comments about closing:   FS#15192 
Comment by Christian Léger (EvilSnowball) - Saturday, 20 June 2009, 23:49 GMT
I had that issue as well. I've discovered that cdemu-daemon uses libdaemon to create its pidfile. So I added the --localstatedir=/var option on the ./configure line in libdaemon's PKGBUILD and recompiled. cdemud now creates the pidfile in /var/run and it works as normal again. I think the last update to the filesystem package (2009.01-1 -> 2009.01-2) might have triggered the problem as it removed the /usr/var directory from the filesystem...
Comment by Christian Léger (EvilSnowball) - Sunday, 21 June 2009, 00:46 GMT
I've created a new bug report (with solution) for the libdaemon package (#15192). That's where the problem really is.

Loading...