Pacman

Welcome to the Pacman bug tracker. Please search the current bugs and feature requests before filing a new one! Use advanced search and select "Search in Comments".

* Please select the correct category and version.
* Write a descriptive summary, background info, and provide a reproducible test case whenever possible.
Tasklist

FS#15143 - Move package to cache when installed with -U

Attached to Project: Pacman
Opened by Allan McRae (Allan) - Wednesday, 17 June 2009, 07:57 GMT
Last edited by Xavier (shining) - Monday, 14 September 2009, 08:02 GMT
Task Type Feature Request
Category General
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version 3.2.2
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Summary and Info:
I would find it useful if pacman moved/copied a local package to the pacman cache when installed with -U as many of the packages I install that way end up in a repo later. Then I need to redownload the package for use in chroots. Maybe let this be controlled by a configuration option?
This task depends upon

Closed by  Xavier (shining)
Monday, 14 September 2009, 08:02 GMT
Reason for closing:  Won't implement
Additional comments about closing:  better done manually :)
Comment by Dan McGee (toofishes) - Wednesday, 17 June 2009, 11:47 GMT
We do this for pacman -U <url> operations, so extending it to this seems logical. I'd accept a patch that does this.
Comment by Xavier (shining) - Wednesday, 08 July 2009, 12:24 GMT
I like this behavior for pacman -U <url> (imagine you just downloaded a 100mb package, you likely want to keep it stored somewhere on your system), but not for packages already on the filesystems because it duplicates them.

My second argument against this is that users sometimes do local rebuild of official packages, and maybe don't want to mix these packages with official ones in the cache (which could cause integrity check failures next time they upgrade their system).

Of course, if the behavior is configurable, I cannot argue, but I won't be the one implementing this :) Also it is easily done with a simple alias or script.
Comment by Allan McRae (Allan) - Wednesday, 08 July 2009, 12:44 GMT
The rebuilding of packages from the repos and subsequent integrity check issues convinced me that this is probably a bad idea.
Comment by Gavin Bisesi (Daenyth) - Sunday, 13 September 2009, 23:44 GMT
I agree, if the user wants the package in cache, it makes more sense (for a local file) to be moved there manually.

Loading...