Arch Linux

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#15057 - [lyx] Last update (3 days ago) make LyX very slow, especially when typing

Attached to Project: Arch Linux
Opened by Etienne Lepercq (guepe) - Thursday, 11 June 2009, 15:44 GMT
Last edited by Eric Belanger (Snowman) - Wednesday, 15 June 2011, 03:36 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Ronald van Haren (pressh)
Architecture i686
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No


I am using this LyX package for several month now without problems. I am using an aging P-M 1.8GHz laptop under Gnome, everything up to date (not from testing).
The last update made LyX very unresponsive, especially when typing: it takes 2-3 even 5 seconds to refresh text when typing. I didn't change anything related to LyX configuration: several thread s talks about this issue - dated from sept. - dec 2008 but has been solved.
This probably is not related to this problem.

But, I found this thread and comment from Vincenzo Ciancia talking about "compiling without assertions" and making LyX slow.

Do you know what compilations flags have been used, and what changed from last package update ? There must be a solution ! ;-)

Additional info:
* package version(s) : 1.6.3-1
* config and/or log files etc.

Steps to reproduce:
Type a text, it is very slow to refresh.
This task depends upon

Closed by  Eric Belanger (Snowman)
Wednesday, 15 June 2011, 03:36 GMT
Reason for closing:  Fixed
Additional comments about closing:  Bug is over a year old, also there are numerous new release of lyx. probably fixed.
Comment by Ronald van Haren (pressh) - Thursday, 11 June 2009, 18:16 GMT
you can see the PKGBUILD from the arch home page when searching the package (look for 'svn entries' or something), so you know next time. For now,

Compiler flags used:
./configure --prefix=/usr \
--with-frontend=qt4 --without-included-boost

before it was:
./configure --prefix=/usr \

I haven't looked if it happens for me too though, I'll do it when I have some time.

Comment by Etienne Lepercq (guepe) - Thursday, 11 June 2009, 18:38 GMT
Thank you for the tip, I learnt something !

Apparently just one flag has been added, --without-included-boost : I don't find anything problematic related to it.
If anyone has the same problem, please report, it should help finding cause of the problem. I didn't find any other slow-down on my laptop, so I think this might be related to LyX...
Comment by Eric Belanger (Snowman) - Friday, 17 July 2009, 19:35 GMT
Just tested on x86_64. Doesn't seem slow.

Ronald: Etienne mentioned compilations flags not configuration flags (unless he meant configuration flags)
Comment by Ronald van Haren (pressh) - Saturday, 18 July 2009, 12:10 GMT
o ic. compilation flags are the same as previous versions, just the ones defined by a clean chroot installation.

I've tested it on both my desktop (x86_64) and my laptop (i686), doesn't seem slow here either.

Etienne: is this still an issue?
Comment by Etienne Lepercq (guepe) - Tuesday, 21 July 2009, 18:26 GMT
I still have a slow responsiveness of LyX but after more use, only when erasing text !

It seems more an issue with LyX, but I am surprised. Still, as you said, the only flag that has changed is related to configuration flags and not compilations one.
It may be related to another lib. I'll try seeking with LyX community.
Comment by Ronald van Haren (pressh) - Monday, 27 July 2009, 17:51 GMT
Have you had any response from the LyX community yet?
Comment by Etienne Lepercq (guepe) - Monday, 10 August 2009, 19:21 GMT
It has already been reported :
Comment by Ronald van Haren (pressh) - Monday, 02 November 2009, 22:32 GMT
there hasn't been a lot of activity in the bug upstream for the last few months. Just wondering if it is still an issue with the latest xorg release?
Comment by Etienne Lepercq (guepe) - Wednesday, 04 November 2009, 14:43 GMT
Yes, still have very slow selections, typing, ... I really think this is related to LyX code and not a dependancy (see upstream bug).
Comment by Laszlo Papp (djszapi) - Sunday, 06 December 2009, 18:49 GMT
status of it ?
Comment by Ronald van Haren (pressh) - Sunday, 06 December 2009, 20:26 GMT
status of it is that it is still not resolved upstream. The bug remains open to track upstream progress (if any)
Comment by Thomas Dziedzic (tomd123) - Wednesday, 16 June 2010, 04:05 GMT
Comment by Etienne Lepercq (guepe) - Wednesday, 16 June 2010, 15:16 GMT
Bug report is available here :
I have compiled LyX in debug mode and tracked what takes so much CPU. I uploaded the valgrind trace but nobody seemed interested…

And that is almost everything "new" :-(
Comment by Etienne Lepercq (guepe) - Monday, 21 June 2010, 15:39 GMT
I tried to reproduce the bug with the latest trunk (several month after 1.6 release) and the bug is not reproduceable anymore ; I think 2.0 will not have such bug ;-)