Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#1500 - imagemagick 6.0.8-1 conflicts with libtool

Attached to Project: Arch Linux
Opened by Damir Perisa (damir.perisa) - Tuesday, 21 September 2004, 21:26 GMT
Last edited by Judd Vinet (judd) - Wednesday, 22 September 2004, 16:03 GMT
Task Type Bug Report
Category Packages: Current
Status Closed
Assigned To dorphell (dorphell)
Architecture not specified
Severity High
Priority Normal
Reported Version 0.7 Wombat
Due in Version Undecided
Due Date Undecided
Percent Complete 0%
Votes 0
Private No

Details

automake-1.9.2-1 [################] 100% 298K 56.4K/s 00:00:05
imlib2-1.1.2-1 [################] 100% 386K 58.5K/s 00:00:06
libtool-1.5.10-1 [################] 100% 513K 64.1K/s 00:00:08

checking package integrity... done.
loading package data... done.
checking for file conflicts...
error: the following file conflicts were found:
usr/lib/libltdl.a: exists in "imagemagick" (target) and "libtool" (target)
usr/lib/libltdl.la: exists in "imagemagick" (target) and "libtool" (target)
usr/lib/libltdl.so: exists in "imagemagick" (target) and "libtool" (target)
usr/lib/libltdl.so.3: exists in "imagemagick" (target) and "libtool" (target)
usr/lib/libltdl.so.3.1.0: exists in "imagemagick" (target) and "libtool" (target)
/usr/lib/libltdl.a: exists in filesystem
/usr/lib/libltdl.la: exists in filesystem
/usr/lib/libltdl.so: exists in filesystem
/usr/lib/libltdl.so.3: exists in filesystem
/usr/lib/libltdl.so.3.1.0: exists in filesystem


errors occurred, no packages were upgraded.

[root@Asteraceae damir]#
This task depends upon

Closed by  dorphell (dorphell)
Wednesday, 22 September 2004, 18:35 GMT
Reason for closing:  Fixed
Comment by Damir Perisa (damir.perisa) - Tuesday, 21 September 2004, 21:27 GMT
Targets: automake-1.9.2-1 imagemagick-6.0.8-1 imlib2-1.1.2-1 libtool-1.5.10-1
Comment by Tobias Powalowski (tpowa) - Wednesday, 22 September 2004, 10:11 GMT
i used -f option to install
Comment by Damir Perisa (damir.perisa) - Wednesday, 22 September 2004, 10:38 GMT
forcing is not a solutoin, but a workaround ;-)

i assume that one of these 2 pkgs must be rebuilt against the newer other one
Comment by Damir Perisa (damir.perisa) - Wednesday, 22 September 2004, 12:01 GMT
and with koffice - *shit*

now, we need to find out, what pkg should have them
Comment by Tobias Kieslich (tobias) - Wednesday, 22 September 2004, 13:52 GMT
my guess is that the files are in the imagemagick package for whatever reason, but should be only part of libtool, as they zhave ever been.
Comment by Judd Vinet (judd) - Wednesday, 22 September 2004, 16:03 GMT
I believe those files have been in libtool for some time now. It's probably imagemagick's fault.
Comment by dorphell (dorphell) - Wednesday, 22 September 2004, 18:35 GMT
Strange that imagemagick included this out of the blue.

Loading...