Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#14963 - [colortail] failing (maybe gcc related)

Attached to Project: Arch Linux
Opened by patrick (brisbin33) - Friday, 05 June 2009, 15:40 GMT
Last edited by Eric Belanger (Snowman) - Monday, 07 December 2009, 00:40 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Douglas Soares de Andrade (dsa)
Architecture x86_64
Severity Very Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
colortail in extra fails to run on [at least] x86_64. i'm not sure, but it may be related to gcc 4. checking the PKGBUILD in abs shows it's patched for gcc3. i tried applying a gcc4 patch from http://bugs.gentoo.org/122022 [attached] but it won't build (could be simple operator error).

i humbly request that if the maintainer (Eric Belanger), or whoever, can get it to build with the gcc4 patch, and if that magically fixes it, that our package in extra be updated to use this patch.

thanks.

Additional info:
* package version(s)
colortail 0.3.0-2
gcc 4.4.0-3

Steps to reproduce:
install extra/colortail on x86_64
`colortail -k /etc/colortail/conf.messages /var/log/errors.log`
view errors [attached]

PS: i think i'm fairly competent but still learning (1 year w/ arch) and i apologize if any assumptions i've made are wrong :)
This task depends upon

Closed by  Eric Belanger (Snowman)
Monday, 07 December 2009, 00:40 GMT
Reason for closing:  Works for me
Additional comments about closing:  I updated colortail to 0.3.2-1 and it works fine.
Comment by Baho Utot (baho-utot) - Saturday, 13 June 2009, 23:02 GMT

I have had problems compliing in i686

This patch worked for me
Comment by patrick (brisbin33) - Saturday, 13 June 2009, 23:41 GMT
Baho, you're patch also got it to build on my x86_64, thank you. sadly it did not fix the error, failed identically as before. if it works for you (and everyone else) maybe it's something on my setup.
Comment by Jan de Groot (JGC) - Sunday, 16 August 2009, 22:20 GMT
Builds fine again, but the resulting binary on x86_64 aborts with an invalid pointer.
Comment by patrick (brisbin33) - Tuesday, 18 August 2009, 20:05 GMT
confirmed, just upgraded to 0.3.0-3 and it fails the same way.
Comment by Laszlo Papp (djszapi) - Saturday, 07 November 2009, 16:26 GMT
colortail 0.3.0-3 works here.

Loading...