Arch Linux

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#14940 - [okular] has Digitial Restrictions Management (DRM) enabled by default

Attached to Project: Arch Linux
Opened by Devin Cofer (Ranguvar) - Wednesday, 03 June 2009, 16:20 GMT
Last edited by Jan de Groot (JGC) - Monday, 08 June 2009, 13:38 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Pierre Schmitz (Pierre)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No


The Okular document viewer/reader in the kdemultimedia package by default restricts the user's ability to freely manipulate shared PDF files. The option to change this behavior is not too deeply buried in the settings, but Okular does not make it obvious that the behavior can be altered at all.

Additional info: (KDE dev) (Okular/KPDF dev)

Steps to reproduce:
Download a DRM-encumbered PDF from the Internet or otherwise obtain one, and attempt to copy text from it.

I propose that Arch Linux modify the PKGBUILD and build with the "-DOKULAR_FORCE_DRM" compile-time setting off, which (I believe) will modify the default setting to not honor Restrictions Management. In the case that this actually disables DRM and the option to turn it back on, there is a patch in the referenced Debian bug page to modify the default.

While users should have the ability to enable DRM if they want it (!?), restrictions that are not mandatory or forced upon those who create PDF software should not be by default enabled. This seems fairly simple to me -- if you don't have to honor such ridiculousness as DRM, don't (at least by default, or worst case make it very clear to the user that they can turn off this behavior), and it's a tiny modification.
This task depends upon

Closed by  Jan de Groot (JGC)
Monday, 08 June 2009, 13:38 GMT
Reason for closing:  Upstream
Additional comments about closing:  Ask upstream to disable it by default.
Comment by Jan de Groot (JGC) - Thursday, 04 June 2009, 07:25 GMT
Reading through the debian bug I see they don't disable it by default, because:
- It's the specification, complain to Adobe or the author of the document if you feel limited in freedom
- It's shipped with enabled as default option upstream

Though "DRM" limits your freedom, this is just a piece of software that follows the specification. The software even gives you the choice to disable it, so I don't see why enabling it by default limits your freedom.
Comment by Devin Cofer (Ranguvar) - Monday, 08 June 2009, 11:19 GMT
"It's the specification, complain to Adobe or the author of the document if you feel limited in freedom"
I don't know of any other PDF reader besides Adobe's that honors the DRM flag. Maybe Foxit, but I'm not sure. The spec itself only says PDF readers should make a "reasonable effort" to support DRM. I think leaving it as an option (off by default) is reasonable, obviously the makers of evince, epdfview, xpdf, Sumatra, etc. are fine not doing anything at all :)

My argument is that the dialog box telling you that you've been stopped from manipulating the PDF in ways the "owners" don't want you to gives no mention of the fact that you can disable this behavior, and that having DRM enabled by default is not necessary at all -- users should not be restricted if there is no need.
Comment by Jan de Groot (JGC) - Monday, 08 June 2009, 11:50 GMT
If there wasn't need, this wouldn't have made it into the specification anyways.

Point is, this discussion is going the same as the one you linked to on the debian list. Some users thinking they need more freedom by a default option, and maintainers thinking the default should be as intended upstream.
Comment by Alessandro Doro (adoroo) - Monday, 08 June 2009, 12:57 GMT

Are you saying that xpdf doesn't respect the specification?
> The Xpdf package honors these permission settings. Specifically:
> I won't help these people because I believe that an author's requests relating to the use of his/her work should be honored.

If other viewers "are fine not doing anything at all" they are really flawed.

I think that every pdf reader should respect the author's whishes.
If you don't agree you can build the package yourself.
And if you really want to cheat there is a ps/pdf interpreter in your system. Play with that but, at least, think you're doing something wrong.